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Adding Stop Point 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "File -> Open" menu to open a file, into which the Stop (color change) point is going to be inserted. 
3 - Click "Freehand Select Mode" button. (Picture No. 1).  

Picture No. 1  

   

4 -  In the Freehand Select Mode, select an area (see also Interactive Free-Hand Splitting), which will follow 
the Stop point in the new design. In this example, it is "b" character. Once you have selected the area, click 
"Split" button to separate selected red stitches into a new object (Picture No. 2).  

Picture No. 2  

   

5 - Now you can see that there are two objects in "Object Order Bar" at the right side of the screen. Near 
each object there is a small box containing the colors of the object. Double-click left mouse button on the box 
containing the color which you want to change (Picture No. 3). 
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Picture No. 3 

  

6 - Choose the new color in the dialog box that appears on the screen.  (Picture No. 4). Click "OK" button to 
confirm the new color.    

Picture No. 4 

  

7 - Now you can see in "Object Order Bar" at the right side of the screen that the objects have different 
colors. This means, that the Stop (color change) point will be inserted into the final design. 
8 - Use "File -> Save As" command to save the whole design to a file on your disk. (Picture No. 5).  Specify 
the format and the file name of the new design in the dialog boxes which appear on the screen.  

Picture No. 5 
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Auto-Split 

This tutorial explains how to use the Auto-Split command in Editor. This command will automatically split 
selected objects into parts, while taking into account the maximum prescribed size, maximum prescribed color 
count or maximum prescribed stitch count.  

Note: Other ways of splitting are explained in the following tutorials: Auto-Split Along Hoop Boundaries, 
Interactive Free-Hand Splitting, Split Before/After Color, Separate Color, Using Initial and Ending Stitch Boxes 
and Saving and Sewing of Split Designs.  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design you want to auto-split by selecting "File -> Open" menu (Picture No. 1).  

Picture No. 1  

 

3 - Click "Edit -> Auto-Split" menu to split the selected objects (lettering "EMBIRD" in this example). A dialog 
box will appear on the screen, allowing you to specify the maximum size of each part - for example, 100 x 
100 mm to fit the standard hoop. Select "OK" in this dialog box to continue with splitting (Picture No. 2).  

Picture No. 2  

 

4 - After a while, Embird will finish automatic splitting of the design. When you look at the "Object Order Bar" 
at the right side of the screen, you will see there that the lettering "EMBIRD" was automatically split into 3 
parts: "EM", "BI" and "RD" (Picture No. 3). 
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Picture No. 3 

 

5 - In this example, we have moved each part to show you how the original design was split (Picture No. 4).  

Picture No. 4 

 

6 - Finally, save each object to a separate file on your hard disk. Use "File -> Save Separated As" command 
(see also Tutorial Splitting - Saving and Sewing of Split Designs). Specify the format and the file name of the 
new design in the dialog boxes which appear on the screen.  
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Auto-Split Along Hoop Boundaries 

The following tutorial explains how to automatically split a large design in accordance with boundaries of 
sewing areas in overlapped hoops (e.g. Brother Jumbo Hoop, Viking Plus Hoop, Janome GigaHoop, Janome 
Macro Hoop, Giant Hoop-It-All™, etc.). 
 
Note: Other ways of splitting are explained in the following tutorials: Interactive Free-Hand Splitting, Split 
Before/After Color, Separate Color, Using Initial and Ending Stitch Boxes, Auto-Split and Saving and Sewing of 
Split Designs. 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select the "File -> Open" menu to open a file which you want to split for overlapped hoop (Picture No. 1).  
3 - In this example, the design will be split for "Brother Jumbo Small Hoop", therefore select this hoop in 
"Options -> Hoop Size" menu.  

Picture No. 1  

 

4 - Click the "Edit -> Auto-Split" menu to automatically split the selected object. The "Maximum Size" dialog 
box will appear on the screen. Set the "Split in accordance with hoop boundary" option to ON and then click 
"OK" button to continue (Picture No. 2). 

Picture No. 2  
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5 - Another dialog box will appear on the screen, inquiring whether you want to separate objects before 
splitting them in accordance with hoop boundary (Picture No. 3). This process might help to avoid the 
disruption of separable objects. In this example, the whole design is in fact a single solid object, so click "No" 
button to skip the "separate" process. Another example is shown below, explaining the meaning of the "Yes" 
(separate) option. 

Picture No. 3 

 

6 - After a short while, the design will be automatically split into two parts (Picture No. 4). The upper part lies 
in the top (red) section of the hoop, the bottom part lies in the bottom (blue) section of the hoop. 
7 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the "Babylock, Bernina, Brother .PES" format.  
 
Note: All the design parts will be automatically combined and saved into a single .PES file on the hard disk. If 
you want to save each part into a separate file, choose the "Babylock, Bernina, Brother .PEC" format" in the 
"Choose Format" dialog box in step 6.  

Picture No. 4 

 

8 - Once the design parts are saved, you can check the results of the auto-split function. Click "Edit -> 
Deselect All" menu to cancel the selection of objects. Then move the mouse pointer to the upper object, 
depress the left mouse button and move the mouse to change the position of the upper object.  You can see 
how the design was split along the boundary of the top (red) section of the hoop (Picture No. 5). 
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Picture No. 5 

 

9 - The meaning of the separate process (which was offered during the auto-splitting procedure in step 5 
above) can be explained on another design consisting of separable objects (Picture No. 6). 

Picture No. 6 

 

10 - Select "Edit -> Auto-Split" menu and click "Yes" button in the dialog box which inquires about the 
separation (Picture No. 7). 
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Picture No. 7 

 

11 - After a short while, the design will be automatically split into two parts, both without disruptions 
(Picture No. 8). Compare these results with those shown in Picture No. 9, which were obtained without 
separating objects. The bottom part is disrupted, because some of its stitches (those which midpoints lie in 
the red section of the hoop) were included to the upper part. 

Picture No. 8 

 

Picture No. 9 
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Barudan CF Card - Reading Files 

Use this command if you want to read designs from Barudan CF (Compact Flash) Card. It is supposed, that 
you have the CF Card Reader hardware attached to your PC, and that this reader works like another disk drive 
on your PC (e.g. drive F:).  
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select "Right Panel -> Input/Output Operations -> Barudan CF Card" command from the main menu 
(Picture No. 1).  

Picture No. 1  

 

3 - A dialog box will appear on the screen (Picture No. 2). Choose the "Drive:" which contains Barudan CF 
Card. In this example it is "F:" drive. The upper box shows the folders and files of  Barudan CF Card.  
4 - In the "Folder:" box select (double-click) the folder containing designs which you want to read from CF 
Card (arrow 1 in Picture No. 2). In this example we have selected "Embird.fdr" folder. 
5 - In the "Files:" box select the files you want to read from CF Card (arrow 2 in Picture No. 2). To select a 
design, please move the mouse pointer to its file name and click the left mouse button. You can select 
multiple files: Move mouse pointer to the file name of the first design in the "Files:" box at the right side of 
the screen, depress the left mouse button and hold it down while moving the mouse pointer over the file 
names of the other designs. When the mouse pointer is over the last design, please release the left mouse 
button. In this example we have selected all the files stored in the "Embird.fdr" folder. 
6 - Click "Read selected files from card" button to read selected files from CF Card (arrow 3 in Picture No. 2).  

Picture No. 2  
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7 - Another dialog box will appear on the screen (Picture No. 3). Choose the format in which the designs 
imported from Barudan CF Card will be saved to your hard disk. Click "OK" button to continue. 

Picture No. 3 

 

8 - Embird will read the files from Barudan CF Card, convert them 'on-the-fly' to chosen format and save to 
the hard disk to currently chosen Right Panel's drive and folder. When finished, it will display the result of this 
operation (Picture No. 4). Click "OK" button to continue.  

Picture No. 4 

 

9 - Finally, the imported designs will be shown on the screen; they are stored in the right panel's "Files:" box 
(Picture No. 5).  

Picture No. 5 
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Barudan CF Card - Writing Files 

Use this command if you want to write designs to Barudan CF (Compact Flash) Card. It is supposed, that you 
have the CF Card Reader hardware attached to your PC, and that this reader works like another disk drive on 
your PC (e.g. drive F:).  
 
1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen select the design which you want to write to Barudan CF 
Card. To select a design, please move the mouse pointer to its file name and click the left mouse button 
(Picture No. 1). You can select multiple files: Move mouse pointer to the file name of the first design in the 
"Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving the 
mouse pointer over the file names of the other designs. When the mouse pointer is over the last design, 
please release the left mouse button.  

Picture No. 1  

   

3 - Select "Right Panel -> Input/Output Operations -> Barudan CF Card" command from the main menu 
(Picture No. 2).  

Picture No. 2  

 

4 - A dialog box will appear on the screen (Picture No. 3). Choose the "Drive:" which contains Barudan CF 
Card. In this example it is "F:" drive. The upper box shows the folders and files of  Barudan CF Card (empty 
card in this example).  
5 - Click "Create new folder" button to create a new folder for the designs and choose this folder in the 
"Folder" box. In this example we have created "Embird.fdr" folder (see below in Picture No. 4). 
6 - The bottom box shows the files which you are going to write to the card (Picture No. 3). Click "Write files 
to card" button to start writing of designs to the card. 
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Picture No. 3 

 

7 - Embird will write the files to Barudan CF Card and it will display the result of this operation (Picture No. 4). 
In this example, the "PORSCHE.U01", "PORSCHE.U02" and "SQUIRREL.U03" designs were written to the card. 
The corresponding files with .EDR extension contain the Embird color palette for these designs.  

Picture No. 4 

 

8 - Barudan CF Card is now ready for use. You can eject it from the disk drive and use it with your 
embroidery machine. 
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Change Stitch Type 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design using "File -> Open" command. In this example, we want to change the type of stitch 
connecting "A" and "B" letters. Now it is jump (floating) stitch, drawn as dashed line, and we want to change 
it to normal (running) stitch (Picture No. 1).  

Picture No. 1  

 

3 - Zoom in the lettering using "View -> Zoom -> In" menu (arrow 1 in Picture No. 2). You can use this menu 
several times to zoom in the characters to the comfortable size. The "Zoom In" command is also accessible 
via "Ctrl + Pg Up" keyboard shortcut.  
4 - Click "View -> Stitch Direction" menu to switch on the displaying of stitch direction (arrow 2 in Picture 
No. 2).  

Picture No. 2  

   

5 -  A small arrow drawn in the midpoint of every stitch will simplify the stitch selection process (Picture 
No. 3).  

Picture No. 3  
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6 - Select the stitch between "A" and "B" characters using the "Freehand Select Mode" . More information 
regarding the stitch selection is available in Interactive Free-Hand Splitting tutorial. A stitch is selected if its 
midpoint lies inside the selection polygon. Selected stitch is drawn in red color  (Picture No. 4). 

Picture No. 4 

 

7 - Another way of stitch selection is to use the "Sew Simulator". More information regarding simulator is 
available in Sew Simulator tutorial. Select "View -> Sew Simulator" menu and its window will appear on the 
screen. Click "Halt on floating stitch (Jump)" button to pause the simulation on every jump stitch (arrow 1 in 
Picture No. 5). Push "Play" button to start the simulation (arrow 2). The simulation will stop on the occurrence 
of jump stitch - it is the stitch no. 274 in this example, as you can see it in Picture No. 5. Once the stitch no. 
is known, close the simulator window by clicking "Close" button. Enter the stitch no. to "Initial Stitch" (arrow 
3) and "Ending Stitch" (arrow 4) boxes located at the top of Editor window (Picture No. 6). This will select the 
stitch no. 274 and enable further operations. 

Picture No. 5 

 

Picture No. 6 
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8 - Once you have selected the right stitch, select "Edit -> Stitch Type" menu. A dialog box will appear on the 
screen, allowing you to specify the new stitch type. In this example, we want to change the jump to running 
stitch (Picture No. 7). Click "OK" button to continue.  

Picture No. 7 

 

9 - Check the result of the operation. The jump stitch between "A" and "B" characters has changed to running 
stitch, which is drawn as solid line (Picture No. 8).  

Picture No. 8 

 

10 - Use "File -> Save As" command to save the modified design to a file on your disk. Specify the format and 
the file name of the new design in the dialog boxes which appear on the screen. 

Note: You can insert also the stop point into the design using the steps shown above. Select the stitch after 
which you want to place the stop point (see step 6). Select "Edit -> Stitch Type" menu and choose "Stop 
(color change)" option in the dialog box that appears on the screen. 
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Changing Character Proportions 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Text" menu or "Insert -> Font Engine Text" menu (Picture No. 1).   

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen. In the "Plug-in" box choose the alphabet which will 
be used for text characters. 
4 - Type your text into the "Text" box and click "Character Proportions" button located at the right side of the 
"Plug-in" box (Picture No. 2).  

Picture No. 2  

   

5 - The "Character Proportions" dialog box will appear on the screen (Picture No. 3). In this example, we have 
increased the size of upper case lettering (+50%), and also the size of numbers (+100%). Click "OK" button 
to confirm these changes. 

Picture No. 3 
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6 - Click "OK" button in the "Insert Text" dialog box to create the text. The specified character proportions are 
taken into account (Picture No. 4).   

Picture No. 4 

   

7 - In case you would like to delete the new character proportion settings, click "Set default values" button in 
the "Character Proportions" dialog box (Picture No. 5). The size of characters and numbers turn back to their 
default values. Confirm these changes by clicking "OK" button.  

Picture No. 5  

 

8 - Click "OK" button in the "Insert Text" dialog box to create the text. Then you can compare the first text 
with the second text below, which was created with default character proportion settings (Picture No. 6).  

Picture No. 6  
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Color and Palettes 

1 - Run "Embird", it will start in "Manager" mode. 
2 - Use "Drive", "Folder" and "Files" boxes (located on the Right Panel at the right side of the screen) and 
choose the folder with embroidery designs, e.g. "C:\EMBIRD32\FILES" folder in this example. In case you are 
using Embird 2006 or later, you will find some free designs in "C:\Program Files\EMBIRD32\FILES" folder. 
3 - Double click the file name of the design which you want to display. It will appear on the preview area. 
Below this area there is a bar which contains boxes with design colors. 
4 - Move mouse pointer to the box containing color which you want to change and double click the left mouse 
button. (Picture No. 1).  

Picture No. 1  

 

5 - You can select the new color in the dialog box which appears on the screen. There are several possibilities 
how to choose the new color: Either from the "Basic color" boxes (at the left side of the screen), in "Color 
spectrum" box (in the middle of the screen) or from "Color bar" (at the right side of the screen). There is also 
possibility to type numbers into "Red, Green, Blue" boxes if you want to choose color with known R, G, B.  
6 - After choosing your new color, click "Add to Custom Colors" button. The new color appears in "Custom 
colors" box (Picture No. 2). Then click "OK" button to confirm the selection.      

Picture No. 2  

 

7 - The new color will appear in the box, but not in the design. The color changes must be applied - click the 
"Apply Color Changes"  button located below color boxes (Picture No. 3). 

Picture No. 3 
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8 - Now, you should see differences between the design with previous color (Picture No. 1) and new color 
(Picture No. 4). The brown color of squirrel's cob has changed to the yellow one. 
9 - Repeat steps 4 ~ 7 if you want to change an other design color or color of the background. 
10 - The color changes are not permanent unless you save the new color palette. If you want to discard the 
color changes and restore previous colors, click "Restore Color Palette" button.  
11 - Click "Save Color Palette" button if you want to save the new color palette (Picture No. 4).   

Picture No. 4 

 

12 - Specify the folder and the file name of the palette file in the dialog box which appears on the screen 
(Picture  No. 5). It is recommended to save the color palette to the same folder and with the same file name 
as corresponding design, just change the extension to .EDR.  

Note:  Tajima DST file cannot store the color palette, this palette must be saved into a separate file. So, we 
added a support for a file with the .EDR extension. If you have the SQUIRREL.DST file and save the color 
palette, it will be stored in the SQUIRREL.EDR file (unless you change its name). The option in "Options -> 
Support Palette Files" menu must be ON, otherwise the .EDR files are not taken into account by Embird. Open 
"Help -> Contents -> Color Palette Menu" for more information about .EDR extension.   

Picture No. 5  

 

13 - After saving, when you double click on the file name of the design (SQUIRREL.DST), it will be displayed 
with the new color palette (Picture  No. 6).  

Picture No. 6  
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Converting Designs 

1 - Run Embird.  
2 - Select the designs which you want to convert in the "Files:" box at the right side of the screen (Picture No. 
1). To select the designs, please move mouse pointer to the file name of the first design ("DACHSHND.DST" 
in this example), depress the left mouse button and hold it down while moving the mouse pointer over the file 
names of the other designs. When the mouse pointer is over the last design ("SNAIL.DST" in this example), 
please release the left mouse button.  

Picture No. 1  

 

3 - Select "Right Panel -> Convert Files" menu to convert the selected files (Picture No. 2).   

Picture No. 2  

 

4 - A dialog box will appear on the screen, allowing you to choose the target design format (Picture No. 3). 
Specify the format by clicking on appropriate radio button (e.g. Viking Husqvarna .HUS) and click "OK" button 
to continue with file conversion. 
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Picture No. 3 

 

5 - The conversion process will start and last for a while. Once it is finished, the converted files will be stored 
in the same folder, as the source files - see the list in "Files:" box at the right side of the screen, it contains 
the new .HUS files (Picture No. 4).  

Picture No. 4 
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Convert To Stitches (1 color) 

Use "Image -> Convert To Stitches (1 color)" command in Editor to automatically convert the image into 
stitches. 
 
Note: This command does not work the same way as Sfumato Stitch plug-in. Sfumato Stitch plug-in 
generates stitches from color photos using different, more sophisticated algorithm. Also, this command is not 
"auto-digitizing" and it does not replace Embird Studio, which offers true digitizing possibilities.  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the image by selecting "Image -> Open" menu (Picture No. 1).  

Picture No. 1  

 

3 - Resize the image by running "Image -> Set Size" command from the main menu. In this example, we 
want the design to fit the standard 100 x 100 mm hoop (Picture No. 2).  

Picture No. 2  

 

4 - Adjust the image parameters by selecting "Image -> Adjust" command in the main menu (Picture No. 3). 
In this example we have increased the contrast by 20%. 
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Picture No. 3 

 

5 - Run "Image -> Convert To Stitches (1 color) command from the main menu. A dialog box will appear on 
the screen, allowing you to choose the "details" setting and to enable/disable the stitch filter (Picture No. 4). 
Click "OK" button and wait until Embird creates the stitches.  

Picture No. 4 

 

6 - Save the new design to a file on your hard disk using "File -> Save As" command. Specify the format and 
the file name of the new design in the dialog boxes which appear on the screen. 
7 - Click "Manager" menu to switch back to Manager window. Check the design by double-clicking its filename 
in the "Files:" box (Picture No. 5).  

Picture No. 5 
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Convert To Stitches (4 colors) 

Use "Image -> Convert To Stitches (4 colors)" command in Editor to automatically convert the color image 
into stitches. The design will always have only 4 colors - red, yellow, blue and black. 
 
Note: This command does not work the same way as Sfumato Stitch plug-in. Sfumato Stitch plug-in 
generates stitches from color photos using different, more sophisticated algorithm. Also, this command is not 
"auto-digitizing" and it does not replace Embird Studio, which offers true digitizing possibilities.  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the image by selecting "Image -> Open" menu (Picture No. 1).  

Picture No. 1  

 

3 - Resize the image by running "Image -> Set Size" command from the main menu. In this example, we 
want the design to fit the standard 100 x 100 mm hoop (Picture No. 2).  

Picture No. 2  

 

4 - Adjust the image parameters by selecting "Image -> Adjust" command in the main menu (Picture No. 3). 
In this example we have increased the contrast by 30%. 
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Picture No. 3 

 

5 - Run "Image -> Convert To Stitches (4 colors) command from the main menu. A dialog box will appear on 
the screen, allowing you to choose the "details" setting and to enable/disable the stitch filter (Picture No. 4). 
Click "OK" button and wait until Embird creates the stitches.  

Picture No. 4 

 

6 - Save the new design to a file on your hard disk using "File -> Save As" command. Specify the format and 
the file name of the new design in the dialog boxes which appear on the screen. 
7 - Click "Manager" menu to switch back to Manager window. Check the design by double-clicking its filename 
in the "Files:" box (Picture No. 5).  

Picture No. 5 
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Copying Files 

The following tutorial explains how to copy files with Embird from hard disk to removable USB key memory. 

Note: Another way of copying files is explained in Co-operation with Total Commander tutorial.  

1 - Run Embird, it will start in "Manager" mode.  
2 - Select the designs which you want to copy in the "Files:" box at the right side of the screen (Picture No. 
1). To select the designs, please move mouse pointer to the file name of the first design ("CAMPANUL.DST" in 
this example), depress the left mouse button and hold it down while moving the mouse pointer over the file 
names of the other designs. When the mouse pointer is over the last design ("EVA.DST" in this example), 
please release the left mouse button. If you want to add another file to the selection, depress the CTRL key 
on the keyboard and click the file name ("CHAIR.DST" and "MOOSE.DST" in this example). 

Picture No. 1  

 

3 - Click "Right Panel -> Copy Files to Clipboard" menu to copy the selected files to the clipboard 
(Picture No. 2). 

Picture No. 2 

 

4 - Connect the USB memory key to the PC and click the "Refresh" button to update the contents of the 
"Drive:" box, otherwise Embird might not recognize the new disk drive. In this example, the USB memory key 
is recognized as "E:" disk drive and the "Emb_File" folder is chosen in "Folder:" box as the destination folder 
(Picture No. 3).  
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Picture No. 3 

 

5 - Click "Right Panel -> Paste Files from Clipboard" menu to write the files from clipboard to chosen folder 
(Picture No. 4). 

Picture No. 4 

 

6 - The copy operation will start and when it is finished the files appear in the "Files:" box (Picture No. 5). 

Picture No. 5 
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Co-operation with DP Cross Stitch Software 

Embird Plus v. 7.20 and above can co-operate with DP Cross Stitch Software, release 1.32 and above. This 
software is developed by DP Software company and it allows you to create cross stitch designs. More 
information, demo, registration and support for DP Cross Stitch Software are available at 
http://www.dpsoftware.co.uk 
 
Note: DP Software company is not affiliated with Embird. There exists also Embird Cross Stitch plug-in 
developed by Embird authors - find more information in Embird Cross Stitch tutorial.  

Please read the guide below to find out how to use the DP Cross Stitch Software with Embird. It is supposed 
that you have downloaded the DP Cross Stitch Software software from the web site of its developers and 
successfully installed it on your computer. Before you start using the DP Cross Stitch Software with Embird, 
please run Embird and check in "Options -> Plug-ins Paths" menu that the correct path to the XSTITCH.EXE 
file (main application file of DP Cross Stitch Software) is specified there in the "Machine Cross Stitch" box.  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> 3rd party - DP Cross Stitch Design" menu (Picture No. 1). This command will launch the 
DP Cross Stitch Software which will work as a plug-in for Embird.  

Picture No. 1  

 

3 - Embird window will disappear for the time the cross stitch is running. The main window of DP Cross Stitch 
Software will appear on the screen (Picture No. 2). Create the cross stitch design using this software. In this 
example we have created the pink lettering "Embird".  
4 - When you are finished, click "File -> Save as" command to save the cross stitch project to a file on your 
hard disk (Picture No. 2).  

Picture No. 2  
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5 - Click "Digitise" button (arrow 1 in Picture No. 3) to compile your cross stitch project into stitches. 
6 - Close the main window of DP Cross Stitch Software (arrow 2 in Picture No. 3) to return to Embird. 

Picture No. 3 

 

7 - The output from the DP Cross Stitch Software will be launched into Embird Editor, so that you can edit it, 
add lettering or just save it to the hard disk in target embroidery format (Picture No. 4).  

Picture No. 4 

 

8 - Use "File -> Save As" command to save the design to a file on your disk. Specify the format and the file 
name of the new design in the dialog boxes which appear on the screen. 



 33 

Co-operation with Thred Digitizing Software 

Thred is a versatile and affordable digitizing program, developed by Thredworks. It can be used with Embird, 
or as a stand alone application. More information, demo, registration and support for Thred are available at 
http://www.thredworks.com. Please note, that Thred is not developed nor sold by Embird.  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - If you want to digitize a brand new design in Thred select "Insert -> 3rd party - Thred Design" menu (or 
click "3rd party - Insert Thred Design" button)  (Picture No. 1).  

Picture No. 1  

 

3 - If you want to edit an existing desing in Thred, open it first in Editor using the "File -> Open" menu and 
then select "Edit -> Edit in Thred" menu (Picture No. 2).  

Picture No. 2  

 

4 - Once you are finished with editing in Thred, save the changes using the "File -> Save" command and 
close Thred. (Picture No. 3). Embird Editor window will appear on the screen, showing the design which was 
created (or modified) in Thred. 
5 - You will have to save the changes also in Embird, otherwise they are ignored. Use "File -> Save As" 
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command to save the modified design to a file on your disk. Specify the format and the file name of the new 
design in the dialog boxes which appear on the screen. 

Picture No. 3 
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Co-operation with Total Commander 

The following tutorial explains how to use the Total Commander application in co-operation with Embird 
for copying files from hard disk to removable USB key memory. Before you start to use the "Launch Total 
Commander" button in Embird, you must first download and install the Total Commander application to your 
PC. 

Note: Total Commander is a stand alone file manager for Windows similar to Windows Explorer. It is 
developed by Christian Ghisler, who is not affiliated with Embird. More information, demo, registration and 
support for Total Commander are available at http://www.ghisler.com  

1 - Run Embird, it will start in "Manager" mode.  
2 - If you are going to launch the Total Commander from Embird for the very first time, you must specify the 
location of this application so that Embird is capable of launching it. Select "Options -> Plug-ins Paths" menu, 
this will display a dialog box on the screen, in which you can specify the path to the Total Commander 
application (Picture No. 1). Click "OK" button to confirm the new settings. 

Picture No. 1  

 

3 - Click "Launch Total Commander" menu to start the Total Commander application (Picture No. 2). 

Picture No. 2 

 

4 - The Total Commander window will appear on the screen (Picture No. 3). The currently chosen folder in 
Embird's Right Panel will be automatically open in the right panel of Total Commander (in this example it is 
"C:\Program Files\EMBIRD32\FILES" folder). Connect the USB memory key to the PC and choose it in the left 



 36 

panel of Total Commander. In this example, the USB memory key is recognized as "E:" disk drive and the 
"E:\Emb_Files" folder is open in left panel. 

Picture No. 3 

 

5 - In right panel of Total Commander, right click the name of those files which you want to select and copy 
to the left panel (to the USB memory key). The selected files will be highlighted by red color (Picture No. 4). 

Picture No. 4 

 

6 - Depress the "F5" key on the keyboard, or click the "F5 Copy" button located at the bottom of Total 
Commander window. This will display a dialog box, in which you must confirm the operation of copying of 3 
files to "E:\Emb_Files" folder (Picture No. 5). Click "OK" button to continue. 

Picture No. 5 
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7 - The copy operation will start and when it is finished the files appear in the left panel of Total Commander 
window (Picture No. 6). 

Picture No. 6 

 

Note: Registered users of Iconizer plug-in can also use Embird Quick Viewer in conjunction with Total 
Commander - see more details in Embird Quick Viewer tutorial. 
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Creating Custom Giant Hoop-It-All™ 

You can create custom Giant Hoop-It-All™ in case the built-in hoop choices in Embird do not suit you. The 
following tutorial explains this process. When you add a new Giant hoop into Embird, the settings for this 
hoop will be saved to "C:\Program Files\EMBIRD32\GHIA.INI" file (or to "C:\EMBIRD32\GHIA.INI file if you 
are using version prior to Embird 2006) on your hard disk. If you send us this file, we will be able to include 
the new hoop to the list of built-in hoops in the next version of Embird.  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Options -> Hoop Size" menu. 
3 - In the "Hoop Size" dialog box which appears on the screen, choose "Giant Hoop-It-All™" tab and then 
click "Create" button. 
4 - The "Custom Giant Hoop-It-All™" dialog box will appear on the screen (Picture No. 1). Measure several 
distances with the hoop attached to your embroidery machine and then enter the data into the boxes. All 
measurements are explained below. 
 
Note: All measurements must be in millimetres, not in inches.  

Picture No. 1  

 

5 - Measure the total inner hoop width and height (Picture No. 2). In case the template was supplied 
with your hoop, measure the width and height of available sewing area on the template.  

Picture No. 2  
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6 - Size of the sewing area in each section is the maximum area you can sew out with your embroidery 
machine and standard hoop. For example, Viking can sew out 100 x 100 mm in standard hoop, Janome can 
sew out 125 x 90 mm in standard hoop, etc. (Picture No. 3). However, if you are creating hoop for Pfaff, 
please specify smaller size of sewing area, so that it does not cover the "gray" area reserved for needle 
mechanism (see also Step 9 below). 
7 - It is supposed that on each side of the Giant hoop you can sew out in 5 sections - marked as A, B, C, D, E. 
Sections A, B, C, D usually correspond to lines marked on the rails of your Giant Hoop-It-All™. Section E could 
be the bottom of the rail. In case there are no lines marked on the rails, you should define the 5 sections 
yourself and mark them on the rails. Of course, the sections should be defined in such a way that they cover 
the maximum available area for sewing. 
8 - Attach the Giant hoop to your sewing machine and slide the bracket to sew in section A. Measure the 
starting position of the needle. Important is the vertical distance between the top inner hoop edge and the 
needle position, and the horizontal distance between the right inner hoop edge and the needle position. 
Repeat this step for sections B, C, D and E (Picture No. 3). 
9 - You should also specify the not-usable area around the hoop inner perimeter, which is reserved for 
needle mechanism. This will create a "gray" not-usable area around the inner hoop perimeter. 

Picture No. 3 

 

10 - In case of Giant-L hoop and sewing at the left side of Giant hoop, the top section at left side will be E 
and the bottom will be A. You must measure the distances at the right side of hoop (white crosses in Picture 
No. 4). Mark the starting position of needle for sections A, B, C, D, E while the Giant hoop is attached to your 
sewing machine (yellow crosses in Picture No. 4), then rotate the hoop by 180 degrees and measure the 
distances as shown in steps above.  

Picture No. 4 
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Creating Custom Thread Catalogs 

Embird supports custom thread catalogs. There are two ways how to create custom thread catalog. 
 
The first way of creating custom thread catalog is to select the "Color Palette -> Thread Catalogs" menu in 
Manager and then click "New Catalog" button in the dialog box which appears on the screen. This way is 
explained in Creating Custom Thread Catalogs (Another Way) tutorial. 
 
The second way of creating custom thread catalog is as follows: It is supposed, that you prepare the text 
file with thread chart e.g. in NOTEPAD, or in any other text editor, and then save this text file (with .TXT or 
.TCH extension) to "C:\Program Files\EMBIRD32\CHARTS" folder (or into "C:\EMBIRD32\CHARTS" folder if 
you use version prior to Embird 2006). Each line of this file must have the following structure:  
 
THREAD_NUMBER,NAME_OF_THREAD_CATALOG,NAME_OF_COLOR,R_VALUE,G_VALUE,B_VALUE 
 
where 
 
THREAD_NUMBER is the number of the thread in catalog 
NAME_OF_THREAD_CATALOG is the name of the thread catalog 
NAME_OF_COLOR is the name of color (can be omitted, see example below) 
R_VALUE,G_VALUE,B_VALUE are R, G, B components used to obtain the right color  

Picture No. 1  

 

Here is an example of custom thread catalog, containing four Madeira Rayon threads. For thread number 
1087, the name of color is not specified. These four lines should be stored in text file, e.g. in MADEIRA.TXT 
and the file must be saved in "C:\Program Files\EMBIRD32\CHARTS" folder (or in "C:\EMBIRD32\CHARTS" 
folder if you use version prior to Embird 2006) to be accepted by Embird. 

**************************** EXAMPLE *************************************  
1000,Madeira Rayon,Black,0,0,0 
1003,Madeira Rayon,Natural White,240,237,228 
1087,Madeira Rayon,,212,206,197 
1187,Madeira Rayon,Dark Pink,208,0,87 
************************* END OF EXAMPLE ********************************* 
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Creating Custom Thread Catalogs (Another Way) 

Embird supports custom thread catalogs. There are two ways how to create custom thread catalog. 
 
The first way of creating custom thread catalog is to select the "Color Palette -> Thread Catalogs" menu in 
Manager and then click "New Catalog" button in the dialog box which appears on the screen. This way is 
explained below. 
 
The second way of creating custom thread catalog is as follows: It is supposed, that you prepare the text 
file with thread chart e.g. in NOTEPAD, or in any other text editor, and then save this text file (with .TXT or 
.TCH extension) to "C:\Program Files\EMBIRD32\CHARTS" folder (or into "C:\EMBIRD32\CHARTS" folder if 
you use version prior to Embird 2006). This way is explained in Creating Custom Thread Catalogs tutorial.  

1 - Run Embird, it will start in "Manager" mode.  
2 - Select "Color Palette -> Thread Catalogs" menu (Picture No. 1).  

Picture No. 1  

 

3 - The dialog box containing the thread catalogs will appear on the screen (Picture No. 2). Click "New 
catalog" button to create a brand new catalog of threads. 

Picture No. 2 

 

4 - Another dialog box will appear on the screen, allowing you to specify the name of the catalog, and the 
number, name and color of the first thread (Picture No. 3). You can specify either R, G, B components of the 
color, or you can double-click the large color area and choose the new color from the color dialog box, which 
appears on the screen. Click "OK" button to confirm the operation. 
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Picture No. 3 

 

5 - The contents of the new thread chart ("My Threads") will be shown (Picture No. 4). Click "Add thread" 
button to add another thread into this chart. 

Picture No. 4 

 

6 - Specify the number, name and color of the second thread (Picture No. 5), then click "OK" button to 
confirm the operation. 

Picture No. 5 

 

7 - The "My Threads" catalog now contains 2 threads (Picture No. 6). 

Picture No. 6 
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Creating Design Images for Cataloguing 

1 - Run Embird, it will start in "Manager" mode.  
2 - Use "Drive", "Folder" and "Files" boxes (located on the Right Panel at the right side of the screen) and 
choose the folder with embroidery designs, e.g. "C:\EMBIRD32\FILES" folder in this example. In case you are 
using Embird 2006 or later, you will find some free designs in "C:\Program Files\EMBIRD32\FILES" folder. 
3 - In the "Files" box select the designs which you want to create images of. To select multiple designs, 
please move mouse pointer to the file name of the first design in the "Files:" box at the right side of the 
screen, depress the left mouse button and hold it down while moving the mouse pointer over the file names 
of the other designs. When the mouse pointer is over the last design, please release the left mouse button 
(Picture No. 1).  

Picture No. 1  

 

4 - Once the files are selected, click "Right Panel" menu and choose "Export -> Export Image..." 
command (Picture No. 2).  

Picture No. 2  

 

5 - Specify the size of images - either the width or the height. Click "OK" button to continue (Picture No. 3).  
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Picture No. 3  

 

6 - After a while, the "Save As" dialog box will appear on the screen (Picture No. 4). Choose the file format for 
images in "Save file as type" box. You can choose between .BMP and .JPG formats. File size of image stored 
in .JPG file is smaller than the file size of image stored in .BMP file. On the other hand it takes more time to 
create the file with .JPG extension, because it contains compressed image. 
7 - Finally, click "All" button to create images of all selected designs. In case you have selected only single 
design, click "OK" button. Images will be stored in the same folder as the designs, i.e. to 
"C:\EMBIRD32\FILES" folder in this example (Picture No. 4). 

Picture No. 4 

 

8 - Now you can view images to check them. In this example, we have displayed the "VERONIK2.BMP" file in 
ACDSee image viewer (Picture No. 5).  Another free image viewer is IrfanView.  

Picture No. 5 
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Decapsulation of Floppy Disk  

This tutorials explains how to decapsulate the contents of a floppy disk from an executable .EXE file. Read 
the Encapsulation of Floppy Disk tutorial first to find out how to create the stand alone executable (.EXE) file 
which contains encapsulated contents of non-standard floppy disk. 
 
Follow these steps to decapsulate the floppy disk: 
 
1 - Run the .EXE file which contains the encapsulated contents of floppy disk. You must run this file on PC 
which is equipped with 3.5" floppy disk drive and which is running either Windows 98 or Windows ME. 
Decapsulation does not work when running in Windows NT, 2000 or XP. 
2 - A dialog box will appear on the screen. Click "Start Decapsulation" button (Picture No. 1).  

Picture No. 1  

   

3 - Insert the floppy disk into the disk drive. Make sure, that the disk is not write-protected (Picture No. 2). 
Click "OK" button to continue. 
 
Note: You will be asked either for 2DD (double-sided double-density, 720 kB) or 2HD (double sided high-
density, 1.44 MB) floppy disk, depending on the format of data stored in the encapsulated .EXE file. Make 
sure, that you are inserting the right type of disk.  

Picture No. 2  

   

4 - Note, that all files already stored on the floppy disk will be erased during the decapsulation process 
(Picture No. 3). If you agree, click "Yes" button to continue.  

Picture No. 3  

   

5 - The decapsulation process will start (Picture No. 4). Wait until this process is finished.  
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Picture No. 4  

   

6 - Once the decapsulation is finished, a dialog box will appear on the screen, showing the result of the 
operation (Picture No. 5).  

Picture No. 5  

   

7 - Floppy disk is now ready for use. You can eject it from the disk drive and use it with your embroidery 
machine. 
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Digitizing Studio - Co-operation with Embird  

Digitizing Studio is additional plug-in for Embird. To use it, you must download it (e.g. from 
http://www.embird.com/sw/embird/down.htm) and install it (run the downloaded file). 
 
1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click "Insert -> Studio or Sfumato Design" command from the main menu to launch the Digitizing 
Studio plug-in (Picture No. 1).  

Picture No. 1 

 

3 - Create a new design using  Digitizing Studio tools. Find more information about using Digitizing Studio in 
its Help file - press F1 key when running this application. 
4 - Once the design is ready, select "Design -> Compile and Put into Embird Editor" command from the main 
menu (Picture No. 2). Dialog box will appear on the screen, allowing you to save the project to an .EOF file on 
your hard disk. 
 
Note: It is always recommended to save your project in Digitizing Studio, because this will store the design in 
scalable Embird Outline Format (.EOF). This allows you to re-open your project later in Digitizing Studio, and 
continue in your work: re-size the design, add new objects or perform some other modifications. Finally, the 
project can be compiled into stitches again. Compare this with situation when all you have is the "stitch file" - 
this file does not contain the contours of the filled areas, but only stitches of filled areas.  

Picture No. 2 
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5 - Your project will be compiled into stitches and the new design will be inserted into Embird Editor (Picture 
No. 3). Now you can change the hoop using "Options -> Hoop Size" command from the main menu. You can 
also add lettering or perform any other operation. 
6 - Finally, save the design to your hard disk using the "File -> Save As" command. 

Picture No. 3 
 

 

7 - In Digitizing Studio, you can also edit designs which were not created in this plug-in: First, open such a 
design in Embird Editor using the "File -> Open" command from the main menu. 
 
Note: Designs which were created in Digitizing Studio are stored in .EOF file. If you have such a file, open 
this file in Digitizing Studio using its "Design -> Open" menu instead of steps explained below. 
 
8 - Use "Edit -> Edit in Digitizing Studio" command (Picture No. 4). 

Picture No. 4  
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9 - The design will be launched into Digitizing Studio plug-in (Picture No. 5). Now you can modify the design, 
create the new shapes, etc.  

Picture No. 5  

 

10 - When you are finished, use "Design -> Compile and Put into Embird Editor" command to return to 
Embird Editor (see Picture No. 2 above). 
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Digitizing Studio - Creating Fill Objects 

In Digitizing Tools plug-in the design is digitized so that user creates outline (vector) objects either on a blank 
background or on an image (template). Image imported to the background of the Work Area has to be 
usually edited before digitizing. Read Digitizing Studio - Importing Image tutorial to find out how to edit 
image - crop, rotate, resize image and add blank border to image. This tutorial explains how to create filled 
objects - the main building block of the design. 
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Studio or Sfumato Design" menu to open Embird Studio window. 
3 - Import the image to the background and adjust it for digitizing using the steps explained in Digitizing 
Studio - Importing Image tutorial.  
4 - Select proper tool for digitizing of the "girl's head" object (Picture No. 1). Long narrow objects are mostly 
created with use of column tool, round broad objects are created with use of fill tool.  

Select the fill tool and create the "girl's head" object with slight overlap to "hair": Move mouse pointer to 
the place on Work Area where the first point should be created, and click the left mouse button. A point will 
be created on the Work Area. Move mouse pointer to the place of the second point and click the left mouse 
button again. Another point will be created on the Work Area, connected with the first point by line. The 
midpoint of this line is another point, whose position can be adjusted to create curve (instead of line) 
between the first point and second point. Use this process to add as many points as necessary for creation of 
fine object edges. Finally, press ENTER key on the keyboard to close the object - this will connect the last 
point with the first point and draw selection rectangle around this new object (Picture No. 1). 
 
Tip: See also Digitizing Studio - How to Create Curve Objects tutorial. 

Picture No.1 

 

5 - Use the fill tool again and create two "hair" objects. Neighboring areas should overlap one another slightly 
to prevent gaps caused by pull effect of the thread during the sewing process (Picture No. 2). 
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Picture No. 2  

 

Understanding Fill Objects: 
 
The edge of a fill object is composed of lines and curves (Picture No. 2). Small rectangles are end points of 
lines and curves. Small circles are middle points of curves. Fill edge must form a closed loop, which means 
that its last point must be placed on top of its first point. The cross at the top is beginning of the edge. 
Diagonal line at the bottom indicates the place of last fill stitch and angles of cover stitches (longest line) 
and zig-zag underlays (short and medium length line). Small cross in the object is the 'Focus point' for effects 
like Circular fill.  
 
Studio automatically generates edge underlay and two zig-zag underlays as well as overlays and connections. 
Fill object can contain openings (Opening Tool). User can adjust various parameters of Fill object, including 
gradient-stitch density at beginning and end of object and effects like the wave, contour or circular fill. Fill 
objects may be filled also with automatic column (satin) stitches.  
 
Fill object may be followed with Carving object. 
 

6 - Use Carving tool to carve fill object "hair" to stripes (Picture No. 3). Carving objects have to be drawn 
directly after the fill objects. Draw each carve object using the technique explained above for fill tool. Before 
drawing a new carve object, finish previous carve object by pressing ENTER key on the keyboard.  

Picture No. 3 
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7 - Select all carving objects together with fill object (e.g. by depressing CTRL key on the keyboard and 
clicking the item in the Object Inspector list at the right side of the screen). Then click right mouse button and 
select "Generate Stitches" in the menu which appears on the screen (Picture No. 4). 

Picture No. 4 

 

8 - Check the 3D preview of carving effect on fill object by clicking the "3D Matte" tab below the Work Area 
(Picture No. 5). Compare the right part of the "hair" with the left part, which does not have the carves yet. 

Picture No. 5 

 

Understanding Color Palette: 
 
To select color for new objects, click left mouse button on any color in the palette located at the right side of 
the screen. 
 
To change color of an existing object, depress left mouse button on color and drag it to either Work Area or 
to the Object Inspector window and release the left mouse button when cursor is on top of the object (i.e. 
drag & drop color from palette either to selected object in Work Area, or its icon in Object Inspector).  
 
To mix your own color, click right mouse button on any color in the palette. 
 
To pick color from Image, pick color with pipette directly from image in Work Area. 
 
To add object's color to palette, depress right mouse button on object's icon in the Object Inspector and drag 
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mouse pointer to the Palette. Release right mouse button to drop the color into Palette. 
 
9 - The colors of existing fill objects ("girl's head", "hair") were mixed in palette and transferred to objects in 
Object Inspector with drag & drop function (Picture No. 6). 

Picture No. 6 

 

Understanding Opening Object: 
 
Opening can be used only after Fill object, Sfumato object or previous Opening object. It does not appear in 
Object Inspector as a separate object and cannot be selected directly on the Working Area. To select the 
Opening object for transformation, use Part Inspector. The same thing applies for Appliqué Opening object. 
 
Opening can be added only to the last object in Object Inspector. To add an Opening to existing Fill or 
Sfumato object that is not the last created or listed in Object Inspector, drag & drop the object so that it is 
the last object. Then add Opening and drag & drop the object to its original position in the list.  
 
10 - Fill Opening is usually placed in lower fill in case one fill overlaps another to prevent bulking. Opening in 
"girl's head" fill will be created in next steps, because the new fill - "mouths" fill will be placed on top of "girl's 
head" fill. (Opening in "girl's head" fill should be smaller than overlapping "mouth" fill to prevent gaps caused 
by pull effect of thread). Change the position of the "girl's head" fill using the drag & drop function to have 
this object as the last object in Object Inspector (Picture No. 7). 

Picture No. 7 
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11 - Create opening for "mouths" in "girl's head" fill using the Opening Tool (Picture No. 8). 

Picture No. 8 

 

12 - Drag & drop the "girl's head" fill with opening to it's original position in Object Inspector, generate 
stitches (see step 7 above) and check the 3D preview of the design (Picture No. 9). 

Picture No. 9 

 

13 - Create further fill objects: "hands", "shoes", "mouths", "shirt", "trousers", etc. Use carving effect for 
"mouths" fill, generate stitches and check the 3D preview of the design (Picture No. 10). 
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Picture No. 10 

 

Tip: Select "View -> Sew Simulator" command from the main menu to check the simulation of sewing of the 
design. 
 
14 - Click "Design -> Save As" menu to save this digitizing project into a file on your hard disk. Specify the file 
name and location in the dialog box which appears on the screen. 
15 - Click "Design -> Compile and Put into Embird Editor" menu to compile the digitizing project into stitches 
and return back to Editor window. 
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Digitizing Studio - How to Create Curve Objects    

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Studio or Sfumato Design" menu to open Embird Studio window.  
3 - The curve objects can be created using the following tools: "Fill", "Sfumato", "Opening", "Carving", 
"Column", "Column with Pattern", "Outline", "Connection", "Appliqué" and "Appliqué opening" (see the tools 
in red rectangle in Picture No. 1). 

Picture No. 1 

 

4 - Select "Fill" tool in the toolbar at the left side of the screen. Move mouse pointer to the place on Work 
Area where the first node should be created, and click the left mouse button. A node will be created on the 
Work Area (Picture No. 2). 

Picture No. 2 

 

5 - When you are creating new objects, the edges can be composed either from lines or from curves - 
depending on the "Edge Type" setting (Picture No. 3). Select the "curve" edge type to draw curve elements, 
which have also the middle points allowing to change their shape. Click the left mouse button in Work Area to 
place another node of curve (Picture No. 3). 
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Picture No. 3 

 

6 - The rectangular node is the end point of the curve, the circular node is the middle point of the curve. 
Move the circular node to adjust curve shape (Picture No. 4).   

Picture No. 4 

 

7 - The "Middle Point First" check box (Picture No. 5) has the following meaning: If it is OFF, the curve end 
point is created on a place where you click the left mouse button, and the middle point lies between this 
point and previous end point. Then the middle point must be dragged to the proper position so that the curve 
has the right shape (Picture No. 6). 
 
Note: To drag the middle point, you need to move the mouse pointer to this point, depress the left mouse 
button and move the mouse pointer while holding down the left mouse button. When the middle point is on 
the proper position, release the left mouse button. 
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Picture No. 5 

 

Picture No. 6 

 

8 - In case the "Middle Point First" is ON, the line element is created on a place where you click the left 
mouse button in Work Area (Picture No. 7). On a second click this line turns into curve using the previous 
point (end of line) as its middle point (Picture No. 8).  

Picture No. 7 
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Picture No. 8 

 

9 - Fill object must created closed loop. Continue with creation of curve object and place other nodes on 
Work Area. Finally, create the last node close to the first node, and move it on the top of the first node 
(Picture No. 9). 

Picture No. 9 

 

10 - Press ENTER (or SPACE) key on the keyboard to close the fill object. Another way is to click the right 
mouse button on Work Area. This will display a popup menu. Choose "Finish Object" command to close the fill 
object (Picture No. 10). 

Picture No. 10 
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11 - Fill object is closed, the rectangle will appear around it (Picture No. 11). 

Picture No. 11 

 

12 - Closed fill object can be edited in case you need to revise some of its nodes. Use "Edit" tool to switch an 
existing object into editing mode and the move, add or delete the nodes, or change the shape of the curve 
(Picture No. 12). 

Picture No. 12 

 

13 - Finish editing by pressing ENTER (or SPACE) key on the keyboard (step No. 10). 



 61 

Digitizing Studio - Importing Image 

1 - Design is digitized so that user creates outline (vector) objects either on a blank background or on an 
image (template). 
Studio can import an image in JPG, BMP, PNG and TIFF formats. Convert image to one of these file types.  

Embird Manager can convert  following image file types: .BMP, .GIF, .JPG, .PCX, .PNG, .PSD, .TGA, .TIF.  
(Embird Manager-> Image Operations-> Convert Images) 

2 - Open Embird Studio. Import the image to Studio by selecting " Image->Import". (Picture No.1) 

Picture No. 1  

 

3 - Studio ignores the DPI, resolution, or size set by the graphics program which generated the imported 
image, instead using this scheme: 
100 pixels = 1 cm of design size; 254 pixels = 1 inch. User may also select 'Scale image to fit current hoop' 
option to scale image to hoop size while importing image. (Picture No. 2) 

Picture No. 2 

 

4 - Edit image. Crop image, rotate, set size and border around the image. (Picture No. 3) 
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Picture No. 3 

 

5 - Click on first icon of edit image window to rotate image. Move the red line in circle with left mouse button 
to set the rotation angle or click on number: right mouse button allow to increase angle value, left mouse 
button allow to decrease angle value. 
(Picture No.4) 

Note: You can find "Edit image window" tutorial, when you click on "Help" button in the window". 

Picture No. 4 

 

6 - Click with right mouse button on circle area to show dialog box with slide bar and box allowing to set 
exact rotation angle value (Picture No. 5). 

Picture No. 5 
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7 - The image is cropped by selecting the working area with crop lines. Crop lines allows you to cut out the 
area of image intended for digitizing (the one which will appear on the work area) and throw away the 
unused image parts. Move the crop lines close to edges of the image area intended for digitizing. Crop lines 
have square handle in the middle to allow user to seize and move the crop line. Area that will be cut off is 
grayed (Picture No. 6). 

Picture No. 6 

 

8 - Choose the middle icon in edit image window to set size of selected area. Depress left mouse button on 
width or height value to decrease it or depress right mouse button to increase the width or height of image. It 
is possible to resize image keeping aspect ratio (checked option) or uncheck box keep aspect ratio and 
change the width and height separately. (Picture No. 7) 

(Click with right mouse button on width or height arrow to show slide bar and set the values with slider. Look 
at the picture No. 5     You can find "Edit image window" tutorial, when you click on "Help" button in the 
window".) 

Picture No. 7 

 

8 - Border is an empty area around the image. Border that can be set around the image allows easier objects 
creation on the image edge (Picture No. 8).  

Note: Maximal size of the border is 0.50 cm. 

(Click with right mouse button on width or height arrow to show slide bar and set the values with slider. Look 
at the Picture No. 5    You can find "Edit image window" tutorial, when you click on "Help" button in the 
window. ) 
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Picture No. 8 

 

9 - After above four steps, click Apply to perform changes. Cropped, rotated and resized image with blank 
border is prepared for digitizing. (Picture No. 9) 

Picture No. 9 
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Display Calibration  

Before you start viewing your designs in Embird, you should calibrate the display so that the designs are 
displayed in 1:1 scale on the screen. This is great especially for viewing designs in photo-realistic 3D view 
mode (See also Viewing Designs tutorial).  

1 - Run Embird, it will start in "Manager" mode (Picture No. 1).  

Picture No. 1  

 

2 - Select "Options -> Display Calibration" menu (Picture No. 2).   

Picture No. 2  
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3 - A dialog box will appear on the screen, containing "Calibration Square" in its left part (Picture No. 3). 
Measure the width and height of this square in millimeters. Typically, it is about 53 mm, but you can obtain 
different results, depending on the type and resolution of your display. Specify the height and width of the 
calibration square into the corresponding boxes at the right part of this dialog box. Finally, click "OK" button 
to confirm these new settings. 
 
Tip: If you are measuring in inches instead of millimeters, please multiply your measurements by 25.4 to 
obtain the results in millimeters. For example, 2 and 1/2 inches are 63.5 mm. 

Picture No. 3 

 

4 - Now you can double-click the filename of some designs in the "Files:" box at the right panel and measure 
the displayed design to make sure it is viewed in 1:1 scale. Make sure that the "1:1 Normal" tab is selected at 
the bottom of the preview area. If not, click it first and then measure the displayed design. In this example, 
the height of the "SQUIRREL.DST" design should be 70 mm and its width should be 50 mm (Picture No. 4).  
 

Picture No. 4 
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Editing Existing Thread Catalog    

Customer can edit thread numbers and names, add new threads or delete threads in charts supplied with 
Embird software.  

Example:  
 
1 - Open MADEIRA.TXT file from "C:\Program Files\EMBIRD32\CHARTS" folder (or from 
"C:\EMBIRD32\CHARTS" folder if you use version prior to Embird 2006) in text editor, e.g. in NOTEPAD. 
2 - Add new threads to the end of the list (Picture No. 1). 
3 - Click "File -> Save" menu to save the changes in this text file. 

Picture No. 1 

 

4 - Run Embird and select "Color Palette ->Thread Catalogs" menu to display the edited Madeira Rayon chart. 
The new threads #1799, #1800, #1801 and #1802 now appear in the list (Picture No. 2). 

Picture No. 2 

 



 68 

Embird Cross Stitch 

This tutorial explains how to use Embird Cross Stitch plug-in. Cross Stitch plug-in is installed together with 
Embird 2004 (and later version), there is no special installation file available. However, you will have to 
purchase and register Cross Stitch plug-in separable from main Embird program at 
http://www.embird.com/sw/embird/register.htm, otherwise there is stitch limit for every design you create. 
After purchase and insertion of registration password, evaluation version turns into full version. No additional 
download or installation needed.  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert" -> "Cross Stitch Design" menu (Picture No. 1).  

Picture No. 1  

 

3 - Cross Stitch plug-in will start and its window will appear on the screen (Picture No. 2). The screen is 
divided into 6 areas. Click on the following links to learn more about each area: Menu Bar, Main Toolbar, 
Design Toolbar, Color Palette Bar, Work Area, Status Bar.  

Picture No. 2  

 

4 - Use Cross Stitch tools to create the design: Put pixels into a grid, each pixel will be compiled into cross 
(Picture No. 3). You do not have to put manually each pixel into the grid - use the tools located on 
Design Toolbar at the left side of the screen. 
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Picture No. 3 

 

5 -  When the design is ready, save your Cross Stitch project to hard disk. Use "File" -> "Save As" menu 
(Picture No. 4).  

Picture No. 4 
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6 -  Compile your Cross Stitch project into stitches. Use "File" -> "Compile and Put into Embird Editor" menu 
(Picture No. 5).  

Picture No. 5 

 

7 -  The design will be put into Embird Editor. If you have saved your Cross Stitch project in step 4, Embird 
will automatically open the "Save As" dialog box in the Editor window, allowing you to save the design in 
desired embroidery format. Otherwise use "File" -> "Save As" menu to display the "Save As" dialog 
box (Picture No. 6).  

Picture No. 6 
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Embird Cross Stitch - Creating New Fill Pattern   

This tutorial explains how to create a new fill pattern in Embird Cross Stitch plug-in. You can create either 
monochrome patterns (typically) or even color fill patterns. Each pattern is standard Embird Cross Stitch 
File (.ECF), but what makes it different from other .ECF files is it location on the hard disk: Only files stored in 
"C:\Program Files\EMBIRD32\X_FILLS" folder (or in "C:\EMBIRD32\X_FILLS" folder if you use version prior to 
Embird 2006) are recognized as fill patterns for Embird Cross Stitch plug-in. 
 
Note: If you create some pattern which you would like to share with other users, please send us the .ECF file 
containing the pattern and we will be able to include it into the set of pre-defined patterns in the next version 
of Embird. 
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Cross Stitch Design" menu to open Embird Cross Stitch window. 
3 - The Cross Stitch plug-in will be launched, and its "Preferences" box will appear on the screen (Picture 
No. 1). Specify the width and height of Work Area, e.g. 20 x 20 crosses. The cross size settings are not 
important if you create a fill pattern.  

Picture No. 1  

   

4 - Select black color by left-clicking on it in the Color Palette Bar at the right side of the screen 
(Picture No. 2).  

Picture No. 2  

   

5 - Use Cross Stitch tools to draw your pattern (Picture No. 3). Make sure that the pattern you create is 
continuous, i.e. if you imagine tiles of your patterns placed one beside the other they should create 
homogeneous pattern. If necessary change the work area size in "Options -> Preferences" menu. 
 
Note: More information about tools is available in Embird Cross Stitch - Design Toolbar tutorial. More 
information about creating a new cross stitch design is available in Embird Cross Stitch - Creating Simple 
Design tutorial. 
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Picture No. 3 

 

6 -  When the pattern is finished, save it to hard disk using the "File -> Save As" command (Picture No. 4).   
 

Picture No. 4 

   

7 - Pattern must be saved into "C:\Program Files\EMBIRD32\X_FILLS" folder (or into "C:\EMBIRD32\X_FILLS" 
folder if you use version prior to Embird 2006), otherwise it is not recognized by Cross Stitch. Browse to this 
folder and give your pattern the unique name (Picture No. 5).  
 

Picture No. 5 
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8 - The pattern is now ready for use. Click the "..." button to check the pattern (Picture No. 6).  
 

Picture No. 6 

   

9 - Search for the new pattern in the dialog box which appears on the screen (Picture No. 7). Choose the new 
pattern by clicking on it, this will draw a blue selection rectangle around it. Click "OK" button to confirm your 
selection.  

Picture No. 7 

 

10 - Now you can fill in the areas using your new pattern. 
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Embird Cross Stitch - Creating Simple Design 

This tutorial explains how to create a simple cross stitch design on blank background in Embird Cross Stitch 
plug-in. Design is digitized so that user puts pixels into a grid on Work Area. When finished, each pixel is 
compiled into cross and the design is launched into Embird Editor for final adjustment and save in desired 
embroidery format. Although it is not shown in the following tutorial, it is possible to import image or chart 
into the background of Work Area - these topics are explained in Embird Cross Stitch - Set Size of Image and 
Embird Cross Stitch - Importing Chart tutorials. 
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Cross Stitch Design" menu to open Embird Cross Stitch window. 
3 - The Cross Stitch plug-in will be launched, and its "Preferences" box will appear on the screen (Picture No. 
1). Specify the cross size and the size of Work Area. In this example, the cross size is 2.0 mm (i.e. there will 
be 5 crosses per centimeter), and the size of Work Area is 30 x 30 crosses - this means that the design we'll 
create will fit the 60 x 60 mm hoop size. Confirm these settings by clicking "OK" button. 

Picture No.1 

 

4 - Embird will adjust the size of Work Area to 30 x 30 crosses (Picture No. 2). Now we can start using Cross 
Stitch tools for drawing our simple design - "two cherries". Select red color from the palette at the right side 
of the screen: Move mouse pointer to the box containing the red color and click the left mouse button to set 
this color as default "cross color 1". This means, that the left mouse button will draw crosses on Work Area 
having this color. If you select a color in palette with right mouse button click, this will set the color as default 
"cross color 2" for drawing with right mouse button on Work Area. 
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Picture No. 2  

 

5 - Move mouse pointer to the icon of "Filled Ellipse" tool at the left side of the screen and click the left 
mouse button to select this tool. Move mouse pointer to the Work Area, depress left mouse button and drag 
mouse to draw ellipse (circle). Release left mouse button when you have the desired shape and size (Picture 
No. 3). 
 
Note: More information about tools is available in Embird Cross Stitch - Design Toolbar tutorial. Before you 
start drawing crosses on Work Area, you might want to change the cross type - normal, upright, mini, 
horizontal or vertical. Find more information in Embird Cross Stitch - Color Palette Bar tutorial. 

Picture No. 3 

 

6 - Select green color from the palette at the right side of the screen. For drawing of leafs, select "Pencil" tool 

at the left side of the screen. Move mouse pointer to the Work Area and draw the leafs (Picture No. 4).  
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Tip: If you make a mistake, you can delete the unwanted cross by "Eraser" tool . Another way which 
does not require the change of active tool is to depress ALT key on the keyboard and click the unwanted 
cross while holding this key down. 

Picture No. 4 

 

7 - Add the outlines to the design automatically by selecting "Insert -> Insert Outline Around Each Color 
(Multi-Color)" command from the main menu (Picture No. 5). 
 
Tip: It is possible to create outlines, or back stitch lines also manually. Find more information about the tools 
allowing these operations in Embird Cross Stitch - Design Toolbar tutorial. 

Picture No. 5 

 

8 - Check the designs with outlines (Picture No. 6). Now we would like to fill the background of the design 

with some pattern. Select "Fill contiguous area" tool at the left side of the screen. Select light blue color 
in the color palette. 
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Picture No. 6 

 

9 - Click the "Choose fill pattern" button at the right side of the screen. A dialog box will appear on the 
screen, allowing you to choose the fill pattern. Scroll the window down and choose some pattern 
(Picture No. 7). Click "OK" button to confirm the selection. 
 
Tip: You can create you own fill patterns - find more details in Embird Cross Stitch - Creating New Fill Pattern 
tutorial. 

Picture No. 7 

 

10 - Move mouse pointer to the Work Area and position the cursor anywhere over the blank space. Click left 
mouse button to fill this area with selected pattern and color (Picture No. 8). 
 
Note: If you don't select any pattern, the area will be filled with crosses of currently chosen type (normal, 
upright, mini, horizontal or vertical). 
Tip: You can fill in areas by applying gradient and filter to the fill pattern - click "Fill Properties" button 

at the right side of the screen to access these options.  
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Picture No. 8 

 

11 - Check the 3D preview of design by clicking the "3D" tab below the Work Area (Picture No. 9). 

Picture No. 9 

 

Tip: Select "View -> Sew Simulator" command from the main menu to check the simulation of sewing of the 
design. 
 
12 - Click "File -> Save As" menu to save this cross stitch project into a file on your hard disk. Specify the file 
name and location in the dialog box which appears on the screen. 
13 - Click "File -> Compile and Put into Embird Editor" menu to compile the cross stitch project into stitches 
and return back to Editor window.  
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Embird Cross Stitch - Importing Chart  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Cross Stitch Design" menu to open Embird Cross Stitch window. 
3 - In Embird Cross Stitch window select "Chart -> Import" menu (Picture No. 1).  

Picture No. 1  

   

4 - A dialog box will appear on the screen allowing you to choose the file containing scanned image of chart. 
Browse to the folder with scanned chart, select it (arrow 1 in Picture No. 2) and click "Open" button (arrow 2) 
to open the scanned chart.  

Picture No. 2  

   

5 - Another dialog box will appear on the screen, displaying the chosen chart and allowing to calibrate it for 
use in Cross Stitch. Notice the three connected red marks in the top left corner of the chart (Picture No. 3). 
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Picture No. 3 

   

6 -  Position mark 1 to the upper left corner of the ten square grid, position mark 2 to the upper right 
corner of the ten square grid and position mark 3 to the bottom right corner of the ten square grid 
(Picture No. 4). To change the position of some mark, move the mouse pointer to its handle square, depress 
the left mouse button and drag mouse while holding the left mouse button down. Release left mouse button 
when the mark is on the right position.  

Picture No. 4 

 

7 - Click "Align Grid" button in the bar at the top of the window. Specify the horizontal and vertical mark 
spacing in the dialog box which appears on the screen (Picture No. 5). As you can see in Picture No. 4 above, 
in this example the horizontal mark spacing is 20 squares (arrow 1) and vertical mark spacing is 10 squares. 
Hit "OK" button (arrow 2) to continue with grid aligning.  
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Picture No. 5 

   

8 - Check the results of alignment (Picture No. 6). In case the red grid follows the scanned chart grid, click 
"OK" button to insert the aligned chart into the Cross Stitch work area. Otherwise click "Undo Alignment" 
button to revise the position of red marks.  

Picture No. 6 

   

9 - The aligned chart is now displayed as the background of work area (Picture No. 7). Now you can manually 
put crosses on their position. Before you start, it is a good idea to set the "View -> Crosses As Squares" 
option to ON to make the crosses you draw more visible on the blurred background.  

Picture No. 7 
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Embird Cross Stitch - Set Size of Image  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Cross Stitch Design" menu to open Embird Cross Stitch window. 
3 - In Embird Cross Stitch window select "Image -> Import" menu (Picture No. 1).  

Picture No. 1 

 

4 - A dialog box will appear on the screen allowing you to choose the background image file. Browse to the 
folder with image, select it and click "Open" button (Picture No. 2). 

Picture No. 2  

 

5 - Image is imported to the background of Work Area in Cross Stitch window (Picture No. 3). Now it is 
possible to manually draw crosses on Work Area over the background image, or automatically digitize 
crosses from the background image. 
 
Note: The auto-digitizing process will convert one pixel of image to one cross on Work Area. The size of cross 
can be adjusted from 1 mm to 10 mm. The image should be resized before auto-digitizing in order to fit 
design into the hoop area. 
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Example: If the hoop area is 140 x 200 mm and cross size is 2 mm, the image should have 70 pixels height 
(i.e. 140/2) and 100 pixels width (i.e. 200/2) to utilize the most area of hoop and don't exceed boundaries of 
hoop. If the cross size is adjusted to 3 mm, the image should have 46 pixels height (i.e. 140/3) and 66 pixels 
width (i.e. 200/3). 

Picture No. 3  

 

6 - Select "Image -> Set Size" command to adjust the size of background image (Picture No. 4). Use the 
calculation explained above to set the size of "sunflower" image. In this example, our design has to fit the 
standard hoop size 100 x 100 mm. If the cross size is 2 mm, image should be resized up to 50 x 50 pixels. 

Picture No. 4  

 

7 -  Adjust image height (bigger size of image) to 50 pixels. Image width is set automatically to 49 pixels to 
keep the aspect ratio of width and height determined by original image size (Picture No. 5). Click "OK" button 
to continue. 
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Picture No. 5  

 

8 - Image is resized to 49 x 50 pixels (Picture No. 6). 

Picture No. 6  

 

9 - Select "Image -> Auto-digitize Crosses from Image" menu to convert each pixel of the resized image into 
the cross on Work Area (Picture No. 7). 

Picture No. 7  

 

10 - A dialog box will appear on the screen allowing you to adjust the width and height of cross. Adjust cross 
size to 2 mm (Picture No. 8). Click "OK" button to continue. 
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Picture No. 8  

 

11 - Another dialog box is informing you about the design size and number of crosses. Because we have 
already adjusted the image size in step 7 above, the design fits the hoop area 100 x 100 mm (Picture No. 9). 
Click "OK" button to continue. 

Picture No. 9  

 

12 - You can reduce the number of colors to lower value (Picture No. 10). The lower number of colors you 
choose, the lower number of jumps in final cross stitch design will be created. 

Picture No. 10  

 

13 - You can choose the transparent color (color of the background that will be skipped and not converted to 
crosses) or ignore this selection if you want to convert every pixel of image into cross (Picture No. 11). 

Picture No. 11  

 

14 - Choose the transparent color in the dialog box which appears on the screen and confirm the selection by 
clicking "OK" button (Picture No. 12). 

Picture No. 12  
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15 - Confirm applying of noise filter that decreases the number of isolated points and therefore reduces the 
number of jumps in final cross stitch design (Picture No. 13). 

Picture No. 13  

 

16 - Image is automatically converted to crosses on Work Area. Check the 3D preview of design by selecting 
"View -> 3D Preview" command from main menu, or by clicking the "3D Preview" button on the Main Toolbar 
(Picture No. 14). 

Picture No. 14  

 

17 - The 3D Preview of design will be displayed on the screen (Picture No. 15). Click "Close" button close this 
window. 

Picture No. 15  

 

18 - Click "File -> Save As" menu to save this cross stitch project into a file on your hard disk. Specify the file 
name and location in the dialog box which appears on the screen.  
19 - Click "File -> Compile and Put into Embird Editor" menu to compile the cross stitch project into stitches 
and return back to Editor window. 
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Embird Co-operation with Google Picasa  

Google Picasa is free application developed by Google company (http://www.google.com) and it allows to 
organize, edit and share images and photos. It allows to manage your photos and images in one place, and 
find photos or images you forgot you had on your hard disk. It cannot work directly with embroidery designs, 
but new Embird Manager's option "Automatically Create Documentation Files (*.jpg)" allows to create 
image files automatically for every design which you digitize or display in Embird. Google Picasa can then 
index these images and allows you to quickly browse through them. This way you can use Google Picasa to 
quickly locate your design, which is stored in the same folder as its image. 
 
Note: Before you start, please download Google Picasa application from http://picasa.google.com and install 
it on your PC. 
 
Hint: It is recommended to move all your designs into the sub-folder of "My Documents" folder in your user 
profile. Otherwise it might happen that Google Picasa will not index the images of your designs. We 
recommend to create folder "My Designs" under "My Documents" and keep all embroidery designs in sub-
folders of "My Designs" folder. 
 
Follow these steps to create images from your designs for Google Picasa:  

1 - Run Embird, it will start in "Manager" mode 
2 - Select "Options" menu and make sure that the "Automatically Create Documentation Files (*.jpg)" option 
is ON (Picture No. 1). In case it is OFF, please select this menu to switch ON this option.  

Picture No. 1  

 

3 - Display your designs on the screen - you can use e.g. thubmnail view mode (Picture No. 2). More details 
about viewing designs is available in Viewing Designs tutorial. Embird will create the .JPG documentation 
image file for every design being viewed. This image will be stored in the same folder as the design.  
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Picture No. 2  

 

4 - Launch Google Picasa application using "Start > Programs > Picasa > Picasa"  menu, or double-click the 
Picasa icon in the tray (Picture No. 3). Browse to the folder which contains your designs. After a short while 
which is needed by Picasa for indexing new images you will see the design images. Google Picasa allows to 
view all folders in one place - just scroll the vertical bar at the right side of screen and locate the image you 
are searching for.  

Picture No. 3 
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5 - Double-click the image to find more information about design - the size, number of stitches and colors 
(Picture No. 4).  

Picture No. 4 
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Embird Indexer for Google Desktop  

Embird Indexer for Google Desktop is Embird Iconizer add-on which integrates with Google Desktop 
application. Google Desktop is free application developed by Google company (http://www.google.com) and 
it allows to search your computer as easily as you search the web with Google internet search engine. 
Starting with Embird 2006 Build 6, Embird Indexer is included in Iconizer plug-in. This means that it works in 
full mode only if you have registered Iconizer plug-in, otherwise it will work only in Demo mode. Embird 
Indexer allows you to easily search for your embroidery designs on your hard disk, it supplies important 
information about the designs to Google Desktop, e.g. stitch count, color count, design size, hoop size, design 
thumbnail, etc. (see Picture No. 5 below) 
 
Note: Before you start using Embird Indexer, you must install Google Desktop application on your PC, which 
is available at http://www.googledesktop.com. 
 
Hint: It is recommended to move all your designs into the sub-folder of "My Documents" folder in your user 
profile. Otherwise it might happen that Google Desktop will not index your designs which are stored in some 
other folder. We recommend to create folder "My Designs" under "My Documents" and keep all embroidery 
designs in sub-folders of "My Designs" folder. Another way how to force Google Desktop to index some 
specific folder is to use special utility "Tweak GDS" which you can download at 
http://desktop.google.com/plugins/i/tweakgds.html 
 
Warning:  At the time of writing this tutorial, Google Desktop version 5.1.0703.13372-en-pb has a bug, 
which causes that only designs with lowercase extension are correctly indexed (for example, SQUIRREL.dst is 
indexed correctly, but SQUIRREL.DST is not). As a temporary workaround for this bug we have prepared 
simple utility which is capable of lowercasing all files stored in chosen folder and all its sub-folders. You can 
download this utility by clicking here. After downloading, run this file and choose the folder which contains 
files with your designs. 
 
To enable Embird Indexer for Google Desktop, please make sure that Google Desktop is already installed 
on your PC and then follow these steps:  

1 - Run Embird, it will start in "Manager" mode 
2 - Select "Options > Iconizer Settings" menu (Picture No. 1).  

Picture No. 1  

 

3 - The "Iconizer Settings" dialog box will appear on the screen. Select the extensions which you would like 
to integrate with Microsoft® Windows® Explorer and with Google Desktop in the upper box. Make sure 
that the "Enable Indexer for Google Desktop" option is ON (Picture No. 2). Confirm these new settings by 
clicking "OK" button.  
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Picture No. 2  

 

4 - Another dialog box will appear on the screen, click "OK" button to allow the integration of Embird Indexer 
with Google Desktop (Picture No. 3). 

Picture No. 3 

 

5 - Now you should run re-indexing of your files so that Google Desktop indexes newly supported files - 
embroidery designs. Click right mouse button on the Google Desktop icon in the tray at the right bottom 
corner of the screen, and select "Indexing > Re-Index" menu (Picture No. 4).  

Picture No. 4 

 

6 - When the re-indexing is finished, you can try to search for some of your designs. In this example we have 
searched for "ROSE" designs on our hard disk using Google Desktop. Embird Indexer has supplied the design 
information and the thumbnail to Google Desktop  (Picture No. 5).  
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Picture No. 5 

 

7 - Click the "Preview" link near the "+" button to see more information about the design (Picture No. 6).  

Picture No. 6 
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Embird Quick Viewer 

The following tutorial explains how to use the Embird Quick Viewer in conjunction with Total 
Commander application. Before you start to use this feature, you must first download and install the Total 
Commander application to your PC. 

Note: Total Commander is a stand alone file manager for Windows similar to Windows Explorer. It is 
developed by Christian Ghisler, who is not affiliated with Embird. More information, demo, registration and 
support for Total Commander are available at http://www.ghisler.com  

1 - Run Embird, it will start in "Manager" mode.  
2 - Click "Options -> Iconizer Settings" menu. A dialog box will appear on the screen, containing the "Enable 
Viewer for Total Commander" option (Picture No. 1). Set this option to ON to enable the Embird Quick 
Viewer for all extensions selected in the upper list (which also specifies the extensions that are handled by 
Embird after double-click in Microsoft® Windows® Explorer - see also Iconizer tutorial). Click "OK" button to 
confirm the new settings. 

Picture No. 1  

 

3 - If you are going to launch the Total Commander from Embird for the very first time, you must specify the 
location of this application so that Embird is capable of launching it. Select "Options -> Plug-ins Paths" menu, 
this will display a dialog box on the screen, in which you can specify the path to the Total Commander 
application (Picture No. 2). Click "OK" button to confirm the new settings. 

Picture No. 2  
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4 - Click "Launch Total Commander" menu to start the Total Commander application (Picture No. 3). 

Picture No. 3 

 

5 - The Total Commander window will appear on the screen (Picture No. 4). The currently chosen folder in 
Embird's Right Panel will be automatically open in the right panel of Total Commander (in this example it is 
"C:\Program Files\EMBIRD32\FILES" folder). 
6 - Move the mouse pointer to the name of the file which you want to open in Embird Quick Viewer and click 
left mouse button to focus this file. In this example it is "DAFFODIL.DST" file (Picture No. 4). 

Picture No. 4 

 

7 - Depress the "F3" key on the keyboard, or click the "F3 View" button located at the bottom of Total 
Commander window. This will display the focused file in Embird Quick Viewer window (Picture No. 5). To 
close this window, depress the "ESC" key on the keyboard. 
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Picture No. 5 

 

8 - Depress the "Ctrl+Q" key combination on the keyboard, or choose "Show > Quick View Panel" menu. This 
will display the quick view of focused file in opposite panel (Picture No. 6). To close this panel, depress the 
"Ctrl+Q" key combination on the keyboard again. 

Picture No. 6 
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9 - Select "Show > Thumbnail View" menu for displaying the thumbnails of embroidery designs 
(Picture No. 7). 

Picture No. 7 

 

10 - Use "Show > Custom Column Mode" menu to configure the panel with your custom columns (Picture No. 
8). Embird plug-in for Total Commander "embirdcx" allows you to add the following columns: "Width", 
"Height", "Stitches", "Colors", "Thread changes", "Hoop width" and "Hoop height". 

Picture No. 8 
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Encapsulation of Floppy Disk 

This tutorials explains how to encapsulate the contents of a floppy disk. Encapsulation of floppy disk is 
useful when you need to transfer the whole contents of non-standard floppy disk (e.g. Barudan FDR, 
Barudan FMC, ZSK, etc.) via Internet to your customer who does not have Embird software and needs only 
the right floppy disk for sewing.  
 
Non-standard floppy disks are disks with designs stored in special format. These disks are not recognized 
and cannot be accessed in Windows Explorer or in common file manager - these applications report "Disk is 
not formatted" error when you attempt to read floppy disk contents. In Embird you can access non-standard 
floppy disks via Left Panel menu of Manager window. However, the non-standard floppy disk formats require 
low-level access and therefore the non-standard floppy disks are supported only when running Embird in 
Windows 98 or Windows ME. Embird does not support non-standard floppy disks when running in Windows 
NT, 2000 or XP. 
 
During the encapsulation process, Embird will prepare stand alone executable file (.EXE) which you can 
attach to the e-mail  and send to your customer. After running this file at the recipient's PC, it will format the 
floppy disk and write the whole contents to the floppy disk. This is explained in Decapsulation of Floppy Disk 
tutorial. 
 
Follow these steps to encapsulate the floppy disk: 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Insert the floppy disk into the floppy disk drive. Write your designs to this floppy disk using the steps 
explained in Writing Designs to Floppy Disk tutorial.  
3 - Select "Left Panel -> Encapsulate Floppy Disk" menu (Picture No. 1).  

Picture No. 1  

   

4 - A dialog box will appear on the screen (Picture No. 2). Click "Start Encapsulation" button.  

Picture No. 2  
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5 - Choose the file name for the executable file which are you going to create. In this example, we are 
encapsulating floppy disk which contains three roses design, therefore the name of the file is "ROSES.EXE" 
(Picture No. 3). Click "Save" button after choosing the right name for your file.  

Picture No. 3  

   

6 - Click "OK" button in the dialog box which prompts you for inserting the floppy disk into drive A: (Picture 
No. 4).  

Picture No. 4  

   

7 - The encapsulation process will start (Picture No. 5). Wait until the whole contents of the floppy disk is 
encapsulated into "ROSES.EXE" file.  

Picture No. 5  

   

8 - The executable file is now ready for sending to your customer. Run your e-mail client software and attach 
this file to your message. 
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Exporting Animated Images 

The following tutorial explains how to create animated images of designs in Embird 2006 or later. Use 
animated images if you want to prepare advertisement for the web site presenting your designs, or use it as 
another form of documentation if you are sending desings to your customers in e-mail.  

1 - Run Embird, it will start in "Manager" mode.  
2 - In the "Files:" box at the right side of the screen select the design. To select a design, please move the 
mouse pointer to its file name and click the left mouse button (Picture No. 1).  

Picture No. 1  

 

3 - Click "Right Panel -> Export -> Export Animated Image" menu to create the animated .GIF file of the 
selected design (Picture No. 2). 

Picture No. 2 

 

4 - Another dialog box will appear on the screen, allowing you to specify the properties of the animated 
image: its width and height, the delay between images, the delay after finished design and the stitch rate 
(cadence) of image generation (Picture No. 3). Click "OK" button to continue. 
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Picture No. 3 

 

5 - The animated image will be created after a short while, and another dialog box will appear on the screen. 
Choose the destination folder and filename for the image and then click "OK" button to save it (Picture No. 4). 

Picture No. 4 

 

6 - Now you can insert the image to your web site project, or send it in e-mail. Wait 3 seconds for animation - 
the delay specified in step 4. 

Picture No. 5 

 



 101 

Exporting Screen Saver 

The following tutorial explains how to create screen saver file for Windows (.SCR) in Embird 2006 or later. 
Embird screen saver displays the simulation of sewing of selected designs when the computer is idle.  

1 - Run Embird, it will start in "Manager" mode.  
2 - In the "Files:" box at the right side of the screen select the design of which you want to create the screen 
saver. To select a design, please move the mouse pointer to its file name and click the left mouse button 
(Picture No. 1).  
 
Note: You can select multiple files if you want to create single screen saver which simulates sewing of several 
designs. To select multiple designs, please move mouse pointer to the file name of the first design in the 
"Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving the 
mouse pointer over the file names of the other designs. When the mouse pointer is over the last design, 
please release the left mouse button.  

Picture No. 1  

 

3 - Click "Right Panel -> Export -> Export Screen Saver" menu to create the screen saver file of the selected 
design (Picture No. 2). 

Picture No. 2 
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4 - Embird will prepare the screen saver and after a short while the "Save As" dialog box will appear on the 
screen, allowing you to save the screen saver file to chosen folder on your hard disk. Choose "C:\WINDOWS" 
folder (or "C:\WINNT" in case you have Windows NT installed on your PC) to immediately install your screen 
saver into Windows. Click "OK" button to continue. 
 
Tip: Click "Preview" button in the "Save As" dialog box if you want to test the screen saver before saving. 

Picture No. 3 

 

5 - The screen saver will be saved and install into Windows and is ready to use. Click "Start -> Settings -> 
Control Panel -> Display" menu to open the dialog box with Display properties. On the "Screen Saver" tab 
choose the new screen saver from the list of available options (Picture No. 4). 

Picture No. 4 
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6 - Click "Settings" button if you want to modify some properties of the screen saver, such as "drawing style", 
"speed of simulation", "background color", etc. (Picture No. 5). Confirm the new settings by clicking "OK" 
button. 

Picture No. 5 

 

7 - When the computer is idle, the screen saver will start and the simulation of sewing of selected design will 
be shown on the screen (Picture No. 6). 

Picture No. 6 
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Exporting Simple Documentation 

1 - Run Embird, it will start in "Manager" mode. 
2 - Use "Drive", "Folder" and "Files" boxes (located on the Right Panel at the right side of the screen) and 
choose the folder with embroidery designs, e.g. "C:\EMBIRD32\FILES" folder in this example. In case you are 
using Embird 2006 or later, you will find some free designs in "C:\Program Files\EMBIRD32\FILES" folder. 
3 - In the "Files" box select the design of which you want to create the simple documentation (Picture No. 1).  
 
Note: To select multiple designs, please move mouse pointer to the file name of the first design in the 
"Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving the 
mouse pointer over the file names of the other designs. When the mouse pointer is over the last design, 
please release the left mouse button.  

Picture No. 1  

 

4 - Once the design is selected, click "Right Panel" menu and choose "Export -> Export Simple 
Documentation" command (Picture No. 2).  

Picture No. 2  

 

5 - Embird will process the design and after a short while the dialog box will appear on the screen. Click 
"Preview" button if you want to check the exported simple documentation (Picture No. 3). 
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Picture No. 3 

 

6 - Click "Close" button to close the preview window and return to "Save As" dialog box (Picture No. 4).  

Picture No. 4 

 

7 - Choose the file format for images in "Save file as type" box. You can choose between .BMP and .JPG 
formats. File size of image stored in .JPG file is smaller than the file size of image stored in .BMP file. On the 
other hand it takes more time to create the file with .JPG extension, because it contains compressed image 
(Picture No. 5). 
8 - Finally, click "All" button to create simple documentation of all selected designs. In case you have selected 
only single design, click "OK" button. Images will be stored in the same folder as the designs, i.e. to 
"C:\EMBIRD32\FILES" folder in this example (Picture No. 5).  

Picture No. 5 
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File Summary Info 

Use this command if you want to edit the summary information of the design. This allows you to 

add the "Title", "Subject", "Author", "Category", "Keywords", "Revision Number" and 

"Comments" to your design. These information will be displayed in the yellow hint when you 

display the design in Manager and place the mouse pointer on the preview area. Also, once you 

add the summary information to your designs, you can use the "Right Panel -> Folder 

Operations -> Search" command to search for design with specified "Keyword", etc. (see also 

Search Files tutorial). 

 

Warning: File Summary Info command works only on PCs with Windows 2000 and Windows 

XP, and only with disks formatted with NTFS file system (i.e. it does not work with FAT 

system).  

 

Note: The "File Summary Info" will be lost if you copy the design from NTFS disk to e.g. FAT 

disk, because FAT disks do not support the streams required for storing the info. 

 

1 - Run Embird, it will start in "Manager" mode. 

2 - In the "Files:" box at the right side of the screen select the design whose "Summary Info" 

you want to modify. To select a design, please move the mouse pointer to its file name and click 

the left mouse button (Picture No. 1). 

 

Note: You can select multiple files if you want to set the same summary information to several 

designs. To select multiple designs, please move mouse pointer to the file name of the first 

design in the "Files:" box at the right side of the screen, depress the left mouse button and hold 

it down while moving the mouse pointer over the file names of the other designs. When the 
mouse pointer is over the last design, please release the left mouse button.  

Picture No. 1  

   
3 - Select "Right Panel -> File Summary Info" command from main menu (Picture No. 2).  
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Picture No. 2  

   
4 - The "File Summary Info" dialog box will appear on the screen (Picture  No. 3). Enter the 
information and hit "OK" button to confirm these properties. 

Picture No. 3 

   
5 - Double click the file name in the "Files:" box to display it. The file summary information will 

be displayed at the bottom of the yellow hint, which appears when you move mouse cursor on 

the preview area (Picture No. 4).  

 

Note: In case the yellow hit does not appear after a while, switch ON the displaying of hints in 

"Options -> Show Hints" menu.  
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Picture No. 4 
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Font Engine Plug-in  

This tutorial explains how to use the Font Engine plug-in for Embird. This plug-in allows you to create 
lettering from TrueType and Open Type fonts, i.e. from fonts installed in your Windows system. You can even 
use fonts, which are not installed (to save system resources); find more information in the Font Engine Plug-
in - Using 'Not Installed' Fonts tutorial. In Font Engine, it is possible to create lettering with satin (auto-
column), plain and motif fills and with thin, satin and appliqué outlines.   

Note: If you want to use Font Engine, there is no special file to download and install. Font Engine plug-in is 
installed together with Embird software. However, you must pay for it if you want to use it. In other words, 
the registration fee for Embird does not cover the registration of Font Engine plug-in. 
 
Note: There are no TrueType nor Open Type fonts included in Font Engine. Font Engine is just engine, which 
is capable of converting these fonts into stitches.  

Read the following tutorial to find out how to create lettering in Font Engine:  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Font Engine Text" menu to create lettering from TrueType or Open Type fonts (Picture 
No. 1).  

Picture No. 1  

 

3 - Font Engine dialog box will appear on the screen (Picture No. 2). In the "Fonts" box you can choose the 
font which will be used for characters. The "Unicode" check box located above the "Fonts" box allows to 
switch between "normal" character sets and "Unicode" character sets (used usuallyl for Japanese and Chinese 
complex fonts). At the right side of the "Fonts" box, you can modify other font properties: Click "B" for bold 
font and/or "I " for italic effect. After choosing the font, you can type your text into the "Text" box at the 
bottom of the "Insert" tab.  
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Picture No. 2  

 

4 - Click the "Properties" tab to change the size, fill type, outline type, and other properties of lettering 
(Picture No. 3). If you want to change more fill and outline parameters, click "Parameters" button. 

Picture No. 3 

 

5 - Click the "Layout" tab to change the layout parameters of your lettering (Picture No. 4). For example, you 
can change the baseline, place the text on the other side of baseline, create bridge effect by choosing an 
"Envelope" style, etc.  
 
Note: There are several points shown on the layout area, allowing you the following:  
 
A. Use red points to move the character along the baseline. 
Depress CTRL key to move only selected character; otherwise, all characters placed after selected character 
will move. 
 
B. Use green points to rotate the character. 
Depress CTRL key to change the angle by 15 degrees. 
Depress ALT key to set the angle to 0 degrees. 
 
C. Use teal points to resize the character, either horizontally or vertically. 
Depress CTRL key to change the size in larger steps. 
Depress ALT key to maintain the aspect ratio of width and height. 
 
D. Use purple points to skew or mirror the character, either horizontally or vertically. 
Depress CTRL key to skew in larger steps. 
Depress ALT key to mirror the selected letter. 
 
Depress SHIFT key while moving the point to apply the operation to all characters.  
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Please note that undo/redo/reset operations are available for changes in Layout; use the buttons located 
below layout area.  

Picture No. 4 

 

6 - Finally, click "OK" button to create the lettering and insert it into Editor window (Picture No. 5).  

Picture No. 5 

 

7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  
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Font Engine Plug-in - Parameters of Text  

This tutorial explains how to adjust fill and outline parameters of Font Engine text. 
 
1. Parameters of Lettering Fill 
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Font Engine Text" menu to create lettering from TrueType and OpenType fonts installed 
on your computer (Picture No. 1). 

Picture No. 1 

 

3 - Type your text into the "Text" box at the bottom of the "Insert" tab (Picture No. 2). 

Picture No. 2 

 

4 - Select the "Properties" tab and set the size of characters in the "Size" box (Picture No. 3). 
 
Tip: Uncheck the "Keep ratio" box if you do not want to keep the aspect ratio, but you want to set the width 
and height independently. 
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5 - Choose the type of fill for lettering in the "Characters box" (Picture No. 3). 

Picture No. 3 

 

There are several fill and outlines types available there, allowing you to create a lot of lettering combination: 
 
Fill options: 
 
No fill - The interior of each character is empty, so the lettering consists only of outlines. 
 
Plain fill - Default plain fill is Fill 1, but different fill patterns can be selected by user in Parameters dialog 
box.  
 
Auto Column - Characters are filled by columns of satin stitches. 
 
Motif fill - Characters are filled with simple stitch forming some motif instead of dense parallel stitches. 

Outline options: 
 
No outline - Lettering is not outlined. 
 
Sketch - The outline resembles a very flat satin stitches.  It can be used for outlines that are thicker than 
running stitch outline and thinner than narrowest possible satin stitch outline. 
 
Sample -The chosen pattern is repeated along the outline. 
 
Satin outline - The zig-zag outline of constant width similar to column objects. 
 
Border - The outline is composed of pre-digitized objects. It can have outlines of separate color. 
 
Appliqué outline - The outline contains tack-down stitches of separate color to stitch appliqué fabric to the 
underlying fabric. 

Click the "Parameters" button, this will display a dialog box in which you can modify more settings 
(Picture No. 4). In this dialog box, the Fill icon (the left one below the "Parameters" button) shows the page 
containing the parameters of the fill, and the Outline icon (the right one below the "Parameters" button) 
shows the page containing the parameters of the outline. 

Click the "Fill" icon and choose some other type of fill (default is "Fill 1"). For example, choose the "Cusped 
Lines" fill (Picture No. 4). 
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Picture No. 4 

 

Note: The lettering size must be large enough, otherwise the fill pattern might be undistinguished 
(Picture No. 5). Choose the lettering height at least 2.5 cm (or 1 inch) to have the fill pattern noticeable 
(Picture No. 6). 

Picture No. 5 

 

Picture No. 6 

 

1.1 Plain Fill 
 
The other parameters of the plain fill such as pull compensation, density, angle of stitches, etc. are: 
 
Pull Compensation is extension of each stitch on edge of object in order to compensate for thread pull (on 
elastic fabric) or sinkage (on fleece).  The thread pull and sinkage causes that object is smaller (narrower) 
than intended. Normal value for pull compensation is 1 or 2. Use higher values (3, 4 or 5) for elastic fabric or 
fleece. These values are displayed in tenths of millimeter (1/10 mm). 
 
Density defines the distance between zig-zag stitches in tenths of millimeters (i.e. value 4 means 0.4 mm). 
The bigger number you specify the lower density and less stitches you obtain.  
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Angle of fill stitches is changed by clicking on circular angle indicator. 
 
Scale function is intended for enlarging or shrinking pattern of fill motif. 
 
Gradient affects the distance between rows of stitches or motifs within object. If density is 4.0 and gradient 
is 30.0, for example, the distance of rows will gradate from 0.2 mm to 15 mm according to set Gradient Type 
(Gradient Type box). 
 
Effect. Plain Fill and Motifs Fill may be combined with additional effects like Wave, Contour fill, Radial fill, 
Square fill and Rounded fill. Parameters of Wave can be adjusted by clicking on the wave control or by 
pressing mouse button on parameters values. Wave parameters define the curve of fill rows. Radial, Square 
and Rounded fill effects create stitches in a spiral starting from the 'Focus Point' of the object.  
 
Random Broadening defines maximum random prolongation of column stitches to side. This creates ragged 
edges effect on lettering. 
 
Random Shift randomizes pattern to allow user to create fur-like effects, for example. 
 
Edge Walk Underlay helps to make sharp edges of fill. 
 
Zig-Zag Underlays stabilize the fabric with a grid of loose stitches before sewing the higher density cover 
stitches. 
The angles of underlays can be set here. To change the angle click on circular angle indicator or press mouse 
button on the angle value. 
 
Note 1: Click the "Parameters" button at the top of the window to switch ON the Show More Parameters 
option. The "Show More Parameters" option must be ON to allow the user to adjust the angles and densities 
of zig-zag underlays. In case the "Show More Parameters" option is OFF the angles of zig-zag underlay are 
adjusted automatically according to angle of cover stitches.  
 
Note 2: The Edge and both Zig-Zag underlays can be usually turned ON on all Plain Fill objects because Font 
Engine ignores these underlays on small letters. Turn them OFF if you need to decrease the stitches number 
and/or the fabric is firm and does not need the stabilization. 
 
Complete row if density above option defines the density under which the last point on each row of 
stitches is omitted. If the last point is not omitted, the result would be stitches that may be too small on the 
edge of fill. This parameter is visible only if " Show More Parameters" option is ON. 
 
1.2 Auto Column 
 
Auto Column - Characters are filled by columns of satin stitches (Picture No. 7). 

Picture No. 7 

 

Note: It is not recommended to use satin stitches (auto column) longer than 1.2 cm (12 mm) - the widest 
part of letter should not be thicker than 12 mm. Satin stitch longer than 12mm is replaced with jump stitch 
and short running stitch. Jump stitches are not shown in 3D preview so the gaps appear in text preview 
(Picture No. 8). Embroidery machine will sew these jump stitches, but they might be too loose. It is 
recommended to use plain fill in this case (Picture No. 9).  
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Picture No. 8  

 

Picture No. 9 

 

The other parameters of the auto-column fill type (see Picture No. 10 below) are: 

Pull Compensation is extension of each stitch on edge of object in order to compensate for  thread pull (on 
elastic fabric) or sinkage (on fleece). The thread pull causes the ends of stitches are pulled inwards and object 
is smaller (narrower) than intended. 
 
Density defines the distance between zig-zag stitches in tenths of millimeters (i.e. value 4 means 0.4 mm). 
The bigger number you specify the lower density and less stitches you obtain. If the column object forms a 
bend, the distance on the inner curve is lower. 
 
Auto Select Column Underlay check box allows user to switch off the automatic program decision on what 
type of underlay will be used for the object. Then the Center, Edge and Zig-Zag check boxes allow user to 
choose which underlays will be used for the object. Density parameter indicates the density of the zig-zag 
underlay. These parameters are visible only if " Show More Parameters" option is ON. 
 
Use pattern option determines whether the Auto Column uses pattern set in Plain Fill pattern combo box or 
not. If it is switched OFF, the column stitches are without pattern. 

Picture No. 10 
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1.3 Motif Fill 
 
Motif fill - Characters are filled with simple stitch forming some motif instead of dense parallel stitches 
(Picture No. 11). 

Picture No. 11 

 

The other parameters of the motif fill type (see Picture No. 12 below) are: 
 
Shift defines movement of motifs in each row with respect to previous row. 
 
Scale parameter determines the size of the motif and consequently the length of fill stitches. 
 
Distant Motif Rows Jumps (if loose density) defines whether the jump (trim) or connection is inserted 
between distant rows of motifs or stitches. This parameter is visible only if " Show More Parameters" option is 
ON. 
 
Density is distance between motif rows measured in tenths of millimeters (i.e. density 160 means 16 mm 
distance between 2 rows). 
 
Pull Compensation is extension of each stitch on edge of object in order to compensate for thread pull (on 
elastic fabric) or sinkage (on fleece).  The thread pull and sinkage causes that object is smaller (narrower) 
than intended. Normal value for pull compensation is 1 or 2. Use higher values (3, 4 or 5) for elastic fabric or 
fleece. These values are displayed in tenths of millimeter (1/10 mm). 
 
Angle of fill stitches is changed by clicking on circular angle indicator. 
 
Gradient  affects the distance between rows of stitches or motifs within object. If density is 4.0 and gradient 
is 30.0, for example, the distance of rows will gradate from 0.2 mm to 15 mm according to set Gradient Type 
(Gradient Type box). 
 
Effect.  Plain Fill and Motifs Fill may be combined with additional effects like Wave, Contour fill, Radial fill, 
Square fill and Rounded fill. Parameters of Wave can be adjusted by clicking on the wave control or by 
pressing mouse button on parameters values. Wave parameters define the curve of fill rows. Radial, Square 
and Rounded fill effects create stitches in a spiral starting from the 'Focus Point' of the object.  

Picture No. 12 
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2. Parameters of Lettering Outline 
 
6 - Choose outline type for lettering in the "Characters box" (Picture No. 3 above). Default setting is "Sample" 
outline, Single Stitch. 
 
Click the " Parameters" button, this will display a dialog box in which you can modify more settings (Picture 
No. 13). In this dialog box, the Fill icon (the left one below the "Parameters" button) shows the page 
containing the parameters of the fill, and the Outline icon (the right one below the "Parameters" button) 
shows the page containing the parameters of the outline. 
 
Click the "Outline" icon to switch to the page containing the parameters of outlines (Picture No. 13). 

Picture No. 13 

 

2.1 Sketch Outline 
 
Sketch - This outline resembles a very flat satin stitches.  It can be used for outlines that are thicker than 
running stitch outline and thinner than narrowest possible satin stitch outline (Picture No. 14, Picture No. 15). 

Picture No. 14 
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Picture No. 15 

 

2.2 Samples Outline 
 
Samples - The chosen pattern is repeated along the outline (Picture No. 16, Picture No. 17). 

Picture No. 16 

 

Picture No. 17 

 

The other parameters of Sketch and Samples outline are: 

Width - This parameter is common for all five outline types. Width is the width of reference cells along the 
outline to which the stitches are projected. It is not necessarily the width of finished outline, because 
projected stitch sample can be wider or narrower than reference cells. The bigger value you adjust the thicker 
outline you get. 
 
Min. Length and Max. Length - When user changes the sample, program automatically sets these two 
parameters together with width to values default for this sample. However, user can change these 
parameters. 
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2.3 Satin Outline 
 
Satin outline can be used to create zig-zag outline of constant width similar to column objects (Picture No. 
18). 

Picture No. 18 

 

2.4 Border Outline 
 
Border is composed of pre-digitized objects. It can have outlines of separate color (Picture No. 19, Picture 
No. 20). 

Picture No. 19 

 

Picture No. 20 
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2.5 Appliqué Outline 
 
Appliqué outline contains tack-down stitches of separate color to stitch appliqué fabric to the underlying 
fabric. Program automatically sets "No fill" option when user selects Appliqué outline (Picture No. 21, Picture 
No. 22). 

Picture No. 21 

 
 

Picture No. 22 
 

 
 
The other parameters of Satin, Border and Appliqué outlines are: 
 
Density parameter defines the maximum distance between stitch samples. If the Outline object forms a 
bend, the distance on the inner side is lower. 
 
Pull Compensation is extension of each stitch on edge of object in order to compensate for thread pull (on 
elastic fabric) or sinkage (on fleece). The thread pull causes the ends of stitches are pulled inwards and object 
is smaller (narrower) than intended. 
 
Auto Select Underlay check box allows user to switch off the automatic program decision on what type of 
underlay will be used for the object. The Center, Edge and Zig-Zag check boxes allow user to choose which 
underlays will be used for the object. Density parameter indicates the density of the zig-zag underlay. 
 
Border sample length defines the size of samples along the outline.  
 
Tip: You can save the adjusted fill and outline parameters as default. Click "Parameters" button located at the 
top of parameters dialog box and select "Save as Default" menu. Parameters are saved as default separately 
for fill (Picture No. 23) and for outline (Picture No.  24). The "Reset Default" function serves for erasing 
setting saved as default and returning to original setting (plain fill-fill1, sample outline-single stitch). 
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Picture No. 23 

 

Picture No. 24 

 

7 - The "Fill exterior" option allows to create empty characters surrounded with fill (Picture No. 25). 
Adjustable border of exterior fill  is measured in tenth of millimeters. Fill is outlined  with selected outline 
(Picture No. 26, Picture No. 27). 
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Picture No. 25  

 

Picture No. 26  

Lettering created with "Fill exterior" option and "Floating stitches" connection type  
(see "Insert" tab in Picture no. 2)  

 

Picture No. 27 

Lettering created with "Fill exterior" option and "Floating stitches (solid)" connection type 
(see "Insert" tab in Picture no. 2) 
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Font Engine Plug-in - Using 'Not Installed' Fonts  

This tutorial explains how to use Font Engine plug-in with fonts which are not installed in Windows 
system. All fonts which are installed in Windows use system resources and therefore they slow down the 
whole operating system. However, Font Engine plug-in is capable of supporting those fonts which are not 
installed in Windows system. This means that you can use hundreds of fonts you have stored on your CD, 
DVD or on your hard disk. 
 
Note: There are no True Type nor Open Type fonts included in Font Engine. Font Engine is just the engine, 
which is capable of converting fonts you acquire into stitches.   

Read the following tutorial to find out how to use not installed fonts in Font Engine:  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Font Engine Text" menu to create lettering from True Type or Open Type fonts (Picture 
No. 1). Please note the two buttons located at the right side of the "Fonts" box. The first one allows you to 
specify three folders with your "not installed" fonts. Embird will scan these folders and all their sub-folders for 
fonts and add found fonts to the "Fonts" box once the scanning is finished. Use the second button for 
scanning folders for new fonts (use it only when you copy some new fonts to these folders and you want to 
let Embird know about the changes).  

Picture No. 1  

 

3 - Click the first button to specify your folders containing "not installed" fonts. A dialog box will appear on the 
screen, allowing you to choose three folders (Picture No. 2). It is recommended that you copy your fonts to 
"C:\Program Files\EMBIRD32\FONTS" folder (or to "C:\EMBIRD32\FONTS" folder if you use version prior to 
Embird 2006), but you can choose any other folder on your hard disk.  

Note: Embird will not copy the fonts; it assumes that you already have them in these folders. Please use 
Windows Explorer to copy the fonts into the folders before running Embird.  

Picture No. 2  
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4 - Click the small "folder" button (Picture No. 2) to choose the folder from the list (Picture No. 3). 

Note: Embird will scan this folder and also all its sub-folders for fonts. In this example, we want to support 
"not installed" fonts stored on the CD-ROM (the CD must be inserted in the D: drive). 

Picture No. 3 

 

5 - Embird will add the "D:\" folder to the dialog box (Picture No. 4). The "Search for fonts also in ZIP and 
RAR archives" option allows you to enable/disable the searching for fonts in compressed files.  

Picture No. 4 

 

6 - Click "OK" button to confirm the new settings. The scanning process will start (Picture No. 5). Please wait 
until it is finished; it may last for several minutes, depending on the number of fonts you have stored in the 
chosen folders.  

Picture No. 5 

 



 126 

Picture No. 6 

7 - Once the scanning process is finished, the recognized fonts will be added to the " Fonts" box and you can 
use them as normally installed fonts (see also Font Engine Plug-in tutorial). The "not installed" fonts are 
drawn in blue color in the "Fonts" box. 
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Formatting Floppy Disk  

Embird supports standard and non-standard floppy disk formats.  
 
Standard floppy disks are disks with designs stored in standard MS-DOS format. These disks are recognized 
and can be accessed in Windows Explorer, common file manager or any other application supporting floppy 
disks. In Embird you can access standard floppy disk by choosing the disk drive (typically "A:") in "Drive:" box 
in Right Panel of Manager window. 
 
Non-standard floppy disks are disks with designs stored in special format. These disks are not recognized 
and cannot be accessed in Windows Explorer or in common file manager - these applications report "Disk is 
not formatted" error when you attempt to read floppy disk contents. In Embird you can access non-standard 
floppy disks via Left Panel menu of Manager window. However, the non-standard floppy disk formats require 
low-level access and therefore the non-standard floppy disks are supported only when running Embird in 
Windows 98 or Windows ME. Embird does not support non-standard floppy disks when running in Windows 
NT, 2000 or XP. 
 
Formatting Standard Floppy Disks (MS-DOS Format) 
 
Format standard floppy disk using Windows formatting commands: 
 
1 - Insert the floppy disk into the disk drive. Make sure, that the disk is not write-protected. 
2 - Click "My Computer" icon located on the Desktop. A window containing all available drives will be shown 
on the screen. 
3 - Right click the icon which represents the floppy disk drive (typically "A:"). This will display a popup menu. 
4 - Choose "Format" command from the popup menu. A dialog box will appear on the screen, allowing you to 
choose the formatting options. 
5 - Choose the right disk capacity and click "Start" button to start the formatting process. 
 
Note 1: In case of "Tajima" disk, use 2DD (double-sided double-density) floppy disks and always specify 
"TAJIMA" label in the format dialog box. Floppy disk without this label might be not recognized by the 
embroidery machine. 
 
Note 2: You can format also standard floppy disks in Embird by using the steps explained below for non-
standard floppy disks - just choose "Standard Floppy Disk" option in step 3. 
 
Formatting Non-Standard Floppy Disks (e.g. Barudan, ZSK) 
 
Non-standard floppy disks cannot be formatted using Windows formatting commands. Use the following 
steps: 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select "Left Panel -> Format Floppy Disk" command from the main menu (Picture No. 1).  

Picture No. 1  
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3 - Choose the floppy disk format in the dialog box which appears on the screen (Picture No. 2). Click "OK" 
button to continue.  

Picture No. 2  

 

4 - Insert the floppy disk into the disk drive. Make sure, that the disk is not write-protected (Picture No. 3). 
Click "OK" button to continue. 
 
Note: Embird will either ask you for 2DD (double-sided double-density, 720 kB) or 2HD (double sided high-
density, 1.44 MB) floppy disk, depending on the format you choose in step 3. Make sure, that you are 
inserting the right type of disk. 

Picture No. 3 

 

5 - Note, that all files already stored on the floppy disk will be erased during the formatting process (Picture 
No. 4). If you agree, click "Yes" button to continue.  

Picture No. 4 
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6 - The formatting process will start (Picture No. 5). Wait until the floppy disk is formatted to 100%.  

Picture No. 5 

 

7 - Once the formatting is finished, a dialog box will appear on the screen, showing the result of the 
operation. Click "OK" button (Picture No. 6).  

Picture No. 6 

 

8 - Floppy disk is now formatted and ready for use - now you can write the designs to it. Find more details in 
Writing Designs to Floppy Disks tutorial. 
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How to Start with Embird 

Step 1 - Downloading Embird 
 
1 - Run your internet browser and open the download page of Embird software 
(http://www.embird.com/sw/embird/down.htm).  
2 - When this page is loaded, click the bold underlined text "Embird" to download installation files of Embird 
to your computer (Picture no. 1). 

Picture No. 1 

 

3 - Wait until the downloading process is finished. 
4 - Check the size of downloaded installation file on your hard disk to find out whether this file is complete. 
The amount of bytes of the downloaded installation file must be exactly the same as it is declared on our 
download web site (see Picture No. 1 above, 9 589 760 bytes in this example). You can check the file size in 
Windows Explorer - find more details about this topic in your Windows User Manual. 
 
Warning: Most problems with downloading are caused by premature termination of download process. When 
the downloading lasts too long, the process might be interrupted. The downloaded installation file is 
incomplete and cannot be used. Unfortunately, some internet browsers do not delete these incomplete files, 
nor display any error message, and users consider the file to be complete. Therefore, we strongly recommend 
you use a download manager offering more sophisticated downloading and capable of continuing with 
downloading even after interruption. One such software is GetRight® software; a free, fully functional demo 
available at http://www.getright.com. 
 
Note: Sometimes we offer for downloading not only the "regular" version of program, but also the "beta" 
version of program. The beta version is version in the development. Use this version in case that you want to 
test the new functions. Beta version is intended for skilled users of Embird, not for beginners. By its very 
nature, beta software may contain bugs and have errors or incomplete features that may have a detrimental 
effect on the software program itself, upon the files on your computer and/or upon your computer.  
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Step 2 - Embird Installation 
 
5 - To install Embird on your computer run the saved installation file in Windows: Select Start -> Run -> 
Browse -> browse to the folder with downloaded installation file of Embird and select this file, then click "OK" 
button to continue.  
6 - The installation process will start and the Embird setup window will appear on the screen. Follow the steps 
displayed in this window to install Embird on your computer. 
7 - When the installation process is finished, the "Installation was successful" message will appear on the 
screen and the icon for launching of Embird will appear on your desktop. 
 
Step 3 - Testing Embird 
 
8 - Unless you have already inserted the password into Embird, it will run in demo (evaluation) mode. Demo 
of Embird is fully functional 30 days or 100 runs, whatever comes first. You have a lot of time to find out 
whether Embird meets all your needs or not. After this period, you will have to insert the registration 
password into Embird to turn it into full version, otherwise the demo will expire. 
 
Embird tutorials are available at http://www.embird.com/sw/embird/tutorial.htm 
The manual of Embird in Adobe Acrobat .PDF format are available for free downloading at 
http://www.embird.com/sw/embird/tutordown.htm 
Free tutorial plug-ins for Embird are available at http://www.embird.com/sw/embird/down.htm 
 
You can test all features Embird also when the demo is expired (i.e. after 30 days or 100 runs after 
installation), but only with our free designs stored in the "C:\Program Files\EMBIRD32\FILES" folder (or in 
"C:\EMBIRD32\FILES" folder if you are using version prior to Embird 2006) on your hard disk. 
 
Step 4 - Testing Embird Plug-ins 

9 - Use similar steps as explained in sections 1 and 2 above to download and install Embird plug-ins 
(Alphabets, Digitizing Studio).  Alphabets can be downloaded in all-in-one installation file (containing all 
available alphabets), or each Alphabet separately. 
 
Note 1: Installation files of Embird include also installation of Iconizer, Cross Stitch and Font Engine plug-ins. 
There are no separate installation files for these plug-ins available, because these plug-ins are installed at the 
same time as Embird main program. 
 
Note 2: Installation file of Studio includes  installation of Digitizing Tools plug-in and Sfumato Stitch plug-in. 
 
Demo of Embird plug-ins are not limited by time period or number of runs, but their function is limited: 

• Demo of Sfumato Stitch, Digitizing Tools and Cross Stitch plug-in has stitch and saving limit  
• Demo of Alphabets and Font Engine plug-in is limited to 6 characters (3 capitals, 3 lower cases)  
• Demo of Iconizer plug-in displays embroidery files of 50% of randomly chosen designs  

Demo versions of all Embird plug-ins are functional also with demo version of Embird basic software. In other 
words, it is not necessary to register Embird basic software to test the plug-ins. 
 
Step 5 - Registration of Embird and its Plug-ins 
 
Please be sure before registration that you tested Embird and its plug-ins and you have found 
out that they meet your needs. Be aware that there is no refund on registered Embird and/or 
plug-ins. 
 
You will receive the passwords in e-mail after purchasing Embird and/or plug-ins at 
http://www.embird.com/sw/embird/register.htm within one working day. 
 
Note: There are no special installation files for registered users. Demo (evaluation) version of main program 
and plug-ins will change into the full versions after inserting the registration password. In other words, there 
is only single installation file for Embird, which runs in demo mode until you insert the passwords and unlock 
it for running in full mode. 
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Iconizer Plug-in  

This tutorial explains how to use the Iconizer plug-in. Iconizer plug-in works together with Microsoft® 
Windows® Explorer, the application which is present in every installation of Windows version 95 and above. 
The principle of Iconizer plug-in is simple: Normally, when you run Explorer and you are not using the 
Iconizer plug-in, each design file is represented by universal "type" icon (Picture No. 1). Registered Iconizer 
plug-in will show a small icon of the design contents instead (Picture No. 2). This allows you to browse and 
sort your designs easily, because you can see the contents of each design file while using all the great 
features of Microsoft® Windows® Explorer./  

Picture No.1              Picture No.2  

                  

Note: Iconizer plug-in supports only those embroidery formats and image formats which are supported in 
Embird software.  

 
Please read the guide below to find out how to install and use the Iconizer plug-in:  

1 - The installation file for Iconizer plug-in is contained in Embird setup file, so there is no special file to be 
downloaded. During the Embird setup process, the "Shell Integration Setup" dialog box will appear on the 
screen (Picture No. 3).  
2 - Choose "Unused" option and switch off the "Enable Iconizer" box. Hit "OK" button to finish the 
installation.   

Picture No. 3  
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3 - Run "Embird" and click on the "eXplorer" menu. This will launch Microsoft® Windows® Explorer. 
4 - In Explorer, browse to the folder with the designs, e.g. to "C:\Program Files\EMBIRD32\FILES" folder (or 
into "C:\EMBIRD32\FILES" folder if you use version prior to Embird 2006). This folder contains some free DST 
designs, and because the setup have integrated the DST extension to shell with a link to Embird, the designs 
will look like those on Picture No. 4. The Iconizer plug-in is disabled now, because we have chosen this option 
in step 1.  

Picture No. 4  

 

5 - Close the Explorer window. 
6 - In Embird, click on "Options" menu and choose the "Iconizer Settings" command. A dialog box will appear 
on screen (Picture No. 5). You will see that there are 2 lists of extensions in this box. The first list allows you 
to choose which files should be open in Embird when you double-click on them in Explorer. The second list 
allows you to choose which files will be handled by Iconizer. In the example on picture No. 5, the .HUS 
files will be shown as icons in Explorer, but the double-click on .HUS file will not open the file in Embird. If 
there is some other application associated with .HUS extension on your computer (e.g. Husqvarna 
Customizing Software), the design will be open in this application after double-click in Explorer. To enable 
Iconizer for all supported formats, click on "Select all (Enable Iconizer for all)" button located below the 
second list of extensions. Hit "OK" button to confirm the settings, this will close the dialog box.  

Picture No. 5 
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7 - Click on "eXplorer" menu to launch the Explorer again. 
8 - In Explorer, browse to the "C:\Program Files\EMBIRD32\FILES" folder again (or browse into 
"C:\EMBIRD32\FILES" folder if you use version prior to Embird 2006). Now the Iconizer plug-in is enabled and 
the designs will look like those on Picture No. 6.  

Note: You must purchase and register the copy of Iconizer plug-in, otherwise only several icons will be 
showing designs contents. All the others will display the universal "type" icon (Picture No. 7). You can 
purchase the Iconizer plug-in at http://www.embird.com/sw/embird/register.htm. Use the "eXplorer" menu to 
enter the registration number into the Iconizer . This will display a dialog box allowing you to type in the 
registration number. 

Picture No. 6 

  

Picture No. 7 

 



 135 

9 - When you move the mouse cursor to some of the designs in Explorer, and you depress the right mouse 
button, the popup menu will appear (Picture No. 8). There are four commands available - "Open", "Print", 
"Convert" and "Edit". You can choose any of them to launch Embird and perform the operation. In case you 
have enabled the Iconizer for this design format, you will also see the design image in the popup menu. The 
size of this image can be changed in "Options -> Iconizer Settings" menu in Embird (Picture No. 5). The 
Iconizer in popup menu can be disabled by unchecking the "Enable Images in Popup Menu" option in 
"Iconizer Settings" menu (see Picture No. 5 above).  

Picture No. 8 

 

Tips: 
 
1 - Use the "Icons" view mode to obtain the best results, otherwise the icons are too small. In Explorer, click 
on "View -> Icons" command. (Picture No. 9). Please note that you can have also larger icons: Specify the 
icon size in "Iconizer Settings" dialog box (Picture No. 5). The default size for large icons is 32.  

Picture No. 9 
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2 - In Windows ME, 2000 and XP there is another view mode available in Explorer: "Thumbnails" (Picture No. 
10). Choose this mode using the "View -> Thumbnails" command in Explorer (Picture No. 9). The Iconizer in 
"Thumbnails" view mode can be disabled by unchecking the "Enable Thumbnails" option in "Iconizer Settings" 
dialog box (see Picture No. 5 above).  

Picture No. 10 

  

3 - In Windows 2000 and XP there is another view mode available in Explorer: "Tiles" (Picture No. 11). 
Choose this mode using the "View -> Tiles" command in Explorer (Picture No. 9).   

Picture No. 11 

  

4 - Another view mode available in Windows XP is "Details". Make sure the "Enable Columns" option is set to 
ON in "Iconizer Settings" dialog box (see Picture No. 5 above) and in Explorer select "View -> Choose Details" 
menu. (Picture No. 12). The "Choose Details" dialog box will appear on the screen, in which you can select 
which columns are visible in "Details" view mode. Check ON the  "Design Information" option at the end of 
the list (Picture No. 13) and confirm the new settings by clicking OK button. Finally, select "View -> Details" 
menu to switch the view mode. Note the last column showing the design properties - its size, stitch count and 
number of colors (Picture No. 14). 
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Picture No. 12 

  

Picture No. 13 

  

Picture No. 14 
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5 - Registered users of Iconizer plug-in can also allow displaying of design icons in "Files" box located on right 
panel in Embird. (Picture No. 15). Use the small check-box above "Files" box to allow this option, or the 
"Preview Files" command in "Right Panel" menu.  

Picture No. 15 

  

6 - If you have the same design stored in different embroidery formats you may need to know the file 
extension to be able to recognize its format (Picture No. 16). In Explorer, click on "Tools -> Folder Options" 
command. This will bring up a dialog box. (Picture No. 17). Choose the "View" tab and uncheck the "Hide file 
extensions for known file types". Sometimes it might be suitable also to uncheck the "Remember each folder's 
view settings" option, especially in case you use the "Thumbnails" view mode in Explorer and you are 
browsing through many folders.  

Picture No. 16 

  

Picture No. 17 
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7 - When you right click on design in Explorer and choose "Properties" item (Picture No. 18), a dialog box will 
be displayed with new tab - "Embird Iconizer". This new sheet will contain the design image (Picture No. 19). 
The "Embird Iconizer" tab sheet can be disabled by unchecking the "Enable Property Sheets" option in 
"Iconizer Settings" dialog box (see Picture No. 5 above).  

Picture No. 18 

  

Picture No. 19 
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Inserting and Removing Embird  Password 

This tutorial explains how to enter the registration password into Embird, so that it stops to expire and turns 
from evaluation (demo) version into full version. It also explains how to enter the registration numbers for 
plug-ins (Alphabets, Font Engine, Cross Stitch, Digitizing Studio, Sfumato Stitch, Iconizer). It is supposed that 
you already have received an e-mail from us, with text form of the password. The following steps explain 
what to do with this password.  

Note: Another way of inserting passwords into Embird is to use the PASSWORD.KLC file attached to the e-
mail which you receive from us after purchasing Embird registration - this is explained in Inserting 
Registration Password from PASSWORD.KLC file tutorial.   

Inserting Main Embird Password from E-mail 

1 - Run your e-mail software (Microsoft Outlook, Netscape Communicator, etc.) and open the e-mail with 
passwords which you have received from us after paying for Embird registration at 
http://www.embird.com/sw/embird/register.htm. Typically, you would receive two e-mails, containing 
different forms of password. Choose the e-mail without attachment, containing the text form of the password 
(Picture No. 1). 

Picture No. 1  

 

2 - Highlight the registration password and depress CTRL and C keys simultaneously to copy the selected text 
(password) into clipboard. If you don't know how to copy the text into the clipboard, please read the 
following: Put the mouse at the beginning of password and click the left mouse button, holding it down while 
you drag over the password. At the end of password, let go of the mouse button. Password should be 
highlighted. (If you goof, click the mouse button once to unhighlight, then start over.) While it is highlighted, 
hold down the Ctrl key and hit the letter "c". This copies the password to an invisible clipboard. 
3 - Run Embird and select "Help -> Registration" command from the main menu (Picture No. 2). 

Picture No. 2  

 

4 - A dialog box will appear on the screen. Move mouse pointer to the box for entering password and click the 
left mouse button to focus this box (Picture No. 3).  
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Picture No. 3  

 

5 - Depress CTRL and V keys simultaneously to paste the password from clipboard into this box. Then click 
"Register" button to continue (Picture No. 4). 

Picture No. 4  

 

6 - Embird will check the password. Wait several seconds until the password validation process is finished. 
 
Inserting Plug-in Registration Number from E-mail  
 
1 - Install the plug-in which you would like to register. Find more information in Installing Plug-ins tutorial. 
2 - Run Embird, it will start in "Manager" mode. 
3 - Select "Help -> Installed Plug-ins" command from the main menu. 
4 - A dialog box containing the list of installed plug-ins will appear on the screen (Picture No. 5). 
5 - Type in the number we have sent you (see the e-mail in Picture No. 1 above) into the "Registration 
Number" cell which corresponds to the plug-in which you would like to register. 
6 - Click "OK" button to close this dialog box.  

Picture No. 5  
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Checking Embird Registration 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Check the blue bar at the top of Embird Manager window - your name should be displayed there in 
registered Embird. 
3 - Check whether plug-ins are installed and registered by selecting "Help -> Installed Plug-ins" command 
from the main menu (Picture No. 6).  

Picture No. 6  

 

Removing All Password from Embird 

1 - Run Embird and select "Help -> Registration" command from the main menu. 
2 - A dialog box will appear on the screen. Depress CTRL and ALT keys simultaneously and while holding 
them down click the "Register" button (Picture No. 7). 

Picture No. 7 

 

3 - Confirm the password removal by clicking "Yes" button (Picture No. 8). 

Picture No. 8 

 

4 - All Embird passwords will be removed and Embird will close. If you run it again, you will see in the blue 
bar at the top of Embird Manager window that Embird is unregistered. 
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Inserting Registration Password from PASSWORD.KLC file  

This tutorial explains how to enter the registration password into Embird, so that it stops to expire and turns 
from evaluation (demo) version into full version. It also explains how to enter the registration numbers for 
plug-ins (Alphabets, Font Engine, Cross Stitch, Digitizing Studio, Sfumato Stitch, Iconizer). It is supposed that 
you already have received an e-mail from us, with PASSWORD.KLC file in attachment. The following steps 
explain what to do with this file, using different e-mail programs (Microsoft Outlook Express and Netscape 
Communicator).  

Note: Another way of password insertion is using the text form of the password and the standard Windows 
Clipboard functions ("Ctrl+C" to copy selected text from email to the Clipboard and " Ctrl+V" to paste the text 
from the Clipboard into " Embird -> Help -> Registration" dialog box). This way is explained in Inserting and 
Removing Embird Password tutorial. 
 
 
Using Microsoft Outlook Express E-mail Software 
 
1 - Close Embird in case you are running it. 
2 - Run Outlook and open the e-mail with passwords which you have received from us after paying for Embird 
registration at http://www.embird.com/sw/embird/register.htm. Typically, you would receive two e-mails, 
containing different forms of password. Choose the e-mail with attachment, containing PASSWORD.KLC there. 
3 - Click on the clip to show the popup menu (arrow 1 in Picture No. 1). 
4 - Choose "Save Attachments" command in popup menu (arrow 2 in Picture No. 1).  

Picture No. 1  

 

5 - A dialog box will appear on the screen (Picture No. 2). Click "Browse" button and browse to the folder 
where you have installed Embird (arrow 3 in Picture No. 4). Typically it is "C:\Program Files\EMBIRD32" folder 
(or "C:\EMBIRD32" folder if you are using version prior to Embird 2006). 
6 - Click "Save" button to save the file from e-mail attachment into the chosen folder (arrow 4 in 
Picture No. 2). Overwrite the existing file if necessary. Then continue in step 7 below.  

Picture No. 2  
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Using Netscape Communicator E-mail Software 

1 - Close Embird in case you are running it. 
2 - Run Netscape Communicator and open the e-mail with passwords which you have received from us after 
paying for Embird registration at http://www.embird.com/sw/embird/register.htm. Typically, you would 
receive two e-mails, containing different forms of password. 
3 - Move mouse cursor to the "PASSWORD.KLC" attachment (located either in the top right corner of the 
message, or at the bottom of the message). Then click the right mouse button, this will display a popup menu 
(Picture No. 3). 
4 - Choose "Save As" command in popup menu (arrow 1 in Picture No. 3).  

Picture No. 3 

  

5 - A dialog box will appear on the the screen (Picture No. 4). Browse to the folder where you have installed 
Embird, typically it is " C:\Program Files\EMBIRD32" folder (or "C:\EMBIRD32" folder if you are using version 
prior to Embird 2006). 
6 - Click "Save" button to save the file from e-mail attachment into the chosen folder (arrow 4 in 
Picture No. 2). Overwrite the existing file if necessary. Then continue in step 7 below. 

Picture No. 4 
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Checking Embird Registration 

7 - Now you can verify whether the passwords were successfully inserted into Embird or not. Run Embird, it 
will detect the "PASSWORD.KLC" file in its main folder and validate the passwords stored there. In case the 
passwords are accepted, the evaluation version of Embird will turn into full version, and the "Unregistered" 
caption in the blue bar at the top of Embird Manager window will disappear. Check the blue bar at the top of 
Embird Manager window - your name should be displayed there in registered Embird (Picture No. 5). You can 
also check the list of registered plug-ins by selecting "Help -> Installed Plug-ins" command from the main 
menu. 

Picture No. 5 
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Inserting Registration Password - Auto-Copy to Clipboard  

This tutorial explains how to enter the registration password into Embird using special "Auto-Copy to 
Clipboard" command from Embird main menu. 
 
Normally, you can insert the password from e-mail to Embird using standard Windows Clipboard functions 
("Ctrl+C" to copy selected text from email to the Clipboard and "Ctrl+V" to paste the text from the Clipboard 
into "Embird -> Help -> Registration" dialog box - see more details in Inserting and Removing 
Embird Password tutorial).  
 
Another way of inserting passwords into Embird is to use the PASSWORD.KLC file attached to the e-mail 
which you receive from us after purchasing Embird registration - this is explained in Inserting Registration 
Password from PASSWORD.KLC file tutorial.  
 
However, if you are not familiar with using Clipboard function, nor PASSWORD.KLC file, try to use the "Auto-
Copy to Clipboard" command. Assuming you have paid for Embird registration and received an email with 
registration password from us, please follow these steps: 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Check whether your copy of Embird is "Unregistered" by reading the text in the blue bar at the top of 
Embird Manager window (arrow 1 in Picture No. 1). 
3 - In case you have an unregistered copy, select "Help -> Auto-Copy To Clipboard" command from the main 
menu (arrow 2 in Picture No. 1).  

Picture No. 1  

 

4 - Embird will display a dialog box with instructions (Picture No. 2).  

Picture No. 2  

 

5 - Run your e-mail software (in this example it is Microsoft Outlook Express) and open the e-mail with 
passwords which you have received from us after paying for Embird registration at 
http://www.embird.com/sw/embird/register.htm. Typically, you would receive two e-mails, containing 
different forms of password. Choose the e-mail without attachment, containing the text form of the password 
(Picture No. 3). 
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Picture No. 3 

 

6 - In this e-mail, double click the text with password, i.e. the body of the e-mail (Picture No. 3). Embird will 
display a message informing you about the recognition of passwords (Picture No. 4). In case you do not 
obtain this message, please repeat this step - double click again on e-mail with password - until the message 
appears.  

Picture No. 4 

 

7 - Once the password is recognized and inserted into Embird, you will see in the blue bar at the top of 
Embird Manager window that Embird is registered (Picture No. 5). You can also check which plug-ins are 
registered by choosing "Help -> Installed Plug- ins" command from main menu.  

Picture No. 5 

 

8 - Please back-up your passwords using "Help -> Passwords" command from main menu. See more details 
in Passwords Back- up tutorial. 
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Inserting Aligning Stitches  

This tutorial explains how to insert aligning stitches into parts of split design. Aligning stitches can be added 
horizontally, vertically, diagonally or all three. Typical usage of aligning stitches is for designs which are larger 
than your hoop size, and therefore must be split into usable parts. Aligning stitches simplify the positioning of 
the various parts in the hoop when embroidering, allowing you to match up the split parts.  

Note: In Embird, there exists an another easier way of inserting aligning stitches. However, you should read 
this tutorial first to understand what is going on. Then read Inserting Aligning Stitches (Another Way) tutorial.  

1 - Run Embird and click on the "Editor" menu. 
2 - Open the file you want to edit. Select the "File -> Open" menu to open a file. 
3 - Split the design into the appropriate number of parts. In our example the design was split into 2 parts: top 
and bottom. These parts can be seen in the "Objects Order Bar" at the right side of the screen (Picture No. 
1). Read the Interactive Freehand Splitting tutorial to find out how to split a design.  

Picture No. 1  

   

4 - First we want to add the aligning stitches to the top part. Therefore we will hide the bottom part for a 
moment. Move the mouse cursor to any of the color boxes belonging to the bottom part and then click the 
right mouse button. Choose the "Hide All Colors" command in the popup menu which appears on the screen 
(Picture No. 2).  

Picture No. 2  
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5 - Select "Mode -> Points Editing Mode" menu to switch to this mode. 

6 - Click the left mouse button and a small dotted box will appear . Drag this box around the area you 
want to edit, making sure it contains at least one point belonging to the top part (Picture No. 3). 
7 - Choose the join point, i.e. the point where you want the two files to join. In our example we have chosen 
the point -1.5, 0.0 mm. These co-ordinates can be seen on the bottom of the "Objects Order Bar". Make a 
note of these co-ordinates for use in step 15 below. Move the mouse pointer to this position. 

Picture No. 3 

  

8 - Click the right mouse button for the popup menu. Choose the "Insert Horizontal Aligning at Ending" 
command (Picture No. 4). This command will add the aligning stitches to the end of the top part.  

Picture No. 4 
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9 - Three new aligning points were automatically added to the end of the top part (Picture No. 5). The first 
point is at the co-ordinates of the join point. The second point is the left one and the third point is the right 
one. The left and right points have the same Y co-ordinate as the join point. Their X co-ordinates are 
determined by the width of the top part.  

Picture No. 5 

  

10 - We are going to repeat the same process with the bottom part. Move the mouse cursor to any of the 
color boxes belonging to the bottom part and click the right mouse button for the popup menu. Choose the 
"Show All Colors" command (Picture No. 6).  

Picture No. 6 
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11 - Hide all colors belonging to the top part, using the same steps as shown in step 4 above. 
12 - Select "Mode -> Select Mode" menu to switch to this mode. This will cancel the current area of editing in 
the top part. 
13 - Select "Mode -> Points Editing Mode" menu to switch to this mode. 
14 - Following the step 6 above, specify any area of editing, but make sure it contains at least one point 
belonging to the bottom part (Picture No. 7). 
15 - Move the mouse pointer to the join point - in our example point -1.5, 0.0 mm.  

Picture No. 7 

  

16 -  Click the right mouse button for the popup menu. Choose the "Insert Horizontal Aligning at Beginning" 
command (Picture No. 8). This command will add the aligning stitches at the beginning of the bottom part.  

Picture No. 8 
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17 - As the distance between the left and right aligning points will be equal to the width of the section being 
worked on, the distance between these points may be different for each section (not all parts of a design are 
the same width). You must therefore move the right and left aligning points so that they match the 
corresponding points in the top part. (Picture No. 9). To do this, move the mouse cursor to any of the color 
boxes belonging to the bottom part and click the right mouse button and choose "Show All Colors" from the 
popup command which appears on the screen. Then click "Mode -> Points Editing Mode" menu to switch to 
this mode. Click the left mouse button and highlight the left aligning points of the design. Left click and drag 
the bottom aligning points (stitches) so that they match the corresponding points in the top part. Do the 
same for the right aligning points. Both designs should now be the same width with the aligning stitches 
sitting on top of one another. (If you cannot see whether the left and right aligning points match, choose 
"Select Mode" from the "Mode" menu, select the top section of the design and move it up a little bit so the 
aligning stitches show. You should now be able to see both sets of aligning points and make the necessary 
adjustments. Hint: You can use the reference points in the co-ordinate box to help with the lining up.)  

Picture No. 9 

               

Tips:  
 
1 - In a design split into three or more parts, the aligning stitches are inserted at the end of the top section, 
at both the beginning and end of any "middle" sections and at the beginning of the bottom section. 
 
2 - Do not forget to add tie-off/on stitches just before the "Ending" aligning stitches and after the "Beginning" 
aligning stitches. 
 
3 - If your aligning stitches do not show up because they are the same color as the screen background or the 
same color as the aligning stitches of the next part, temporarily change their color. These stitches will be 
either the first or the last color to the right in the "Objects Order Bar" in the part you are working on. Change 
the color back to the original color when you have completed the editing.  
 
4 - When you are sewing the design out, start sewing out the first section and leave the aligning stitches in. 
Re-hoop the fabric or move the hoop and use the adjustments on your machine so that the first aligning 
stitches of the next part sit exactly on top of the previous section then sew out. Complete the design and 
finally remove all aligning stitches.  
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Inserting Aligning Stitches (Another Way)  

This tutorial explains how to insert aligning stitches into parts of split design. Aligning stitches can be added 
horizontally, vertically, diagonally or all three. Typical usage of aligning stitches is for designs which are larger 
than your hoop size, and therefore must be split into usable parts. Aligning stitches simplify the positioning of 
the various parts in the hoop when embroidering, allowing you to match up the split parts. 
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the file you want to edit. To open a design, click "File" menu and choose "Open" command.  
3 - Split the design into the appropriate number of parts. In our example the design was split into 2 parts: top 
and bottom. These parts can be seen in the "Objects Order Bar" at the right side of the screen (Picture No. 
1). Read the Interactive Freehand Splitting tutorial to find out how to split a design.  

Picture No. 1  

   

4 - First we want to add the aligning stitches to the top part. Click on the top part to select it. When it is 
selected, a frame is drawn around it (Picture No. 2).  

Picture No. 2  
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5 - Click on the "Insert" menu and choose the "Aligning Stitches" command. A dialog box appears on the 
screen (Picture No. 3). 
6 - Notice the object order at the right side of screen: Object no. 1 is the top part of cocker design, object no. 
2 is the bottom part. We want to insert the horizontal aligning stitches to the end of the top part. We have 
chosen the join point co-ordinates 0.0, -7.0 mm (see also Insert Aligning Stitches tutorial). The bottom part of 
cocker design is wider than the top part, and because we want the aligning stitches in the top part to match 
the corresponding points in the bottom part, we will choose the reference object no. 2 (Picture No. 3). 

Picture No. 3 

  

7 - Three new aligning points were automatically added to the end of the top part (Picture No. 4). The first 
point is at the co-ordinates of the join point. The second point is the left one and the third point is the right 
one. The left and right points have the same Y co-ordinate as the join point. Their X co-ordinates are 
determined by the left and right edges of reference object specified in the dialog box above.  

Picture No. 4 

  

8 - We are going to repeat the same process with the bottom part. Choose "Mode -> Select Mode" to switch 
into select mode. Then click on the bottom part to select it (Picture No. 5).  
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Picture No. 5 

  

9 - Click on the "Insert" menu and choose the "Aligning Stitches" command. A dialog box appears on the 
screen. We want to insert the horizontal aligning stitches to the beginning of the bottom part, i.e. to object 
no. 2. The join point co-ordinates are the same as for the top part: 0.0, -7.0 mm. Reference object for left 
and right aligning point is object no. 2, because it is wider than object no. 1 (Picture No. 6).  

Picture No. 6 

  

10 - Three new aligning points were automatically added to the beginning of the bottom part (Picture No. 7).  
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Picture No. 7 

  

Tips:  
 
1 - In a design split into three or more parts, the aligning stitches are inserted at the end of the top section, 
at both the beginning and end of any "middle" sections and at the beginning of the bottom section. 
 
2 - Do not forget to add tie-off/on stitches just before the "Ending" aligning stitches and after the "Beginning" 
aligning stitches. Use "Insert -> Tie On/Off Stitches" menu to add these stitches to selected objects. 
 
3 - When sewing the design out, sew out the first section and leave the aligning stitches in. Re-hoop the 
fabric or move the hoop and use the adjustments on your machine so that the first aligning stitches of the 
next part sit exactly on top of the previous section. Then sew out. Complete the design and finally remove all 
aligning stitches.  
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Insert Calendar  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "Insert -> Text" menu or "Insert -> Font Engine Text" menu (Picture No. 1).   

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen. In the "Plug-in" box choose the alphabet which will 
be used for calendar characters.  
4 - Click "Insert Calendar" button located at the right side of the "Text" box (Picture No. 2).  

Picture No. 2  

   

5 - The "Insert Calendar" dialog box will appear on the screen (Picture No. 3). Choose the month and year, 
specify holidays (except Sundays) and choose the type of calendar. Specify the maximum width and height of 
the "day" cell, i.e. the size of cell which contains the date. Finally, hit "OK" button to create the calendar. 
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Picture No. 3 

   

6 - Embird will create the calendar using the chosen alphabet. After a while, the complete design will be 
inserted into the Editor window (Picture No. 4). 
7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  

Picture No. 4 
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Insert Clock 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Text" menu or "Insert -> Font Engine Text" menu (Picture No. 1).  

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen. In the "Plug-in" box choose the alphabet which will 
be used for clock characters. 
4 - Click "Insert Clock" button located at the right side of the "Text" box (Picture No. 2).  

Picture No. 2  
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5 - The "Insert Clock" dialog box will appear on the screen (Picture No. 3). Choose the type of clock, prescribe 
the inner or outer diameter and specify the maximum width and height of the "hour" cell. Finally, hit "OK" 
button to create the clock. 

Picture No. 3 

   

6 - Embird will create the clock using the chosen alphabet. After a while, the complete design will be inserted 
into the Editor window (Picture No. 4). 
7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  

Picture No. 4 
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Insert Multi-line Text or Vertical Text  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Text" menu or "Insert -> Font Engine Text" menu (Picture No. 1).  

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen. In the "Plug-in" box choose the alphabet which will 
be used for text characters. 
4 - Click "Insert Multi-line Text or Vertical Text" button located at the right side of the "Text" box 
(Picture No. 2).  

Picture No. 2  
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5 - The "Insert Multi-line Text or Vertical Text" dialog box will appear on the screen (Picture No. 3). Choose 
the type of text you want to create, specify the text and its alignment. Please note, that you can save the text 
to the file, or load it from the file, using the small buttons located at the right side of the "Lines:" box. Finally, 
hit "OK" button to create the design. 

Picture No. 3 

   

6 - Embird will create the design using the chosen alphabet. After a while, the complete design will be 
inserted into the Editor window (Picture No. 4). 
7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  

Picture No. 4 
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Installing Embird  

This tutorial explains how to install Embird. If you want to update an older version of Embird installed on your 
computer, note that there is no special file with "smart" small update or "patch" available. You must download 
the whole setup file for new version from http://www.embird.com/sw/embird/down.htm. Download the file to 
folder "C:\My Documents" on your hard disk (or to any other folder, but this tutorial refers to "C:\My 
Documents" download). Then uninstall the older version - see how to uninstall in Uninstalling Embird tutorial. 
When you are finished with uninstalling of the previous Embird version, install the new version. If you follow 
the steps explained in this tutorial, your passwords for Embird will remain on your computer and will be 
transferred into the new version automatically. 
 
Warning: If you already have some previous Embird version on your PC and want to update to the latest 
version, please read the note above. Then follow the steps in Uninstalling Embird tutorial to uninstall the 
current version. Only then continue with installation of the latest version. 
 
To install Embird: 
 
1 - Select "Start - > Run" command at the bottom left corner of the Windows screen (Picture No. 1).  

Picture No. 1  

   

2 - A dialog box will appear on the screen. Click "Browse" button (Picture No. 2).  

Picture No. 2  

   

3 - Browse to the folder where you have downloaded the latest version of Embird: in this example it is folder 
"C:\My Documents" (Picture No. 3). Select the installation file of Embird and click "Open" button 
(Picture No. 3).  
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Picture No. 3  

   

4 - Select "OK" to run the installation file of Embird (Picture No. 4). 

Picture No. 4 

   

5 - Installation file will start, and a dialog box will appear on the screen (Picture No. 5). Click "Setup" button 
to continue.  

Picture No. 5 

   

6 - After a short while, the "Choose Language" dialog box will appear on the screen. Choose your language 
and click "OK" button to continue (Picture No. 6).  

Picture No. 6 
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7 - The dialog box with "License Agreement" will appear on the screen (Picture No. 7). Read the agreement 
carefully and if you accept it, choose "I accept the terms in the license agreement" option. You can also 
choose the installation disk drive in this window. Default is "C:" drive. Click "Install" button to continue.  

Picture No. 7 

   

8 - The "Copy ID" dialog box will appear next. You must fill in your first name, last name, street, ZIP, city, 
state, country and e-mail. These data are stored internally only for purpose of illegal copies identification and 
their blocking. Embird does not send any of these information out of your computer.  

Picture No. 8 

   

9 - Another dialog box will appear on the screen, allowing you to change the settings of the "Iconizer" plug-in, 
which is included in Embird installation file (Picture No. 9). Please read Iconizer tutorial to learn more about 
this plug-in. Click "OK" button to continue.  
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Picture No. 9 

   

10 - When the installation is complete, the Information box “Installation Successful” is displayed 
(Picture No. 10).  

Picture No. 10 

   

11 - Embird icon will be automatically created on your desktop and the new program group "Embird" will be 
created in "Start -> Programs" menu of Windows. Now you can double-click Embird application icon (the 
"bird") to launch the Embird program (Picture No. 11).  

Picture No. 11 

 

Tip: To find out how to insert registration password into Embird and thus to turn it from evaluation version 
into full version read Entering Registration Password Into Embird and Inserting and Removing Embird 
Password tutorials.  



 167 

Installing Plug-ins  

This tutorial explains how to install plug-ins (alphabets, Sfumato Stitch, Digitizing Studio) into Embird. Before 
installing any plug-ins, note that Embird software is required (see Installing Embird tutorial). Then download 
each plug-in from http://www.embird.com/sw/embird/down.htm. The installation files can be downloaded to 
folder "C:\My Documents" on your hard disk (or to any other folder, but this tutorial refers to "C:\My 
Documents" download). 
 
Note:  Iconizer, Font Engine and Cross Stitch plug-ins are included in Embird installation file; therefore, 
there are no special installation files needed. These three plug-ins will be installed together with Embird 
software. However, you must pay for them if you want to use them. In other words, the registration fee for 
Embird does not cover the registration of Iconizer plug-in, Font Engine plug-in nor Cross Stitch plug-in. 
 
Tip: Before you start installing plug-ins, please run Embird and check in "Help -> Installed Plug-ins" menu 
which plug-ins are already installed to avoid their useless re-installation. 
 
How to install plug-ins: 
 
1 - Select "Start - > Run" command at the bottom left corner of the Windows screen (Picture No. 1).  

Picture No. 1  

   

2 - A dialog box will appear on the screen. Click "Browse" button (Picture No. 2).  

Picture No. 2  

   

3 - Browse to the folder where you downloaded the plug-in; in this example it is "C:\My Documents" folder 
(Picture No. 3). Select the installation file of plug-in and click "Open" button to continue (Picture No. 3).  
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Picture No. 3  

   

4 - Select "OK" to run the installation file of plug-in (Picture No. 4). 

Picture No. 4 

   

5 - Installation file will start, and a dialog box will appear on the screen (Picture No. 5). Click "OK" button to 
continue.  

Picture No. 5 

   

6 - Another dialog box will appear on the screen, allowing you to choose the target folder for unzipping files. 
This folder should be the same as the main installation folder of Embird program. Normally, it is not necessary 
to change the folder suggested by installation program (i.e. "C:\EMBIRD32" folder, or "C:\Program 
Files\EMBIRD32" folder if you are using Embird 2006 or later), because this is the default folder where Embird 
is normally installed unless you choose some other folder. Click "Unzip" button to continue (Picture No. 6).  

Picture No. 6 
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7 - When the installation is complete, the Information box “Installation Successful” is displayed 
(Picture No. 7). Click "OK" button to continue.  

Picture No. 7 

   

8 - Finally, click "Close" button to close the installation dialog box (Picture No. 8).  

Picture No. 8 

   

9 - For each plug-in you wish to install, repeat Steps 1 to 8 above. To make sure that the plug-ins were 
installed correctly into Embird, run Embird and select "Help -> Plug-ins" menu (Pictures No. 9).  

Picture No. 9   

 

10 - The "Installed Plug-ins" dialog box will appear on the screen, showing the list of installed plug-ins and 
whether these plug-ins are already registered or not (Picture No. 10).  
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Picture No. 10  

 

Tip: To find out how to insert a plug-in registration number and thus to turn the unregistered plug-in into its 
full version read Entering Registration Password Into Embird tutorial.  
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Janome JEF CompactFlash Card - Reading Files  

Use this command if you want to read designs from Janome JEF CompactFlash Card. It is supposed, that you 
have the Janome ATA card inserted in the PCMCIA slot of your notebook, or card reader/writer hardware 
attached to your PC, and that this card works like another disk drive on your PC (e.g. drive F:).   
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select "Right Panel -> Input/Output Operations -> Janome JEF CompactFlash Card" command from the 
main menu (Picture No. 1).  

Picture No. 1  

 

3 - A dialog box will appear on the screen (Picture No. 2). Choose the "Drive:" which contains Janome 
CompactFlash card. In this example it is "F:" drive. 
4 - In the "Folder:" box select (double-click) the folder containing designs which you want to read from the 
card (arrow 1 in Picture No. 2). In this example we have selected "EmbF5" folder. 
5 - In the "Files:" box select the files you want to read from the card (arrow 2 in Picture No. 2). To select a 
design, please move the mouse pointer to its file name and click the left mouse button. You can select 
multiple files: Move mouse pointer to the file name of the first design in the "Files:" box at the right side of 
the screen, depress the left mouse button and hold it down while moving the mouse pointer over the file 
names of the other designs. When the mouse pointer is over the last design, please release the left mouse 
button. In this example we have selected all the files stored in the "EmbF5" folder. 
6 - Click "Read selected files from card" button to read selected files from the card (arrow 3 in Picture No. 2).  

Picture No. 2  
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7 - Another dialog box will appear on the screen (Picture No. 3). Choose the format in which the designs 
imported from Janome JEF CompactFlash card will be saved to your hard disk. Click "OK" button to continue. 

Picture No. 3 

 

8 - Embird will read the files from Janome JEF CompactFlash card, convert them 'on-the-fly' to chosen format 
and save to the hard disk to currently chosen Right Panel's drive and folder. When finished, it will display the 
result of this operation (Picture No. 4). Click "OK" button to continue.  

Picture No. 4 

 

9 - Finally, the imported designs will be shown on the screen; they are stored in the right panel's "Files:" box 
(Picture No. 5).  

Picture No. 5 
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Janome JEF CompactFlash Card - Writing Files  

Use this command if you want to write designs to Janome JEF CompactFlash Card. It is supposed, that you 
have the Janome ATA card inserted in the PCMCIA slot of your notebook, or card reader/writer hardware 
attached to your PC, and that this card works like another disk drive on your PC (e.g. drive F:).  
 
1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen select the design which you want to write to Janome JEF 
CompactFlash Card. To select a design, please move the mouse pointer to its file name and click the left 
mouse button (Picture No. 1). You can select multiple files: Move mouse pointer to the file name of the first 
design in the "Files:" box at the right side of the screen, depress the left mouse button and hold it down while 
moving the mouse pointer over the file names of the other designs. When the mouse pointer is over the last 
design, please release the left mouse button.  

Picture No. 1  

   

3 - Select "Right Panel -> Input/Output Operations -> Janome JEF CompactFlash Card" command from the 
main menu (Picture No. 2).  

Picture No. 2  

 

4 - A dialog box will appear on the screen (Picture No. 3). Choose the "Drive:" which contains CompactFlash 
card. In this example it is "F:" drive. The upper box shows the folders and files of  Janome JEF CompactFlash 
Card (empty card in this example).  
5 - The bottom box shows the files which you are going to write to the card (Picture No. 3). Click "Write files 
to card" button to start writing of designs to the card. 



 174 

Picture No. 3 

 

6 - If you are writing to an empty card, Embird will ask you about the card format (Picture No. 4). Select your 
format and click "OK" button to continue.  

Picture No. 4 

 

7 - Embird will write the files to Janome JEF CompactFlash Card and it will display the result of this operation 
(Picture No. 5). In this example, the "PORSCHE1.JEF", "PORSCHE2.JEF" and "SQUIRREL.JEF" designs were 
written to the card. The corresponding files with .EDR extension contain the Embird color palette for these 
designs.  

Picture No. 5 

 

8 - Janome JEF CompactFlash Card is now ready for use. You can eject it from the disk drive and use it with 
your embroidery machine. 
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Joining Designs  

1 - Run Embird. 
2 - Click "Editor" menu to switch to Editor window. 
3 - Select "File -> Open" menu to open the first design (Picture No. 1).  

Picture No. 1  

 

4 - Click "File -> Merge" menu to open another design (Picture No. 2).  

Picture No. 2  

 

5 - Choose the second design and merge it into Editor by clicking "OK" button (Picture No. 3). 

Picture No. 3 
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6 - Move both designs to the suitable position by using these steps: Position mouse pointer over the design, 
click left mouse button to select it and hold down the left mouse button while moving mouse to move the 
design to the new position. Release the left mouse button. 
7 - Select both designs for joining: Depress "Ctrl" button and click left mouse button over designs, or use 
"Edit -> Select All" menu. 
8 - Click "Join" button to join selected designs. As you can see in Picture No. 4, the final design does not fit 
the hoop, therefore it is necessary to adjust the hoop size. 
9 - Click "Hoop Size" button to choose the suitable hoop (Picture No. 4).  

Picture No. 4 

 

10 - Choose the proper hoop size from the list which appears on the screen (Picture No. 5). Confirm the new 
hoop setting by clicking "OK" button.  

Picture No. 5 

 

11 - Click "Center" button to center the joined design in the hoop (Picture No. 6).  

Picture No. 6 
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12 - Select "File -> Save As" menu to save the joined design to a file on your hard disk (Picture No. 7).  

Picture No. 7 

  

13 - Choose the target file format in the dialog box which appears on the screen (Picture No. 8). Click "OK" 
button to continue.  

Picture No. 8 

 

14 - Choose the drive, folder and file name of the design being saved (Picture No. 9). Click "Save" button to 
continue.  

Picture No. 9 

 

15 - When finished, use "File -> Exit" menu to exit Editor. 
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Lettering 1 (General)  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Text" menu (Picture No. 1). 

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen (Picture No. 2). In the "Plug-in" box you can choose 
the alphabet which will be used for characters. After choosing the alphabet, you can type your text into the 
"Text" box at the bottom of the "Insert" tab. You might want to change the "Connection type" setting - in this 
example we have chosen the "Running stitches (nearest point)" option.  

 Picture No. 2  

   

4 - Click "Properties" tab. Specify the text dimensions (e.g. height) either absolutely or relatively in "Size" 
section. You can also change other text parameters at this tab. This relates to density of cover stitches, type 
of underlay, pull compensation, start/end offset, broadening, random broadening, fill pattern, auto 
shortening, gaps between characters, etc. You can set either GLOBAL parameters for the whole text or 
INDIVIDUAL parameters for each character. Choose this option in the "Use" box. However, please note that in 
most cases all you have to change is the text size (Picture No. 3).  
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Picture No. 3  

   

5 - Click "Layout" tab. Choose the "Baseline" type, e.g. circle (arrow 1 in Picture No. 4). Change baseline 
"Width" and/or "Height" (arrow 2). Move the text along the baseline using the "Start point" scroll bar (arrow 
3) or edit box (arrow 4). Click the "Place on the other side" box if you want to place the text to the other side 
of circle (arrow 5). 

Picture No. 4 

  

6 - Finally, click "OK" button to create the lettering and insert it into Editor window (Picture No. 5).  
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Picture No. 5 

  

7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  
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Lettering 2 (Individual Settings)  

When you create the lettering in Embird, you may specify either global settings for the whole text or 
individual settings for each character. In this example, the meaning of the individual settings is 
demonstrated. The text being inserted consists of two "E" letters, each one having its own fill pattern.   

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Text" menu (Picture No. 1).  

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen (Picture No. 2). In the "Plug-in" box you can choose 
the alphabet which will be used for characters. After choosing the alphabet, type the "EE" text into the "Text" 
box at the bottom of the "Insert" tab. (Picture No. 2).  

 Picture No. 2  
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4 - Click "Properties" tab. Specify the text height "50 mm" or "2 inches" (arrow 1 in Picture No. 3). The 
characters must be large enough, otherwise the fill pattern effect is not visible. Click "Individual settings" 
option in the "Use" box at the bottom of the "Properties" tab (arrow 2). Then click the "..." button of the first 
"E" character at the right side of the screen (arrow 3).  

Picture No. 3  

   

5 - Choose "Fill 1" option in the "Pattern" box. Click "OK" button to confirm the settings (Picture No. 4). 

Picture No. 4 

  

6 - Click the  "..." button of the second "E" character at the right side of the screen (arrow 4 in Picture No. 3). 
Choose "Bricks 1" option in the "Pattern" box. Click "OK" button to confirm the settings. 
7 - Finally, click "OK" button to create the lettering and insert it into Editor window. 
8 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen. 
9 - Click "Manager" menu to switch to Manager window. Display the design on the screen - double click its 
filename in the "Files" box at right panel. In case you have the "Options -> Photorealistic 3D Drawing" option 
set to ON, you will see the difference in fill patterns of "EE" characters.   
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Picture No. 5 
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Lettering 3 (Envelope)  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Text" menu (Picture No. 1).  

Picture No. 1  

   

3 - The "Insert Text" dialog box will appear on the screen (Picture No. 2). In the "Plug-in" box you can choose 
the alphabet which will be used for characters. After choosing the alphabet, you can type your text into the 
"Text" box at the bottom of the "Insert" tab.  

Picture No. 2  

   

4 - Click "Layout" tab. Notice the panel with settings at the bottom of the preview area (on some computers 
with lower screen resolution it might be necessary to scroll the panel using the scroll bar below it). Switch ON 
the "Envelope" option. A rectangle will appear in the preview box, with several sensitive points - black squares 
(Picture No. 3). You can move each sensitive point and thus to change the text envelope. Move the mouse 
pointer to some sensitive point and depress either left or right mouse button. Then move the mouse pointer 
to new location and finally release mouse button. You will immediately see the new shape of the lettering. 
You can also choose some of pre-defined shapes in the box below "Envelope" option. There are also other 
options available - you can choose the type of envelope edge: either "Line" or "Curve". If you want to create 
symmetrical envelope, you will find the "Horizontal" and "Vertical" options in "Symmetry" box very helpful.  
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Picture No. 3  

   

5 - Finally, click "OK" button to create the lettering and insert it into Editor window. 
6 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen. 

Tip: You can create your own shapes, which will be offered in the box with "pre-defined" envelopes located 
below "Envelope" check box (e.g. "eye" shape in Picture No. 3). Once you are ready with new envelope, click 
on the button with "floppy disk" icon (Picture No. 4) and save the lettering project into "C:\Program 
Files\EMBIRD32\PLUGINS" folder (or into "C:\EMBIRD32\PLUGINS" folder if you are using version prior to 
Embird 2006). Only .LTG files saved into this folder are offered in the "pre-defined" box. 

Picture No. 4  
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Lettering 4 (Custom Baselines)  

In Embird 2006 and later you can create custom baselines for "Insert Text" and "Insert Font Engine Text" 
dialog boxes. The Digitizing Tools of Embird Studio are used for preparing the baseline .ETB file, which must 
be stored in "C:\Program Files\EMBIRD32\PLUGINS" folder (or in "C:\EMBIRD32\PLUGINS" folder if you are 
using version prior to Embird 2006) to be recognized by Embird. This tutorials explains how to create the 
custom baseline:  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Studio of Sfumato Design" menu to launch the Embird Studio plug-in (Picture No. 1). 

Picture No. 1  

   

3 - The "Embird Studio" window will appear on the screen (Picture No. 2). Use "Connection" tool to create the 
baseline curve.  

Picture No. 2  

   

4 - Click "Design -> Export" menu when you are finished with creating the baseline curve (Picture No. 3). This 
command will export the curve into .ETB file on the hard disk. This file must be stored in "C:\Program 
Files\EMBIRD32\PLUGINS" folder (or in "C:\EMBIRD32\PLUGINS" folder if you are using version prior to 
Embird 2006) to be recognized by the "Insert Text" and "Insert Font Engine" tools (Picture No. 4).  
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Picture No. 3  

   

Picture No. 4 

  

5 - Test the new baseline by selecting "Text -> Text" or "Text -> Font Engine Text" menu. This will open the 
"Insert Text" dialog box, and on the "Layout" tab there should be the new baseline available as an option in 
the "Baseline:" box (Picture No. 5).  

Picture No. 5 
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Localization of a Stitch 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design using the "File -> Open" menu. 
3 - Type in the same stitch number into both "Initial Stitch" (1) and "Ending Stitch" (2) boxes located in the 
main toolbar at the top of Editor window. In this example, we have localized the stitch no. 1000 (Picture No. 
1).  

Picture No. 1  

 

4 - Move the mouse pointer to any of the color boxes at the right side of the screen and click the right mouse 
button. A popup menu will appear. Choose the "Hide All Colors" command from this menu (Picture No. 2).  

Picture No. 2  

 

5 - All colors will be hidden, only the selection remains visible. In our example, only the stitch no. 1000 is 
selected, therefore all stitches below 1000 and over 1001 will be hidden, only stitch no. 1000 is visible 
(Picture No. 3). 
6 - Now you can use the "Edit -> Stitch Type" menu to change the type of selected stitch. 
 
Note: Another way of stitch selection is shown in Change Stitch Type tutorial. 
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Picture No. 3 

 



 190 

Masking Designs  

When you would like the stitches in an object underneath to be deleted automatically where the upper object 
overlaps, use the "Mask" function of Editor. This function can be used only for two or more selected objects.   

Note: If you want to apply the "Mask" function to a single object, you must first split it in such a way, that 
you separate the underneath layer into the first object, and the upper layers into the second object. 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the first design (Picture No. 1).  

Picture No. 1  

 

3 - Select "File -> Merge" menu to bring in the second (upper) design (Picture No. 2).  

Picture No. 2  

 

4 - Select the objects you want to mask. In this case, there are only 2 objects on Work Area, so click "Edit -> 
Select All" menu to select them. As you can see at the right side of the screen, both objects are now selected 
(Picture No. 3). 
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Picture No. 3 

 

5 - Select "Edit -> Mask" menu. A dialog box will appear on the screen allowing you to modify the "Pull 
compensation" parameter, which specifies the overlap between the upper and bottom objects on the edges of 
splitting (Picture No. 4).  

Picture No. 4 

 

6 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen. 
7 - Finally, check the results of the mask function. Click "Edit -> Deselect All" menu to cancel the selection of 
objects. Then move the mouse pointer to the upper object (dog), depress the left mouse button and move 
the mouse to change the position of the upper object.  You can see that the stitches in the bottom object 
were deleted automatically where the upper object overlaps (Picture No. 5).  

Picture No. 5 
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Objects Order Bar  

The Objects Order Bar is on the right side of Embird Editor screen. It defines the order in which objects 
would be embroidered if joined into a single design. You can change the order by moving objects within the 
Objects Order Bar. The following tutorials explains how to use the Objects Order Bar  to change the sewing 
order in a design combined of 6 characters:  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the first design using "File -> Open" menu. In this example, the first design file contains the "M" 
character. 
3 - Merge other designs into the work area by selecting "File -> Merge" menu. In this example, five 
characters were merged into the work area in this order: "E", "B", "I", "R", "D".  The sewing order of all 6 
characters is "M", "E", "B", "I", "R", "D" (as it can be seen at Object Order Bar Picture No. 1) because we 
have opened the "M" file first, then merged "E" next, followed by the "B", "I", "R", "D" characters. This 
tutorial will demonstrate how to change the sewing order of the first and second characters so that the 
embroidery machine would sew the word "EMBIRD" from left to right. If you look on Picture No. 1, there is 
already word "EMBIRD" in work area, but the order of sewing would be: sew the "M" character first, then 
jump to the left, sew the "E" character, then jump to the right and sew "BIRD".  

Picture No. 1  

 

4 - Move mouse pointer to the icon of the "E" character at Object Order Bar and click left mouse button to 
select this object (Picture No. 2).  

Picture No. 2  
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5 - Drag and drop the icon of the "E" character on the top of the icon of the "M" character, because these are 
the two objects which position should be exchanged. A pop-up menu will appear (Picture No. 3). 
 
Note:  The "drag and drop" technique works in the following way: Move mouse pointer to the icon, depress 
the left mouse button and hold it down while moving the mouse pointer to the target position. Once the 
mouse pointer is located over the target icon, release the left mouse button. 

Picture No. 3 

 

6 - Select "Swap Objects" from this pop-up menu. This will exchange the sewing order of "E" and "M" 
characters. However, it does not mean, that the "E" character will be placed on the position of the "M" 
character in work area (Picture No. 4).  

Tip: Check the sewing order of this combined design in Sew Simulator by selecting "View -> Sew Simulator" 
menu. 

Picture No. 4 

 

7 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and the 
file name of the new design in the dialog boxes which appear on the screen.  
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Open Designs for Giant Hoop-It-All™  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).   

Picture No. 1  

   

3 - Click "Giant Hoop-It-All™" tab and choose the right hoop type for your sewing machine (Picture No. 2). 
Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

   

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename).  
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Picture No. 3  

   

5 - Embird will ask you about the position in Giant Hoop-It-All™ hoop for every file being merged into Editor. 
Specify the "Side" and "Position" in the dialog box which appears on the screen (Picture No. 4). If you are 
opening files that were prepared in Embird, you can deduce the side and position from the last two characters 
of the file name displayed in the blue bar at the top of the window, e.g.  "www_BC.hus" means "Bottom 
Side", "Position C".  
6 - Repeat the steps 4 and 5 for every part you want to open. You can select multiple files in "Merge Files" 
dialog box. 

Picture No. 4 

  

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5).  

Picture No. 5 
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Open Designs for Giant-L Hoop-It-All™  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).   

Picture No. 1  

   

3 - Click "Giant Hoop-It-All™" tab and choose the right hoop type for your sewing machine (Picture No. 2). 
Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

   

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename).  
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Picture No. 3  

   

5 - Embird will ask you about the position in Giant-L Hoop-It-All™ hoop for every file being merged into 
Editor. Specify the "Side" and "Position" in the dialog box which appears on the screen (Picture No. 4). If you 
are opening files that were prepared in Embird, you can deduce the side and position from the last two 
characters of the file name displayed in the blue bar at the top of the window, e.g.  "www_LA.pcs" means 
"Left Side", "Position A".  
6 - Repeat the steps 4 and 5 for every part you want to open. You can select multiple files in "Merge Files" 
dialog box. 

Picture No. 4 

  

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5).  

Picture No. 5 
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Open Janome GigaHoop Design  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

3 - Choose "Janome GigaHoop - Horizontal" or "Janome GigaHoop -Vertical" option (Picture No. 2). Typical 
position is horizontal, with two overlapping hoops. The vertical position works the same way as the horizontal 
does, just the parts are automatically rotated by -90 degrees when loading/saving from/to the hard disk. 
Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

 

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

 

5 - Embird will ask you about the position in Janome GigaHoop for every file being merged into Editor.  If you 
are opening files which were prepared in Embird, you can deduce the position from the file name displayed in 
the blue bar at the top of the window. In this example, it is www_1.jef file and it should be placed into 
position 1 in Janome Giga Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

 

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5). 

Picture No. 5 
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Open Janome #5 Hoop Design  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

3 - Choose "Janome #5 Vertical" or "Janome #5 Horizontal" option (Picture No. 2). Typical position is vertical, 
with 11 overlapping hoops. The horizontal position works the same way as the vertical position does, but the 
parts are automatically rotated by +90 degrees when loading/saving from/to the hard disk. Confirm the hoop 
selection by clicking "OK" button.  

Picture No. 2  

 

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

 

5 - Embird will ask you about the position in Janome #5 Hoop for every file being merged into Editor.  If you 
are opening files which were prepared in Embird, you can deduce the position from the file name displayed in 
the blue bar at the top of the window. In this example, it is www_1.sew file and it should be placed into 
position 1 in Janome #5 Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

 

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5).  

Picture No. 5 
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Open Pfaff Grand Dream Hoop Design  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

3 - Choose "Pfaff Grand Dream Hoop - Vertical" or "Pfaff Grand Dream Hoop - Horizontal" option (Picture No. 
2). Typical position is vertical, with two overlapping sections. The horizontal position works the same way as 
the vertical does, just the parts are automatically rotated by -90 degrees when loading/saving from/to the 
hard disk. Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

 

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

 

5 - Embird will ask you about the position in Pfaff Grand Dream Hoop for every file being merged into Editor.  
If you are opening files which were prepared in Embird, you can deduce the position from the file name 
displayed in the blue bar at the top of the window. In this example, it is "part_a.vp3" file and it should be 
placed into position 1 (section A, as specified by the last character of the filename) of Pfaff Grand Dream 
Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

 

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5).  

Picture No. 5 
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Open Pfaff Grand Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

3 - Choose "Pfaff Grand Hoop - Horizontal" or "Pfaff Grand Hoop - Vertical" option (Picture No. 2). Typical 
position is horizontal, with two overlapping hoops. The vertical position works the same way as the horizontal 
does, just the parts are automatically rotated by -90 degrees when loading/saving from/to the hard disk. 
Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

 

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

 

5 - Embird will ask you about the position in Pfaff Grand Hoop for every file being merged into Editor.  If you 
are opening files which were prepared in Embird, you can deduce the position from the file name displayed in 
the blue bar at the top of the window. In this example, it is "embird biza.vip" file and it should be placed into 
position 1 (section A, as specified by the last character of the filename) of Pfaff Grand Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

 

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5).  

Picture No. 5 
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Open Pfaff Multi-Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).   

Picture No. 1 

   

3 - Choose "Pfaff Multi-Hoop - Horizontal" or "Pfaff Multi-Hoop - Vertical" option (Picture No. 2). Typical 
position is horizontal, with three overlapping sections. The vertical position works the same way as the 
horizontal does, but the parts are automatically rotated by -90 degrees when loading/saving from/to hard 
disk.  

Picture No. 2  

  

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

   

5 - Embird will ask you about the position in Pfaff Multi-Hoop for every file being merged into Editor.  If you 
are opening files which were prepared in Embird, you can deduce the position from the file name displayed in 
the blue bar at the top of the window. In this example, it is Embird_1.pcs file and it should be placed into 
position 1 in Pfaff Multi-Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

   

7 - Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order 
Bar, so that their order is correct (Picture No. 5). 

Picture No. 5 
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Open Viking Plus Hoop Design  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

3 - Choose "Viking Plus - Vertical" or "Viking Plus - Horizontal" option (Picture No. 2). Typical position is 
vertical, with three overlapping sections. The horizontal position works the same way as the vertical does, just 
the parts are automatically rotated by -90 degrees when loading/saving from/to the hard disk. Confirm the 
hoop selection by clicking "OK" button.  

Picture No. 2  

 

4 - Click "File" menu and choose the "Merge" command. The "Merge Files" dialog box will appear on the 
screen (Picture No. 3). Select the file you want to open. You can select multiple files at once (e.g. by 
depressing SHIFT key when you are clicking on a filename). 
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Picture No. 3 

 

5 - Embird will ask you about the position in Viking Plus Hoop for every file being merged into Editor.  If you 
are opening files which were prepared in Embird, you can deduce the position from the file name displayed in 
the blue bar at the top of the window. In this example, it is rosac_1.hus file and it should be placed into 
position 1 (top) in Viking Plus Hoop (Picture No. 4). 
6 - Repeat the steps 4 and 5 for every part. You can select multiple files in "Merge Files" dialog box.  

Picture No. 4 

 

7 - After opening all of the parts there will be a complete design in Work Area. In this example in consists of 
three roses designs (Picture No. 5). Sometimes it might be necessary to change the order of objects - this 
relates to the case of overlapping objects. The last object shown at Object Order Bar at the right side of the 
screen will be sewn you as the last one (and it will cover other objects lying below in case they overlap). If 
necessary, drag and drop the objects at Objects Order Bar, so that their order is correct.  

Picture No. 5 
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Output to EMD Smart Media Card 

Use this command to write designs to EMD Smart Media Cardl; either for Elna or for Singer embroidery 
machine. It is supposed, that you have the Smart Media Card reader attached to your PC, and that this card 
reader works like another disk drive on your PC (e.g. drive F:).  
 
1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen select the design which you want to write to EMD Smart 
Media Card. To select a design, please move the mouse pointer to its file name and click the left mouse 
button (Picture No. 1). You can select multiple files: Move mouse pointer to the file name of the first design in 
the "Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving 
the mouse pointer over the file names of the other designs. When the mouse pointer is over the last design, 
please release the left mouse button.  

Picture No. 1  

   

3 - Select "Right Panel -> Input/Output Operations -> Output to Elna (or Singer) EMD Smart Media Card" 
command from the main menu (Picture No. 2).  

Picture No. 2  
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4 - A dialog box will appear on the screen (Picture No. 3). Choose the "Drive:" which contains EMD Smart 
Media Card. In this example it is "F:" drive. The upper box shows the folders and files of EMD Smart Media 
Card (empty card in this example).  
5 - Switch ON the "Erase card contents before writing new designs" option if you want to delete all designs 
which are already stored on the card (Picture No. 3). 
6 - The bottom box shows the files which you are going to write to the card (Picture No. 3). Click "Write files 
to card" button to start writing of designs to the card. 

Picture No. 3 

 

7 - Embird will write the files to EMD Smart Media Card and it will display the result of this operation (Picture 
No. 4). Click "Close" button to close this window.  

Picture No. 4 
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Passwords Back-up  

Embird allows you to easily back-up all inserted passwords into a "PASSWORD" file stored either on your 
hard disk, floppy disk, USB memory key, etc. We strongly recommend that you back-up your passwords 
regularly to avoid problems caused by re-installation, hard disk failure, or virus attack. If you have a back-up 
copy of your passwords, it is very easy to insert them back into Embird and thus change the demo 
(evaluation) version into the full version.  
 
You can also use the steps explained in this tutorial to transfer the passwords from your desktop computer 
to your laptop, so it will be fully functional on your second computer. However, please note that you may 
transfer Embird to another computer only as long as the other computer is owned by you and as long as it is 
used on only one computer at a time. 
 
Follow these steps to back-up your passwords: 
 
1 - Run Embird and select "Help -> Passwords" menu (Picture No. 1).  

Picture No. 1  

 

2 - The "Passwords" dialog box will appear on the screen. It contains two sections: "Back-up passwords" and 
"Recover passwords" (Picture No. 2). 
3 - To back-up your passwords, insert formatted floppy disk into the A: drive and click the "Back-up" button. 
This will create a "PASSWORD" file on the floppy disk, containing all your passwords. 
 
Note: If you want to back-up your passwords to other disk media, e.g. to USB memory key, choose the drive 
containing this media in the "Back-up to drive:" box before you click the "Back-up" button.  

Picture No. 2  
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Follow these steps to recover your passwords: 
 
4 - Run Embird and select "Help - > Passwords" menu (Picture No. 3).  

Picture No. 3  

 

5 - The " Passwords" dialog box will appear on the screen. It contains two sections: "Back-up passwords" and 
" Recover passwords" (Picture No. 4). 
6 - Choose the disk drive containing the media with back-up copy of your passwords - the one you created in 
step 3. Click "Recover" button to read the passwords from the media and launch them into Embird. This will 
change the demo (evaluation) version of Embird into the full version. 

Picture No. 4 

 

Tip: To verify that your copy of Embird is registered, run Embird and check the blue bar at the top of Embird 
Manager window. If you see "Embird Manager - registered to [your name]" text there then you have 
registered copy (see the blue bar in Picture No. 1 above). To find out which Embird plug-ins are installed and 
registered on your computer, please select "Help -> Installed Plug-ins" menu in Manager or Editor window.  
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Points Editing Mode  

This tutorial explains the Points Editing Mode of Embird Editor. It shows how to: 
 
- Move a single or several stitch points,  
- Add a new stitch point,  
- Change the stitch type, 
- Split the design on chosen stitch point.  
 
Similar steps can be used for deleting of a single or several stitch points.  
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the design which you want to edit  
3 - Click "Points Editing Mode" button or choose this mode using "Mode -> Points Editing Mode" menu. 
4 - Select the area of editing (Picture No. 1). Depress the left mouse button and drag mouse to select the 
area of editing by rectangle. Release the left mouse button once you have chosen the suitable area. In this 
example, we are going to edit some stitches in the top-left corner of the "a" character.  

Picture No. 1  

   

5 - Only those stitch points which lie inside the selection rectangle are accessible for editing. All the rest 
points are drawn in ghost color (Picture No. 2).  

Picture No. 2  
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6 - Move mouse pointer to the handle square of some point, depress the left mouse button and drag mouse 
(while holding the left mouse button down) to move this point (Picture No. 3). The point being moved is 
selected - notice that it has thick handle square. 

Picture No. 3 

  

7 - If you want to move several points at once, you will have to select them first. Click left mouse button on 
the first point to select it. Then move mouse cursor to the second point, depress SHIFT key on the keyboard 
and click the point while holding the SHIFT key down. It will be added to the selection. Now you should have 
two points with thick handle square. Repeat this procedure for every point which you want to add to the 
selection. You can see the number of selected points at the bottom of "Objects Order Bar" at the right side of 
the screen (Picture No. 4).  

Picture No. 4 
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8 - Once you have selected several points, you can move them to the new position. Move mouse pointer to 
any of selected points, depress the left mouse button and drag mouse. Release left mouse button once you 
have moved the points to the new position (Picture No. 5).   

Picture No. 5 

  

9 - You can add a new stitch point easily. The new point is always added AFTER the selected point. Therefore 
it is very useful to switch on the setting in "View -> Stitch Direction" menu, so that you can see the stitch 
direction and select the right point (Picture No. 6).   

Picture No. 6 
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10 - Once you have selected the right point, move mouse pointer to this point and depress the right mouse 
button. A popup menu will appear on the screen (Picture No. 7). Choose "Insert" command from this menu. 
Another way of inserting new point is to depress "Shift" and "Ins" keys simultaneously after selecting the right 
point.  

Picture No. 7 

  

11 - A new point is created in the middle between selected and following point (see arrow in Picture no. 8). 
The new point becomes selected immediately, so that you can move it to other position if necessary.  
 
Note: You can add several new points at once this way: Select several points first after which you would like 
to add the new points. Then use the same steps as shown above.   

Picture No. 8 
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12 - There exists another way of adding new points: You can add them "freehand", directly to the right 
position. Select the point after which you would like to add the new point. Then move mouse pointer to the 
position where you would like to place the new point. Depress CTRL key on the keyboard and click the left 
mouse button while holding the CTRL key down (Picture No. 9).   

Picture No. 9 

  

13 - A new point is created and placed on the chosen position (Picture No. 10). The new point becomes 
selected immediately, so that you can move it to another position if necessary.  

Picture No. 10 
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14 - Points Editing Mode allows you to change the stitch type easily. Stitch type always relates to the stitch 
BEFORE selected point. In the example below, we want to change the connection stitch between characters 
to floating stitch (jump), because now it is running stitch. Select the end point of connection stitch and then 
click the right mouse button for popup menu (Picture No. 11).  Choose "Change to Floating Stitch" command 
from this menu.  

Picture No. 11 

  

15 - Now you can see that the stitch type have changed to floating (jump) (Picture No. 12). Floating stitches 
are drawn by dashed line in Embird.  

Picture No. 12 
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16 - Another feature of Points Editing Mode is that you can split the design on chosen point. In the example 
below, we want to separate the characters - split the design on connection stitch. Select the end point of 
connection stitch first. Then click the right mouse button for popup menu. Finally, choose "Split" command 
from this menu (Picture No. 13).   

Picture No. 13 

  

17 - The design was split on the selected point (Picture No. 14). Now we have two objects in Editor, you can 
see their icons in "Objects Order Bar" at the right side of the screen.  

Picture No. 14 
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Port Connection to Embroidery Machine - Receiving Design 

Use this command if you want to receive (download) a design from embroidery machine into Embird via serial 
communication link. 
 
Note: Only serial communication with Barudan embroidery machine is supported in current version of 
Embird. 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select "Right Panel -> Port Connection to Embroidery Machine" menu (Picture No. 1).  

Picture No. 1  

 

3 - A dialog box will appear on the screen (Picture No. 2). Check the "Serial port" settings - you must choose 
the port on which there is attached a serial communication cable to your embroidery machine.  
4 - Now you are ready to receive the design from the embroidery machine. Go to your embroidery machine 
and let it send the design to communication port connected to PC. Find how to make this operation in the 
manual for your embroidery machine.  
5 - Return to your PC and click "Receive from embroidery machine" button (Picture No. 2).  

Picture No. 2  

 

6 - The serial communication between PC and embroidery machine will start. Embird will receive the bytes of 
the design sent from embroidery machine and it will show the progress (Picture No. 3). 



 222 

Picture No. 3 

  

7 - When Embird receives the last byte of the design, it will wait 5 seconds to make sure this is really the end 
of the data transfer. Then it will offer your a dialog box, in which you can choose the format of the design, 
which was received and is now going to be saved to your hard disk (Picture No. 4). Click "OK" button to 
continue.  

Picture No. 4 

  

8 - In another dialog box you will have to specify the filename for this design (Picture No. 5). Click "OK" 
button to continue. 

Picture No. 5  
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9 - Finally, the received design will be shown on the screen (Picture No. 6).  

Picture No. 6 
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Port Connection to Embroidery Machine - Sending Design  

Use this command if you want to send (upload) a design from Embird to embroidery machine via serial 
communication link. 
 
Note: Only serial communication with Barudan embroidery machine is supported in current version of 
Embird. 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select the design you want to send to embroidery machine in "Files" box on Right Panel.  (Picture No. 1). 
To select the design, please move mouse pointer to its file name and click the left mouse button.  

Picture No. 1  

 

3 - Select "Right Panel -> Input/Output Operations -> Port Connection to Embroidery Machine" menu (Picture 
No. 2).  

Picture No. 2  
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4 - A dialog box will appear on the screen (Picture No. 3). Check the "Serial port" settings - you must choose 
the port on which there is attached a serial communication cable to your embroidery machine.  
5 - Now you are ready to send the design to the embroidery machine. Go to your embroidery machine and 
prepare it for receiving the design on communication port connected to PC. Find how to make this operation 
in the manual for your embroidery machine.  
6 - Return to your PC and click "Send to embroidery machine" button (Picture No. 3). 

Picture No. 3 

 

7 - The serial communication between PC and embroidery machine will start. Embird will send the bytes of 
the selected design and it will show the progress (Picture No. 4).  

Picture No. 4 

  

8 - Once the uploading is finished, Embird will display the results of data transfer (Picture No. 5). Now you are 
ready to sew out the design on your embroidery machine.  

Picture No. 5 
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Print & Stitch 

This tutorial explains how to process the Print & Stitch design in Embird. Print & Stitch technology works in 
the following way: An image can be selected as a background to an embroidery design. This image can be 
resized and printed out (as a mirror image) onto Iron-On transfer paper. This is then ironed onto a piece of 
material, cut out and then hooped for embroidery. A coordinating design is then stitched on top.  
 
It is supposed here that you have some image and the designs which should be embroidered onto the image. 
It will be explained below how Embird can simplify this process.  
 
1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Use "Image -> Open" command from main menu to open the background image file (Picture No. 1).  
3 - Use "Image -> Set Size" command from main menu to set the size of the background image.  

Picture No. 1  

   

4 - Use "File -> Merge" command to merge a design or even several designs belonging to the image (Picture 
No. 2). Do not use "Open" command, because this will erase the background image.  

Picture No. 2  

   

5 - While merging a design, Embird will ask you about its position. (Picture No. 3). This is used for designs 
that have been previously prepared for the Print & Stitch technology in Embird. This is further explained in 
step 8 below. For now, click "Cancel" button when asking about position. 
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Picture No. 3 

  

6 - When you have merged all parts, you can position them over image, because their position is probably not 
correct (Picture No. 4).  Sometimes it is necessary to split some designs, because each part must fit into:  
 
- 100 x 100 mm hoop for .PES, .PEC and .HUS formats, 
- 125 x 90 mm hoop for .SEW format, 
- 140 x 200 mm hoop for .JEF format, 
- 200 x 200 mm hoop for .JEF+ format, 
- 120 x 115 mm for .PCS, .PCM and .VIP formats, 
- 130 x 240 mm for .XXX format. 
 
Read Interactive Freehand Splitting tutorial to find out how to split a design.  

Picture No. 4 

  

7 - All parts are on the correct position now (Picture No. 5). We have also verified that their sizes do not 
exceed the size of hoop, as specified in step 6.  

Picture No. 5 
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8 - Click "File -> Save As" in main menu to save the parts to hard disk. Embird will display a dialog box, 
allowing you to specify the format and file name. Then it will save each part to hard disk. It will automatically 
generate file name for every part being saved, e.g. if you choose "babybook.hus" as filename, Embird will 
save part 1 as "babybook_1.hus", part 2 as "babybook_2.hus", etc. While saving designs, Embird will put a 
small black dot on the image, showing the hoop centering for each part being saved. This will simplify the 
process of embroidering, because you will be able to hoop the fabric and position the needle precisely. When 
the saving is finished, a table with positions is displayed. You can print this table and use it later when re-
opening designs in Embird - see step 5. 
9 - Click "Image -> Save" command in main menu to save modified background image to the hard disk. While 
saving background image, Embird will ask you about the saving of a special file with the .BMQ extension. This 
file contains positions of stored designs. It can be very useful when re-opening parts saved in step 8. If you 
allow Embird to create the .BMQ file, the position box shown in step 5 will be automatically filled with correct 
data.  
10 - Print mirror image of background. Click " Image -> Print Preview" command in main menu to check the 
image before printing. Embird will ask you whether you want to print the mirror image or normal image. Click 
" Image -> Print" command if you are satisfied with print preview. 
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Print Template    

The following tutorial explains how to print a template from Editor. In Embird 2006 and later, it is possible to 
change the position of design being printed - you can move the design across the paper to the right position if 
you want to save the paper space - e.g. if you want to print two or more designs using the same sheet of 
vellum. 
 
Note: You can print the documentation for your designs also from Manager, using the commands contained 
in the "Right Panel -> Print" menu. There are several types of documentation available in this menu. 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select the "File -> Open" menu to open a file which you want to print out (Picture No. 1).   

Picture No. 1  

 

3 - Click the "File -> Print Template without Texts" menu if you want to have the possibility to prescribe the 
design position on the printer paper (Picture No. 2). 

Picture No. 2  

 

4 - The "Print" dialog will appear on the screen (Picture No. 3). Choose your printer in the "Name:" box, and 
click "OK" button to continue. 
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Picture No. 3 

 

5 - The "Print Layout" dialog box will appear on the screen (Picture No. 4). The cyan rectangle represents the 
hoop being printed. In this example, the hoop size is 100 x 100 mm, as it can be seen on the caption 
displayed in the middle of the cyan rectangle. The captions in the corners display the current position of these 
corners over the printer paper. 

Picture No. 4 

 

6 - You can change the hoop position by moving the mouse pointer to the cyan rectangle, depressing the left 
mouse button and moving the mouse to change the position of the rectangle. Finally, release the left mouse 
button (Picture No. 5). 

Picture No. 5 
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7 - You can double-click the paper area to add a text. This will display a dialog box with the pre-defined text, 
which relates to the design being printed (Picture No. 6). You can delete this text, or add some new lines. If 
you want to change the font of the text, click the "Font" button and choose the new one from the dialog box 
which appears on the screen. Click "OK" button to continue. 

Picture No. 6 

 

8 - You can move also the rectangle containing the text across the paper area (Picture No. 7). Use the same 
technique as explained in step 6. Finally, click "OK" button to print the template. 

Picture No. 7 

 

9 - The template will be printed with the hoop area and text area located on their prescribed positions 
(Picture No. 8). 

Picture No. 8 
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Printing Templates of Multiple Designs on Single Sheet  

This tutorial explains how to print templates of multiple designs on a single sheet of paper (or vellum). 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen select the first design which you want to print out. To 
select a design, please move the mouse pointer to its file name and click the left mouse button. Select only 
one design at this time, in this example it is SQUIRREL.DST. You can double click its file name to view the 
design in the preview area (Picture No. 1).  

Picture No. 1  

   

3 - Select "Right Panel -> Print -> Print Floating Design" command from the main menu (Picture No. 2).  

Picture No. 2  
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4 - A dialog box will appear on the screen, allowing you to choose the printer (Picture No. 3). Click "OK" 
button to continue.   

Picture No. 3 

 

5 - The "Print Layout" dialog box will appear on the screen. There are two cyan rectangles placed on the 
paper, the first one shows the position of the design image and the second one is optional comment, 
which you can specify after double clicking anywhere in the Layout area. You can move both rectangles by 
moving the mouse pointer on their area, depressing the left mouse button and moving the mouse pointer 
while holding down the left mouse button. After moving the rectangle to its new position, release the left 
mouse button. In this example, we have moved the "design image" box to the top left corner of the paper 
(Picture No. 4).  

Picture No. 4 

 

6 - Double click the Layout area to add the optional comment. In this example, we have moved the box with 
comment to the top of the paper, close to the design image (Picture No. 5). 
7 - Click "OK" button to print out the template of the first design (Picture No. 5). 

Picture No. 5 
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8 - Insert the printed paper (vellum) back to the printer, we will print another template of the second 
design on this paper. 
9 - Select the second design in the "Files:" box at the right side of the screen (Picture No. 6). In this example, 
it is CHAIR.DST design. You can double click its file name to view the design in the preview area. 
10 - Select "Right Panel -> Print -> Print Floating Design" command from the main menu again (Picture 
No. 6). 

Picture No. 6 

 

11 - The "Print Layout" dialog box will appear on the screen again. Again, there are two cyan rectangles 
showing the position of design image and optional comment, but now there are also two gray rectangles 
showing the position of previous print-outs (Picture No. 7). This is very useful, because now you can 
position the rectangles in such a way that they do not cover the parts of the paper (vellum) which are already 
used. 
12 - Click "OK" button to print out the template of the second design (Picture No. 7). 

Picture No. 7 

 

Tip 1: Click "Delete Print History" button if you want to clear the gray rectangles. This is helpful in case you 
are printing on a new paper, and the print history is not related to this paper. 
 
Tip 2: You can print multiple templates on a single sheet of paper also in Editor and Cross Stitch Plug-in, 
just open single file via "File -> Open" command and use "File -> Print Template without Texts" command. 
See also Print Template tutorial. 
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Processing ZIP and RAR Archives 

The files stored in ZIP and RAR archives can be extracted temporarily (for viewing or printing purposes) or 
permanently. Both ways are explained in this tutorial. 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Use "Drive", "Folder" and "Files" boxes (located on the Right Panel at the right side of the screen) to 
browse to the folder containing ZIP or RAR archive. 
 
If you want to temporarily extract files stored in ZIP or RAR archive, please follow these steps: 
 
3 - Double-click left mouse button on archive filename in "Files:" box to browse to the designs stored in this 
archive (Picture No. 1).  

Picture No. 1  

 

4 - The contents of the archive will be temporarily unzipped to the "TEMP_ZIP" folder created in the 
temporary folder for currently logged on user, e.g. into "C:\Documents and Settings\Administrator\Local 
Settings\Temp\TEMP_ZIP" (or into "C:\EMBIRD32\TEMP_ZIP" folder if you use version prior to Embird 2006), 
and this folder becomes focused automatically in "Files:" box. Now you can display or print the designs stored 
in the archive (Picture No. 2). However, please note that the files stored here are temporary and they will be 
deleted once you open another archive, or close Embird. See steps 6 ~ 8 below to find out how to extract 
files permanently.  
5 - If you want to close the archive and return back to the initial folder, click "Up One Level" button placed 
above "Folder:" box (Picture No. 2).  

Picture No. 2  
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If you want to permanently extract files stored in ZIP or RAR archive, please follow these steps: 
 
6 - Select the archive in "Files:" box at right panel, so that it is highlighted in blue color. You can select 
multiple files (e.g. by depressing SHIFT key when you are clicking archive filename). 
7 - Click "Right Panel" menu and choose "Extract Zipped Files to" command (Picture No. 3).  

Picture No. 3 

 

8 - Choose destination folder in the dialog box that appears on the screen. If this folder doesn't exist yet, it 
will be created. All files stored in selected archives will be unzipped to the chosen folder (Picture No. 4).  

Picture No. 4 

 

Note: The "TEMP_ZIP" folder is automatically created and managed by Embird. You should never place any 
files into this folder, because it is used for ZIP and RAR archives exclusively. If you are obtaining warning 
message during unzipping process reporting that this folder is non-empty, you should close Embird and delete 
this folder manually, e.g. in Windows Explorer or other file manager. 
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Reading Floppy Disks  

Embird supports standard and non-standard floppy disk formats.  
 
Standard floppy disks are disks with designs stored in standard MS-DOS format. These disks are recognized 
and can be accessed in Windows Explorer, common file manager or any other application supporting floppy 
disks. In Embird you can access standard floppy disk by choosing the disk drive (typically "A:") in "Drive:" box 
in Right Panel of Manager window. 
 
Non-standard floppy disks are disks with designs stored in special format. These disks are not recognized 
and cannot be accessed in Windows Explorer or in common file manager - these applications report "Disk is 
not formatted" error when you attempt to read floppy disk contents. In Embird you can access non-standard 
floppy disks via Left Panel menu of Manager window. However, the non-standard floppy disk formats require 
low-level access and therefore the non-standard floppy disks are supported only when running Embird in 
Windows 98 or Windows ME. Embird does not support non-standard floppy disks when running in Windows 
NT, 2000 or XP. 
 
Reading Standard Floppy Disks (MS-DOS Format) 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Insert the floppy disk into the disk drive. 
3 - Choose floppy disk drive in the right panel in "Drive:" box (Picture No. 1).  

Picture No. 1  

 

4 - In the "Files:" box at the right side of the screen select the design which you want to read from the floppy 
disk. To select a design, please move the mouse pointer to its file name and click the left mouse button 
(Picture No. 2). 
 
Note: You can select multiple files and read them all from the floppy disk at once. Please move mouse 
pointer to the file name of the first design in the "Files:" box at the right side of the screen, depress the left 
mouse button and hold it down while moving the mouse pointer over the file names of the other designs. 
When the mouse pointer is over the last design, please release the left mouse button.  
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Picture No. 2  

 

5 - Move mouse pointer to the "Files:" box in right panel and click right mouse button for popup menu. 
Choose "Copy Files to Clipboard" command to copy selected designs to the clipboard. You will find this 
command also in "Right Panel" menu (Picture No. 3).  

Picture No. 3  

 

6 - Select hard disk drive in "Drive:" box in right panel (Picture No. 4). You can also choose the destination 
folder in "Folder:" box, into which the selected files from the floppy disk will be copied.  

Picture No. 4  
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7 - Move mouse pointer to the "Files" box in right panel and click right mouse button for popup menu. Choose 
"Paste Designs from Clipboard" command to copy the files from floppy disk to hard disk. You will find this 
command also in "Right Panel" menu (Picture No. 5).  

Picture No. 5  

 

8 - Embird will paste the files to the chosen drive and folder - in this example, the files will be written to the 
"C:\EMBIRD32\FILES" folder. 
 
Writing Non-Standard Floppy Disks (e.g. Barudan, ZSK) 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Insert the floppy disk into the disk drive.  
3 - Click "List A:" button and wait until Embird recognizes the floppy disk format (Picture No. 6).  
 
Tip: The list of supported non-standard disk formats appears after a short while after moving the mouse 
pointer to he "List A:" button.  

Picture No. 6  
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4 - You can see files stored on the floppy disk in the left panel in "Files:" box. Select files which you want to 
copy to the hard disk (Picture No. 7). To select the files, depress left mouse button and drag mouse over the 
filenames. 

Picture No. 7  

 

5 - Move mouse pointer to the "Files" box in left panel and click right mouse button for popup menu. Choose 
"Copy Files to Hard Disk" command. You will find this command also in "Left Panel" menu (Picture No. 8). 

Picture No. 8 

 

6 - Choose the target format and hit "OK" button to continue (Picture No. 9).  
7 - Embird will read the files from the floppy disk, convert them 'on-the-fly' to chosen format and finally save 
them to hard disk to the actually chosen "Drive:" and "Folder:" in the right panel. Wait until this process is 
finished.  
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Picture No. 9 

 

8 - Once the reading process is finished, a dialog box will appear on the screen, showing the result of the 
operation. You will see the files saved on the hard disk in the right panel in "Files:" box (Picture No. 10).  

Picture No. 10 
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Resizing with Density Adjustment 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design using "File -> Open" menu.  
3 - Click the "Set Size" button, or select the "Edit -> Set Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Click "Stitch Density" button in the "Set Size" dialog box which appears on the screen. This will display 
another dialog box, allowing to change the resizing settings (Picture No. 2).  

Picture No. 2  
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5 - Choose the resizing mode: with or without density adjustment. If you decide to resize with density 
adjustment, you can specify whether you want to keep the original fill pattern for filled areas, or whether 
these areas will be re-filled with a new pattern. You can specify also the density of column stitches and 
density of fill stitches (Picture No. 3). The bigger number you type into the density boxes, the lower density 
you obtain. In fact, this number is distance between stitches in tenths of millimeters (value 4 means 0.4 mm). 
The fill stitches pattern is used for filled areas (this setting is available only in case you switch off the "Keep 
original fill pattern" option). The default setting for pattern is "Fill 1", the examples of all patterns can be seen 
after clicking "Example" button. If you choose the "None" pattern, the fill areas will become columns. 

Picture No. 3 

 

6 - Specify the new size of the design, or let it be the same if all you want to change is the stitch density 
(Picture No. 4).  
7 - Finally, click "OK" button to finish the resizing.  

Picture No. 4 
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Resizing with Density Adjustment (Advanced) 

It this example, it will be shown how you can resize a design with density adjustment. Part of the design will 
be resized with retaining the original fill pattern, while the rest of the design will be re-filled with a new 
pattern. We want to resize the balloon design (Picture No. 1) to 150% of its original size. We would like to 
maintain the fill pattern for the upper part (cyan color), and all the other parts should be re-filled with a new 
pattern.  

Picture No. 1  

 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the file you want to resize. Select the "File -> Open" menu to open a file (Picture No. 2).  

Picture No. 2  
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3 - Separate the upper cyan part of the balloon, which is the color no. 2 in this example. Move the mouse 
cursor to the color no. 2 in the "Object Order Bar" at the right side of the screen (arrow 1) and depress the 
right mouse button. A popup menu will appear on the screen (Picture No. 3). Select "Separate Color" 
command from this menu (arrow 2). The design will be split to three parts - stitches before color no. 2, 
stitches of color no. 2, and stitches after color no. 2. The second part will be selected, with a rectangle around 
it (Picture No. 4).  

Picture No. 3 

 

4 - Click "Set Size" button (arrow 1), or select "Edit -> Set Size" menu (Picture No. 4). Specify the new 
relative size, in this example it is 150%, click the "Keep position" box to set this option to OFF (arrow 3) and 
then click the "Stitch Density" button (arrow 4).  

Picture No. 4 

 

5 - Set the "Adjust stitch density when resizing" and "Keep original fill pattern" options to ON (Picture No. 5). 
Then click "OK" button to confirm these settings and return to previous dialog box. Hit "OK" button in this 
dialog to resize the selected part.  
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Picture No. 5 

 

6 - Select the two remaining parts of design. Repeat the steps 4 and 5, but in the "Stitch Density" dialog box 
set the "Keep original fill pattern" option to OFF (arrow 1) and choose "Fill 1" (arrow 2) as the new pattern 
(Picture No. 6).  

Note: A quick method to select several designs is to left click on the first design, then while holding down the 
Shift key, left mouse click on another design to add it to the selection. You can click on a design within the 
design screen or click a design icon on the "Objects Order Bar" (right side of the screen). 

Picture No. 6 

 

7 - Finally, select "File -> Save As" menu to save the new resized design to your hard disk. You do not need 
to join the three parts before saving, it will be done automatically during the saving process. The result of 
resizing can be seen in Picture No. 7. The upper part has the same pattern as the original design, all the other 
parts are re-filled with a new pattern - compare this picture with Picture no. 1 above.  

Picture No. 7 
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Resizing with Density Adjustment (Prescribe Stitch Count)    

The following tutorial explains how to resize a design with density adjustment and prescribe the approximate 
number of stitches in the final design. 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the file you want to resize. Select the "File -> Open" menu to open a file (Picture No. 1).  

Picture No. 1  

 

3 - Click "Options -> Stitch Density" menu, this will display the "Stitch Density" dialog box on the screen 
(Picture No. 2). Set the "Calculate stitch density automatically to obtain prescribed stitch count" option to ON 
and click "OK" button to confirm these settings. 

Picture No. 2  

 

4 - Click "Edit -> Set Size" menu to change the dimensions of the design. The "Set Size" dialog box will 
appear on the screen. In this example the design is going to be enlarged to 150% of its original size, so 
change the relative width and height of the design to 150% (Picture No. 3). Click "OK" button to continue. 

Picture No. 3 
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5 - Embird will resize the design and display the dialog box, in which you can prescribe the stitch count of 
enlarged design (Picture No. 4). The current values of the "Column stitches density" and "Fill stitches density" 
settings (see the "Stitch Density" dialog box in Picture No. 2 above) would lead to a design with 14358 
stitches. However, you can prescribe e.g. 13000 stitches for the final design (Picture No. 5). Type in the 
"13000" number and click "OK" button to continue. 

Picture No. 4 

 

Picture No. 5 

 

6 - Embird will automatically adjust the density of filled areas and columns to reach the prescribed stitch 
count (Picture No. 6). The number of stitches in the enlarged design is 12971, i.e. it is approximately 13000 
as prescribed in step 5. 

Picture No. 6 

 

7 - Finally, select "File -> Save As" menu to save the resized design to your hard disk. 
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Save and Open Workspace in Editor    

The following tutorial explains how to use the "Save Workspace" and "Open Workspace" commands of Editor. 
These commands allow to store the workspace so that it can be restored exactly as displayed, with objects 
separated, stitches selected, etc. Use these commands if you want to stop your work and continue on another 
day; and have the possibility to quickly restore the current state of workspace. 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the designs and make the editing - in this example there are two objects in the work area, and some 
stitches of the object no. 2 are selected (Picture No. 1).  

Picture No. 1  

 

3 - Click the "File -> Save Workspace As" menu to save the current state of the workspace to a file on your 
hard disk (Picture No. 2). 

Picture No. 2  
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4 - The "Save Workspace" dialog box will appear on the screen (Picture No. 3). Specify the name of the file 
for your project - e.g. "MyProject.eef". The ".eef" extension is mandatory; it means "Embird Editor File". Click 
"Save" button to save the project.  
5 - Once the saving is finished, you can close Editor and exit Embird. 

Picture No. 3 

 

6 - On another day, if you decide to re-open this project, run Embird, switch to "Editor" window and click the 
"File -> Open Workspace" menu (Picture No. 4). 

Picture No. 4 
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7 - The "Open Workspace" dialog box will appear on the screen (Picture No. 5). Choose the "MyProject.eef" 
file and click "Open" button to continue. 

Picture No. 5 

 

8 - Embird will open this workspace project file and it will restore the state of work area - there are two 
objects, and some of the stitches in object no. 2 are selected (Picture No. 6). 

Picture No. 6 

 

9 - Now you can continue with editing, e.g. you can click "Edit -> Split" menu to separate the selected 
stitches in object no. 2. 



 252 

Save Brother Jumbo Hoop Design, Save Viking Plus Hoop Design  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design, which you want to save for Jumbo Hoop or for Viking Plus Hoop. To open a design, click 
"File" menu and choose "Open" command. Please note, that you probably will have to split this design into 
two or three parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Select the proper hoop size, for example "Brother Jumbo Small" or "Viking Plus" (Picture No. 2). Confirm 
the hoop selection by clicking "OK" button.  

Picture No. 2  

 



 253 

5 - You can see now, that the design exceeds the size of one of the three overlapping hoops (red, green, 
blue), which create the Brother Jumbo hoop. Therefore the design must be split at least into two parts. 
Optimal solution is to split the design somewhere between the red and blue hoops in their common area 
(Picture No. 3). Use the "Freehand Select Mode" to select the stitches you want to cut out (separate). More 
information regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(or select the "Edit -> Split" menu) to split the design, this will separate the red selection (Picture No. 4).  

Picture No. 4 
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7 - You can see the parts of split design (part1 and part2) in the "Object Order Bar" at the right side of the 
screen (Picture No. 5). Each part now lies completely in one of the three overlapping hoops.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the "Babylock, Bernina, Brother .PES" format in case of Brother Jump hoop, or the "Viking 
Husqvarna .HUS" format in case of Viking Plus hoop. In the second dialog box that appears on the screen you 
can choose the file name of the design being saved. 
 
Note: In case of Brother Jumbo hoop, all the design parts will be automatically combined and saved into a 
single .PES file on the hard disk. If you want to save each part into a separate file, choose the "Babylock, 
Bernina, Brother .PEC" format" in the "Choose Format" dialog box in step 8. 
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Save Designs for Giant Hoop-It-All™  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1). 

Picture No. 1  

   

3 - Click "Giant Hoop-It-All™" tab and choose the right hoop type for your sewing machine (Picture No. 2). 
Confirm the hoop selection by clicking "OK" button.  
 
Note: If you have not previously done so, verify the markings on your hoop to determine sections A, B, C, D, 
and E. See also the Section Definition in Hoop-It-All™ tutorial.  

Picture No. 2  
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4 - The empty hoop will be drawn in work area (Picture No. 3). 
 
The center of the hoop may be grayed out. If so, this area is non-usable with your sewing machine without 
re-hooping. Also, some area around the hoop perimeter and the corners might be grayed out. This area is 
reserved for needle mechanism and/or is non-reachable by machine's needle. 
 
You will see fuchsia, yellow, white and aqua bars around the hoop. These colors will be explained below. 
Also, there are all "child" hoops drawn, so that the working area looks very complicated. Child hoops 
represent the maximum design size that your sewing machine can sew out in one section within the Giant 
Hoop-It-All™. You can switch on/off each side of the hoop by depressing "Ctrl + Up", "Ctrl + Down", "Ctrl + 
Left" or "Ctrl + Right" key combination (also accessible via "View -> Hoops In Giant Hoop-It-All™" menu). 
You can turn them all on/off at once using the "Ctrl + Ins" key combination. 
 
All sides of the hoop work like a magnet. If you turn off some side, it stops "attracting" designs unless you 
turn it on again. This way you can prepare designs side-after-side, starting with right side and ending with 
top side. All designs belonging to some side will be drawn in that side's color (i.e. fuchsia, yellow, white or 
aqua), but only when the side is off. This way you can check to which side does the particular object belong - 
turn all sides off (by depressing "Ctrl + Ins" keys simultaneously) and you will see.  

Picture No. 3  

   

5 - Let's start with the right side of the hoop. Turn all other sides off using commands in "View -> Hoops In 
Giant Hoop-It-All™" menu (Picture No. 4).  

Picture No. 4 
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6 - You can see in work area that only the right side of the hoop is ON now (Picture No. 5).  

Picture No. 5 

 

7 - Merge the designs into the work area. Use "File -> Merge" menu to merge a file (Picture No. 6). For more 
information on merging files, please read the Open Designs for Giant Hoop-It-All™ tutorial.  

Picture No. 6 

  

8 - Move the design to the right side of the hoop (Picture No. 7).  

Picture No. 7 
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9 - As you can see in Picture No. 7 above, the design exceeds the size of child hoop (which represents the 
maximum design size that the embroidery machine is capable of sewing out). The design must be manually 
split in such a way that each part of the design would fit into one of the five overlapping child hoops (Picture 
No. 8). More information regarding the splitting is available in Interactive Free-Hand Splitting tutorial.  

Picture No. 8 

  

10 -  Repeat the splitting process until every object fits into one of the five child hoops (Picture No. 9). 
Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order Bar, 
so that their order is correct (Picture No. 9).  

Picture No. 9 

  

11 - When you are finished with the splitting, turn off the right side of the hoop (by depressing "Ctrl + Right" 
keys simultaneously). All objects belonging to the right side should be drawn in fuchsia color now (Picture No. 
10). In case some objects are not drawn in this color yet, it means that they do not fit into child hoop and you 
must split them again (press "Ctrl + Right" keys simultaneously to turn on the right side of the hoop and then 
repeat the step 9). Designs placed in the middle of the hoop in gray non-usable area cannot be saved and 
you must either delete them, or skip them during the saving process.  
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Picture No. 10 

  

12 - Turn on the following side of the hoop (e.g. the bottom side) and repeat the steps 7 to 11. 
13 - When you are finished with all four sides of the Giant Hoop-It-All™ hoop, click "File -> Save As" menu to 
save the all design parts to files on your disk. Specify the format and the file name in the dialog boxes which 
appear on the screen. Each design part will be saved into a separate file on the disk.  

Note: Embird will automatically append two characters to the file name of each part (Picture No. 11). These 
characters indicate the hoop section which belongs to the part, e.g. www_RE.hus means that the part should 
be sewn out at the "Right" side in "E" section. This is very helpful during sewing, or if you want to re-open 
these files in Editor - see also the Open Designs for Giant Hoop-It-All™ tutorial.  

Picture No. 11 
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Save Designs for Giant-L Hoop-It-All™  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1). 

Picture No. 1  

   

3 - Click "Giant Hoop-It-All™" tab and choose the right hoop type for your sewing machine (Picture No. 2). 
Confirm the hoop selection by clicking "OK" button.  
 
Note: If you have not previously done so, verify the markings on your hoop to determine sections A, B, C, D, 
and E. See also the Section Definition in Hoop-It-All™ tutorial.  

Picture No. 2  
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4 - The empty hoop will be drawn in work area (Picture No. 3).   
 
Some area around the hoop sides and the corners might be grayed out. This area is reserved for needle 
mechanism and/or is non-reachable by machine's needle. 
 
You will see fuchsia and white bars at the left and right sides of the hoop. These colors will be explained 
below. Also, there are all "child" hoops drawn, so that the working area looks very complicated. Child hoops 
represent the maximum design size that your sewing machine can sew out in one section within the Giant-L 
Hoop-It-All™. You can switch on/off each side of the hoop by depressing "Ctrl + Left" or "Ctrl + Right" key 
combination (also accessible via "View -> Hoops In Giant Hoop-It-All™" menu). You can turn them both 
on/off at once using the "Ctrl + Ins" key combination. 
 
Both sides of the hoop work like a magnet. If you turn off some side, it stops "attracting" designs unless you 
turn it on again. This way you can prepare designs side-after-side, starting e.g. with right side and ending 
with left side. All designs belonging to some side will be drawn in that side's color (i.e. fuchsia or white), but 
only when the side is off. This way you can check to which side does the particular object belong - turn both 
sides off (by depressing "Ctrl + Ins" keys simultaneously) and you will see.  

Picture No. 3  

   

5 - Let's start with the right side of the hoop. Turn the left side off using commands in "View -> Hoops In 
Giant Hoop-It-All™ -> Left" menu. You can see in work area that only the right side of the hoop is ON now 
(Picture No. 4).  

Picture No. 4 
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6 - Merge the designs into the work area. Use "File -> Merge" menu to merge a file (Picture No. 5). For more 
information on merging files, please read the Open Designs for Giant-L Hoop-It-All™ tutorial.  

Picture No. 5 

  

7 - Move the design to the right side of the hoop (Picture No. 6).  

Picture No. 6 
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8 - As you can see in Picture No. 6 above, the design exceeds the size of child hoop (which represents the 
maximum design size that the embroidery machine is capable of sewing out). The design must be manually 
split in such a way that each part of the design would fit into one of the five overlapping child hoops (Picture 
No. 7). More information regarding the splitting is available in Interactive Free-Hand Splitting tutorial.  

Picture No. 7 

  

9 -  Repeat the splitting process until every object fits into one of the five child hoops (Picture No. 8). 
Sometimes it might be necessary to change the order of objects. Drag and drop objects at Objects Order Bar, 
so that their order is correct (Picture No. 8).  

Picture No. 8 
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10 - When you are finished with the splitting, turn off the right side of the hoop (by depressing "Ctrl + Right" 
keys simultaneously). All objects belonging to the right side should be drawn in fuchsia color now (Picture No. 
9). In case some objects are not drawn in this color yet, it means that they do not fit into child hoop and you 
must split them again (press "Ctrl + Right" keys simultaneously to turn on the right side of the hoop and then 
repeat the step 8).  

Picture No. 9 

  

11 - Turn on the left side of the hoop and repeat the steps 6 to 10. 
12 - When you are finished with both sides of the Giant-L Hoop-It-All™ hoop, click "File -> Save As" menu to 
save the all design parts to files on your disk. Specify the format and the file name in the dialog boxes which 
appear on the screen. Each design part will be saved into a separate file on the disk.  

Note: Embird will automatically append two characters to the file name of each part (Picture No. 11). These 
characters indicate the hoop section which belongs to the part, e.g. www_RE.hus means that the part should 
be sewn out at the "Right" side in "E" section. This is very helpful during sewing, or if you want to re-open 
these files in Editor - see also the Open Designs for Giant-L Hoop-It-All™ tutorial.  

Picture No. 10 
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Save Janome GigaHoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design, which you want to save for Janome GigaHoop. To open a design, click "File" menu and 
choose "Open" command. Please note, that you probably will have to split this design into two parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Choose "Janome GigaHoop - Horizontal" or "Janome GigaHoop -Vertical" option (Picture No. 2). Typical 
position is horizontal, with two overlapping hoops. The vertical position works the same way as the horizontal 
does, but the parts are automatically rotated by +90 degrees when loading/saving from/to hard disk.  

Picture No. 2  
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5 - You can see now, that the design exceeds size of one of the two overlapping hoops (red, blue), which 
create the Janome GigaHoop. Therefore the design must be split into two parts (Picture No. 3). Use 
"Freehand Select Mode" button to select the stitches you want to cut out (separate). More information 
regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(or select the "Edit -> Split" menu) to split the design, this will separate the red selection (Picture No. 4).  

Picture No. 4 
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7 - You can see design parts (part1 and part2) in the "Object Order Bar" at the right side of the screen 
(Picture No. 5). Each part now lies completely either in the left or in the right hoop.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Janome .JEF format. In the second dialog box that appears on the screen you can 
choose the file name of the design being saved. Each part will be stored in a separate file, and Embird will 
automatically add the "_1" or "_2" extension to the name you specify. This extension indicates the position in 
GigaHoop. Position no. 1 is the right hoop, position no. 2 is the left hoop. 
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Save Janome Macro Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the design, which you want to save for Janome Macro Hoop. To open a design, click "File" menu 
and choose "Open" command. Please note, that you probably will have to split this design into two parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Choose "Janome MC11000 Macro Hoop - Vertical" or "Janome MC11000 Macro Hoop - Horizontal" option 
(Picture No. 2). Typical position is vertical, with two overlapping sections. The horizontal position works the 
same way as the vertical does, but the parts are automatically rotated by +90 degrees when loading/saving 
from/to hard disk.  

Picture No. 2  
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5 - You can see now, that the design exceeds the size of one of the two overlapping sections (red, blue), 
which create the Janome Macro Hoop. Therefore the design must be split into two parts (Picture No. 3). Use 
"Freehand Select Mode" button to select the stitches you want to cut out (separate). More information 
regarding splitting is available in Interactive Freehand Splitting tutorial.  

Picture No. 3 

 

6 - Use "Freehand Select Mode" (arrow 1 in Picture No. 4) to select stitches you want to cut out (separate). 
Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(arrow 2) to split design (to separate the red selection).  

Picture No. 4 
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7 - You can see design parts (1 and 2) in the "Object Order Bar" at the right side of the screen (Picture No. 
5). Each part now lies completely either in the top (red) or in the bottom (blue) section of Janome Macro 
Hoop.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Janome .JEF format (recommended) or .JEF+ format (in such a case you will have to 
switch off and on your embroidery machine, otherwise the new JEF+ files stored on the USB stick are not 
recognized by machine). In the second dialog box that appears on the screen you can choose the file name of 
the design being saved. 
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Save Janome #5 Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design, which you want to save for Janome #5 Hoop. To open a design, click "File" menu and 
choose "Open" command. Please note, that you probably will have to split this design into several parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Choose "Janome #5 - Vertical" or "Janome #5 - Horizontal" option (Picture No. 2). Typical position is 
vertical, with eleven overlapping sections. The horizontal position works the same way as the vertical does, 
but the parts are automatically rotated by -90 degrees when loading/saving from/to hard disk.  

Picture No. 2  
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5 - You can see now, that the design exceeds the size of some of eleven overlapping sections (red, green, 
blue, yellow, ...), which create the Janome #5 Hoop (Picture No. 3). Therefore the design must be split into 
several parts. Use "Freehand Select Mode" button to select the stitches you want to cut out (separate). More 
information regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Use "Freehand Select Mode" to select stitches you want to cut out (separate). Once you have selected the 
area you want to separate, it will be displayed in red color (Picture No. 4). Click "Split" button (or select the 
"Edit -> Split" menu) to split design (to separate the red selection).  

Picture No. 4 
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7 - You can see design parts (1 and 2) in the "Object Order Bar" at the right side of the screen (Picture No. 
5). Each part now lies completely in one of the eleven hoop sections - the part no. 1 fits the top hoop section, 
and the part no. 2 fits the bottom (green) hoop section of Janome #5 Hoop.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Janome .SEW format. In the second dialog box that appears on the screen you can 
choose the file name of the design being saved. Each part will be stored in a separate file, and Embird will 
automatically add the extension from "_1" to "_11" to the name you specify. This extension indicates the 
position in Janome #5 Hoop. Position no. 1 is the top hoop, position no. 11 is the bottom hoop. 



 274 

Save Pfaff Grand Dream Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the design, which you want to save for Pfaff Grand Dream Hoop. To open a design, click "File" menu 
and choose "Open" command. Please note, that you probably will have to split this design into two parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Choose "Pfaff Grand Dream Hoop - Vertical" or "Pfaff Grand Dream Hoop - Horizontal" option (Picture No. 
2). Typical position is vertical, with two overlapping sections. The horizontal position works the same way as 
the vertical does, just the parts are automatically rotated by -90 degrees when loading/saving from/to the 
hard disk. Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  
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5 - You can see now, that the design exceeds the size of one of the two overlapping sections (red, green), 
which create the Pfaff Grand Dream Hoop. Therefore the design must be split into two parts (Picture No. 3). 
Use "Freehand Select Mode" button to select the stitches you want to cut out (separate). More information 
regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(or select the "Edit -> Split" menu) to split the design, this will separate the red selection (Picture No. 4).  

Picture No. 4 
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7 - You can see design parts (1 and 2) in the "Object Order Bar" at the right side of the screen 
(Picture No. 5). Each part now lies completely either in the left (red) or in the right (green) section of Pfaff 
Grand Dream Hoop.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Pfaff .VIP or .VP3 format. In the second dialog box that appears on the screen you can 
choose the file name of the design being saved. Each part will be stored in a separate file, and Embird will 
automatically add the "a" or "b" extension to the name you specify. This extension indicates the position in 
Pfaff Grand Dream Hoop. Position "a" is the right hoop section, position "b" is the left hoop section. 
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Save Pfaff Grand Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Open the design, which you want to save for Pfaff Grand Hoop. To open a design, click "File" menu and 
choose "Open" command. Please note, that you probably will have to split this design into two parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

 

4 - Choose "Pfaff Grand Hoop - Horizontal" or "Pfaff Grand Hoop - Vertical" option (Picture No. 2). Typical 
position is horizontal, with two overlapping sections. The vertical position works the same way as the 
horizontal does, just the parts are automatically rotated by -90 degrees when loading/saving from/to the hard 
disk. Confirm the hoop selection by clicking "OK" button.  

Picture No. 2  

 



 278 

5 - You can see now, that the design exceeds the size of one of the two overlapping sections (red, green), 
which create the Pfaff Grand Hoop. Therefore the design must be split into two parts (Picture No. 3). Use 
"Freehand Select Mode" button to select the stitches you want to cut out (separate). More information 
regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(or select the "Edit -> Split" menu) to split the design, this will separate the red selection (Picture No. 4).  

Picture No. 4 
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7 - You can see design parts (1 and 2) in the "Object Order Bar" at the right side of the screen (Picture No. 
5). Each part now lies completely either in the left (red) or in the right (green) section of Pfaff Grand Hoop.  

Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Pfaff .VIP or .VP3 format. In the second dialog box that appears on the screen you can 
choose the file name of the design being saved. Each part will be stored in a separate file, and Embird will 
automatically add the "a" or "b" extension to the name you specify. This extension indicates the position in 
Pfaff Grand Hoop. Position "a" is the right hoop section, position "b" is the left hoop section. 
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Save Pfaff Multi-Hoop Design 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Open the design, which you want to save for Pfaff Multi-Hoop. To open a design, click "File" menu and 
choose "Open" command. Please note, that you probably will have to split this design into three parts.  
3 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu (Picture No. 1).  

Picture No. 1  

   

4 - Choose "Pfaff Multi-Hoop - Horizontal" or "Pfaff Multi-Hoop - Vertical" option (Picture No. 2). Typical 
position is horizontal, with three overlapping sections. The vertical position works the same way as the 
horizontal does, but the parts are automatically rotated by -90 degrees when loading/saving from/to hard 
disk.  

Picture No. 2  
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5 - You can see now, that the design exceeds size of one of the three overlapping hoop sections (red, green, 
blue), which create the Pfaff Multi-Hoop. Therefore the design must be split into two (or, in some cases, into 
three) parts (Picture No. 3). Use "Freehand Select Mode" button to select the stitches you want to cut out 
(separate). More information regarding splitting is available in Interactive Freehand Splitting tutorial. 

Picture No. 3 

 

6 - Once you have selected the area you want to separate, it will be displayed in red color. Click "Split" button 
(or select the "Edit -> Split" menu) to split the design, this will separate the red selection (Picture No. 4).  

Picture No. 4 

 

7 - You can see design parts (1, 2 and 3) in the "Object Order Bar" at the right side of the screen 
(Picture No. 5). Each part now lies completely either in the left (red), middle (green) or in the right (blue) 
hoop section.  
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Picture No. 5 

 

8 - Use "File -> Save As" command to save the whole design to a file on your disk. In the "Choose Format" 
dialog box choose the Pfaff .PCS format. In the second dialog box that appears on the screen you can choose 
the file name of the design being saved. Each part will be stored in a separate file, and Embird will 
automatically add the "_1",  "_2" or "_3" extension to the name you specify. This extension indicates the 
position in Pfaff Multi-Hoop. Position no. 1 is the left section, position no. 2 is the middle section and position 
no. 3 is the right section. 
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Save Singer Multi-Hoop Design 

This tutorial was written by Mrs. Elaine Bell. It explains have to split and save a large Multi-Hoop design for 
Singer embroidery machine. Before you start splitting the design in Embird, you must prepare the cross 
reference line either in PSW program, or in Embird.  

Preparing Cross Reference Line in PSW: 
 
1 - Click "New icon or Files -> New". At the Open menu, click "New". At the New menu, click "210x430mm". 
Click "OK". 
2 - Load the 210x430 Multi Hoop. 
3 - Click "Create -> Add multiple hoop cross" 
4 - A stop is automatically added at the beginning of the cross to give you the option of sewing it. The cross is 
a reference line used to align designs at the XL1000 layout screen. The cross is optional, but I find it 
invaluable in lining up designs. The cross is a basting stitch and is easily removed. The color stop is 
unnecessary in Embird, so to delete it - click the "Edit Outline icon" (or "Edit -> Edit Outline"). Press Home on 
the keyboard to go to the beginning of the cross, press the right arrow on the keyboard twice to move to the 
STOP. Press delete to remove the color stop. 
5 - Save the cross reference line as "crossref.xxx". 
 
Preparing Cross Reference Line in Embird: 
 
You can create the reference line easily also in Embird. In Editor, choose the "Options -> Hoop Size" 
command from the main menu and choose "Singer Multi-Hoop Horizontal" hoop option in the dialog box 
which appears on the screen. Then click "Insert -> Cross Reference Line" command in main menu. Finally, 
save the cross reference line to "crossref.xxx" by clicking "File -> Save As" command.  

Splitting and Saving Multi-Hoop Design: 
 
1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Click the "Hoop Size" button, or select the "Options -> Hoop Size" menu. Choose "Singer Multi-Hoop 
Horizontal" hoop option (Picture No. 1). Click "OK" button to confirm this selection. 

Picture No. 1 
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3 - Press "Ctrl+Page Down" keys on the keyboard (or use "View -> Zoom -> Out" menu) to zoom out the 
work are until hoop fits within screen. Picture No. 2 shows the darker blue lines that indicate the center of the 
Singer multi hoop. These lines correspond with the cross reference line created either in PSW or Embird (see 
the steps above). 

Picture No. 2  

 

4 - Select "File -> Merge" command to bring in files to be split. Files will be rotated automatically by -90 
degrees. You can repeat this step several times to bring in more designs. 
5 - Move, rotate and size designs as you please. When the designs are in desired arrangement, click " Edit -> 
Select All" command in the main menu and then click the "Edit -> Center -> Both Axes" menu to center the 
designs both horizontally and vertically. This step is optional. 
6 - Decide how the design will be split. Picture No. 3 shows the designs that will be split into three sections - 
1) elephant, 2) tree, 3) zebra and giraffe. 

Picture No. 3 

  

7 - Select "File -> Merge" command to merge the previously saved cross reference line. The cross is 
automatically centered and aligned with the darker grids in the multi hoop (Picture No. 4). 

Picture No. 4 
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8 - The "elephant" will be split first. 

Note: Hide colors of any design(s) that interfere with splits. In this example, only the "tree" interferes with 
splitting the left and right sections. 
 
a) From the Objects Order Bar (right side of screen), right click one of the colors in the tree. Choose "Hide All 
Colors" command from the popup menu which appears on the screen. This will hide the "tree" obect. 
b) Select "Mode -> Freehand Select Mode" command from the main menu. Left mouse click to draw a 
polygon around the "elephant" and the center of the cross (Picture No. 5). Double click when finished to close 
the polygon - the elephant will be selected and drawn in red color. Click "Edit -> Split" command in the main 
menu. 
c) Use "File -> Save Selected As" command from main menu to save the selected object  - elephant with 
portion of the cross reference line. In the dialog boxes which appear on the screen choose "Compucon .XXX" 
format and save the stitches to "AnimLeft.xxx" file on your hard disk. 
d) Click the "Edit -> Undo" command in the main menu. Since a portion of the cross reference line was 
included in the split, we will need to undo this action so the entire line will be available for future splits. 

Picture No. 5 

  

9 - Split the "giraffe" and "zebra":  
 
a) With "tree" still hidden, click "Mode -> Freehand Select Mode" and left click around the "giraffe" and 
"zebra" and the center of the cross reference line (Picture No. 6). Click "Edit -> Split" command in the main 
menu. 
b) Use "File -> Save Selected As" command from main menu to save the selected object  - giraffe and zebra 
with portion of the cross reference line. In the dialog boxes which appear on the screen choose "Compucon 
.XXX" format and save the stitches to "AnimRt.xxx" file on your hard disk. 
c) Click the "Edit -> Undo" command in the main menu. Since a portion of the cross reference line was 
included in the split, we will need to undo this action so the entire line will be available for future splits. 

Picture No. 6 
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10 - Split the "tree": 

a) From the Objects Order Bar, right click one of the colors in the tree and choose "Show All Colors" from the 
popup menu which appears on the screen. 
b) For this exercise, the height of the tree should fit within the 130 mm width of the large hoop. Since the 
tree is 126 mm tall, only 4 mm of the vertical cross can be included before we're at the 130 mm limit. Zoom 
in (using "Ctrl+Page Up" keys or "View -> Zoom -> In" menu) so the tree will fill the screen. 
c) Click "Mode -> Freehand Select Mode" and draw line around the tree, getting as close as you can at the 
top and bottom so you won't pick up more than 4 mm of the cross reference line (Picture No. 7). Click "Edit -
> Split" command in the main menu. 
d) Use "File -> Save Selected As" command from main menu to save the selected object  - tree with portion 
of the cross reference line. In the dialog boxes which appear on the screen choose "Compucon .XXX" format 
and save the stitches to "AnimCtr.xxx" file on your hard disk. 
 
Note 1:  A quick method to select several designs, left click first design, then while holding down the Shift 
key, left mouse click on another design to add to your selection. You can click a design within the design 
screen or click a design icon on the "Objects Order Bar" (right side of the screen). 
 
Note 2:  After a design has been selected and split, the bottom of the screen will show size, stitch count and 
color count of the selection. 
 
Note 3:  When you "Save Selected As", Editor will display an error message if the design is too large or 
exceeds the color and stitch count limitations. 
 
Note 4:  When you save the parts to .XXX format, they will be rotated back by 90 degrees. 

Picture No. 7 

  

Writing Designs to Card in PSW: 
 
Open each split design in PSW (1.1 users do not convert stitches to block). Write designs to card. 
 
Sewing Designs using Singer XL1000: 
 
1 - At the XL1000 embroidery screen, select Multiple Hoop Embroidery. 
2 - Load each multi hoop design into the embroidery machine.  
3 - Use "Zoom" and Edit/Position to align the multi hoop cross from each design with the X/Y axis on the 
XL1000 layout screen. 
 
For detailed instructions on loading multi hoop designs in the XL1000, please read the XL1000 manual. 
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Search Files 

1 - Run Embird, it will start in "Manager" mode. 
2 - Select the folder in "Folder:" box at right panel (Picture No. 1). Embird will search for files in this folder 
and in all its subfolders. In this example, we have chosen the "C:\EMBIRD32\FILES" folder. In case you are 
using Embird 2006 or later, you will find some free designs in "C:\Program Files\EMBIRD32\FILES" folder.  

Picture No. 1 

   

3 - Select "Right Panel -> Folder Operations -> Search" menu (Picture No. 2).  

Picture No. 2 

   

4 - A dialog box will appear on screen, allowing you to specify the filter for searching files (Picture No. 3). In 
this example, we want to search for file with any name and with any extension. You can specify different 
search criteria, e.g. "squirrel.*" if you want to search only for designs with filename squirrel and any 
extension, or you can specify e.g. "*.dst" if you want to search for designs with any name, but with .dst 
extension. Click "OK" button to continue.  
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Picture No. 3 

   

5 - Another dialog box will appear on screen, allowing you to specify additional search criteria (Picture No. 4). 
In this example we want to find a design containing "car" in keywords (see also File Summary Info tutorial). 
These boxes might be left blank in case no additional criteria are required. Click "OK" button to continue.  

Picture No. 4 

   

6 - Embird will search in chosen folder and all its subfolders for the designs matching the search criteria. Once 
the search process is finished, the results are displayed as thumbnails (Picture No. 5).  

Picture No. 5 
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Select Marked Files 

If you are displaying designs or images from Right Panel as "Thumbnails" or as "Dense Thumbnails", there is 
a check box shown at the left side of each thumbnail in its yellow area. Use this check box to mark some of 
the files while browsing through your designs or images, and then use "Select Marked Files" command in 
"Right Panel" menu to select the marked files in Right Panel. Finally, use e.g. "Delete Files" command from 
"Right Panel" menu to delete the selected (marked) files from your hard disk, or use any other command 
applicable for selected files (e.g. "Cut Files to Clipboard" and paste them into some other folder). This new 
mark feature allows you to sort designs easily. 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Select the designs which you want to view as "Thumbnails" or "Dense Thumbnails" (Picture No. 1). To 
select multiple files, please move mouse pointer to the file name of the first design in the "Files:" box at the 
right side of the screen, depress the left mouse button and hold it down while moving the mouse pointer over 
the file names of the other designs. When the mouse pointer is over the last design, please release the left 
mouse button.  

Picture No. 1  

 

3 - Select "Right Panel -> View Thumbnails" command from the main menu (Picture No. 2). Notice the empty 
check boxes in the yellow area of each design.  

Picture No. 2  
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4 - Click the boxes to set them ON, i.e. to mark the files which you want to process, e.g. delete 
(Picture No. 3). In this example, we have marked the following files: "EmbroideryDst.DST", "EVA.DST", 
"PART1.DST" and "PORSCHE1.DST". 
5 - Click "Down" button (located below the shown designs) if you want to mark designs also on the next 
page. 

Picture No. 3 

 

6 -  In this example, we marked also another two files: "SQUIRREL.DST" and "VERONIK2.DST" 
(Picture No. 4).  

Picture No. 4 

 

7 - If you have marked all the files you want to handle (e.g. delete), run "Right Panel -> Select Marked Files" 
command from the main menu (Picture No. 5).  
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Picture No. 5 

 

8 - Marked files will be selected in the "Files:" box in right panel (Picture No. 6). Now you can run "Right 
Panel -> Delete Files" command from the main menu to delete these files.  

Picture No. 6 

 

Note: The check box for marking files is also available in Viewer window (Picture No. 7). You can set this 
check box to ON while you are browsing through your designs or images in Viewer window, and then you can 
close this window and follow steps 7 and 8 to handle the marked files.  

Picture No. 7 
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Set Envelope 

This tutorial explains how to use the Set Envelope command in Editor. This command allows you to change 
the envelope of selected objects. For example, you can create the "bridge" effect on a ready-made lettering 
design which you have downloaded from Internet.   

Note: If you create a new lettering in Embird, it is the best to create the envelope effect at the same time as 
you create the lettering - please see tutorial Lettering 3 (Envelope). The "Set Envelope" command is based on 
automatic outline recognition algorithm, which recognizes outlines from the stitches in finished design, and it 
will not always give you ideal results. This is similar to resizing with density adjustment.  

Follow these steps:  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the design which you want to edit (Picture No. 1).  

Picture No. 1  

 

3 - Select objects envelope of which you want to change (e.g. by running "Edit -> Select All" command). 
4 - Click "Edit -> Set Envelope" menu (Picture No. 2).  

Picture No. 2  
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5 - The "Set Envelope" dialog box will appear on the screen, and the design is displayed on its "Layout" tab 
(Picture No. 3). You can change the "baseline" in the box below the Layout area. You can "place the text on 
the other side" of baseline, create bridge effect by choosing an "Envelope" style, etc. There are several color 
points shown on the layout area, allowing you the following:. 
 
A. Use red points to move the object along the baseline. 
Depress CTRL key to move only selected object; otherwise, all objects placed after selected object will move. 
 
B. Use green points to rotate the object. 
Depress CTRL key to change the angle by 15 degrees. 
Depress ALT key to set the angle to 0 degrees. 
 
C. Use teal points to resize the object, either horizontally or vertically. 
Depress CTRL key to change the size in larger steps. 
Depress ALT key to maintain the aspect ratio of width and height. 
 
D. Use purple points to skew or mirror the object, either horizontally or  vertically. 
Depress CTRL key to skew in larger steps. 
Depress ALT key to mirror the selected letter. 
 
Depress SHIFT key while moving the point to apply the operation to all objects.  
 
Please note that undo/redo/reset operations are available for changes in Layout; use the buttons located 
below layout area. 

Picture No. 3 

 

6 - In this example, we have chosen one of the pre-defined envelopes (Picture No. 4).  

Picture No. 4 

 



 294 

7 - After selecting "OK" button the modified design is inserted into Editor (Picture No. 5). Compare this text 
with the one shown above in Picture No. 1.  

Picture No. 5 

 

8 - When you are finished with editing, select "File -> Save" menu to save the changes to the file on your 
disk. 
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Sew Simulator 

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "File -> Open" menu to open a design. 
3 - Click on "Sew Simulator" button (Picture No. 1), or select "View -> Sew Simulator" menu.  

Picture No. 1  

 

4 - Sew Simulator window will appear on the screen (Picture No. 2). Simulation of sewing can be started by 
pressing "Play" button (1). When the simulation starts, the "Play" button will be replaced by "Pause" button. 
The current stitch will be drawn in red color. Simulation can be paused by pressing "Pause" button (1), 
resumed by pressing "Play" button again (1), rewound by pressing "Rewind" button (2) and forwarded by 
"Forward" button (3). Simulation can be finished by clicking "Finish" button (4). Click "Close" button (5) to 
return to "Editor".  

Other Controls: 
 

Switches (6), (7), (8) and (9) allow to pause the simulation process on occurrence of the 
next running stitch, jump stitch, stop (color change) or trim, respectively. 
 

If you pause the simulation, you can use the "Locate" button (11) to locate the current stitch in complex 
design.  
 

If you decide to split the design on current stitch, use "Split" button (12).  
 

In case the design does not fit the hoop, use "Hoop Size" button (10) to change the hoop size. 
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Speed of the simulation can be controlled by "Stitches per second" box (13).  
 
Stitch process bar (14) shows the colors of design and simulation progress. The blue lines above the bar 
represent jump stitches, the magenta lines below the bar represent trims. You can click anywhere across the 
bar to move the pointer (current stitch) to this place.   

Picture No. 2  
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Interactive Free-Hand Splitting 

This tutorial explains how to split a design using the free-hand selection of object area.  

Note: Other ways of splitting are explained in the following tutorials: Split Before/After Color, Separate Color, 
Using Initial and Ending Stitch Boxes, Auto-Split, Auto-Split Along Hoop Boundaries and Saving and Sewing of 
Split Designs.  

1 - Run Embird. 
2 - Click "Editor" menu to switch to Editor window. 
3 - Select "File -> Open" menu to open the file, which will be split into two parts.  
4 - Click "Freehand Select Mode" icon to choose the freehand select mode (Picture No. 1).  

Picture No. 1  

 

5 - Select the area which you want to separate (cut out). Move mouse pointer to Work Area and click left 
mouse button to place the starting point of the selection (Picture No. 2).  Move mouse pointer to another 
position on Work Area and click left mouse button to place the second point of the selection, and repeat this 
procedure until you create a boundary around the whole part, which you want to separate. Finally, double 
click the left mouse button to close the boundary. The stitches lying inside the boundary are selected and 
drawn as red (Picture No. 3).  

Picture No. 2  
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6 - Click "Split" button located in the toolbar at the top of the screen to separate the red selection (Picture No. 
3). 

Picture No. 3 

 

7 - Now you can see that the design was split into 2 parts. Some designs might be split also to 3 parts, 
depending on what part you decide to separate. To save the separated part into a file on your hard disk, or to 
move it over the Work Area, click the left mouse button on the part to select it. A black frame is drawn 
around the design when it is selected. (Picture No. 4).  

Picture No. 4 

 

8 - Click "File -> Save Selected As" menu to save the selected part (Picture No. 5)  

Picture No. 5 
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9 - Choose the target file format in the dialog box which appears on the screen (Picture No. 6). Click "OK" 
button to continue.  

Picture No. 6 

 

10 - Choose the drive, folder and file name of the design being saved (Picture No. 7). Click "Save" button to 
continue.  

Picture No. 7 
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11 - To save the second part of the design, select it first and then repeat the steps 7 to 10. 
12 - When you have successfully saved all parts, you can open some of these parts to check it. Click "File -> 
Open -> Cocker2 - part1"  
13 - Embird will ask you whether you want to save the changes in the original design (in the design you have 
opened in step 3 and split). If you don't want to overwrite the original embroidery, click "No" button in 
"Confirm" dialog box which appears on the screen  (Picture No. 8). 

Picture No. 8 

 

14 - The part which was selected in step 12 is open and appears on Work Area. (Picture No. 9). 

Picture No. 9 

 

15 - When finished, use "File -> Exit" menu to exit Editor. 
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Split Before/After Color, Separate Color 

This tutorial explains how to split a design into two parts using function "split before color" or "split after 
color" and how to split a design into three parts using function "separate color".   

Note: Other ways of splitting are explained in the following tutorials: Interactive Free-Hand Splitting, Using 
Initial and Ending Stitch Boxes, Auto-Split, Auto-Split Along Hoop Boundaries and Saving and Sewing of Split 
Designs.  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the design which you want to split.  
3 - Choose the color before which you want to split the design. Move mouse pointer to the box containing 
this color in the "Objects Order Bar" at the right side of the screen (Picture No. 1). After a short while, the 
yellow box with hint will appear on the screen.  

Picture No. 1  

 

4 - Click right mouse button for popup menu and select "Split Before Color" command from this menu (Picture 
No. 2). Embird will split the design before chosen color (i.e. before color 6 in this example) and after a while 
you will see that there are 2 objects at the right side of the screen ("the dog" and "the blue barrier").   

Picture No. 2  
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5 - To save separated object into file on your hard disk, or to move it in Work Area, click left mouse button on 
this object in Work Area (Picture No. 3). The black rectangle will be drawn around the object, which indicates 
that this object is now selected. 

Picture No. 3 

 

6 - Click "File -> Save Selected As" menu to save the selected object to a file on your hard disk (Picture No. 
4).  

Picture No. 4 

 

7 - Specify the format in the dialog box which appears on the screen (Picture No. 5). Check the manual of 
your embroidery machine to find out which format is accepted by your machine. Click "OK" button to 
continue.  
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Picture No. 5 

 

8 - Choose folder and the name of file into which the stitches of selected object will be saved. Click "Save" 
button to continue (Picture No. 6).  

Picture No. 6 

  

9 - Repeat steps 5 to 8 if you want to save also the second part of the design to a file on your hard disk. 
 
10 - Command "Split After Color" will split the design after the chosen color. Choose the color, after which 
you want to split the design. Move mouse pointer to the box containing this color in the "Objects Order Bar" 
at the right side of the screen (Picture No. 7). After a short while, the yellow box with hint will appear on the 
screen. 
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Picture No. 7 

 

11 - Click right mouse button for popup menu and select "Split After Color" command from this menu (Picture 
No. 8).  

Picture No. 8 

 

12 - Embird will split the design after chosen color (i.e. after color 5 in this example) and after a while you will 
see that there are 2 objects at the right side of the screen ("the dog" and "the blue barrier"). Each part is now 
independent object, and it can be selected, moved or saved separately (Picture No. 9), as explained in steps 5 
~ 8. 
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Picture No. 9 

 

13 - The "Separate Color" command will split the design into three parts. Choose the color which you want to 
separate. Move mouse pointer to the box containing this color in the "Objects Order Bar" at the right side of 
the screen (Picture No. 10). After a short while, the yellow box with hint will appear on the screen. 

Picture No. 10 

 

14 - Click right mouse button for popup menu and select "Separate Color" command from this menu 
(Picture No. 11).  
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Picture No. 11 

 

15 - Embird will split the design into 3 parts (Picture No. 12): The first part contains all colors which are 
stored in original design before the chosen color (i.e. color 1 ~ 5 in this example), the second part is the 
chosen color (color 6), and the third part contains all colors which are stored in original design after the 
chosen color (colors 7 and 8). Each part is now independent object, and it can be selected, moved or saved 
separately, as explained in steps 5 ~ 8. 

Picture No. 12 
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Splitting - Using Initial and Ending Stitch Boxes 

This tutorial explains how to split a design using the initial and ending stitch boxes. The Initial Stitch and 
Ending Stitch boxes are located on the Main Toolbar at the top of Editor window. They allow to specify the 
first stitch number and the last stitch number of selection. This selection can be then separated from the main 
object. 
 
Note: Other ways of splitting are explained in the following tutorials: Interactive Free-Hand Splitting, Split 
Before/After Color, Separate Color, Auto-Split, Auto-Split Along Hoop Boundaries and Saving and Sewing of 
Split Designs  

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the design which you want to split.  
3 - In this example we want to split the design below into two parts: dog and barrier. The barrier has colors 
different from dog colors. Set "Initial Stitch" to 1. To find the last stitch of the dog (being the same as initial 
stitch of the barrier), click several times on "To Next Color" button, which is located to the right of "Ending 
Stitch" box. Selected part of embroidery, i.e. stitches 1 to 6667 are drawn in red color (Picture No. 1).  

Picture No. 1  

 

4 - Once the stitches are selected, click the "Split" button (or "Edit -> Split" menu) to separate the red 
selection into an individual object (Picture No. 2).  

Picture No. 2  
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5 - Now there are two independent objects in work area - dog and barrier - as you can see them on the 
Objects Order Bar at the right side of the screen (Picture No. 3). To save the first object (dog) into a file click 
the left mouse button on this part. This will select the object.  
6 - Use "File -> Save Selected As" command to save selected object to a file on your disk. Specify the format 
and the file name of the new design in the dialog boxes which appear on the screen.  

Picture No. 3 

 

7 - Click left mouse button on the barrier object to select it.  
8 - Use "File -> Save Selected As" command to save this object to a file on your disk. Specify the format and 
the file name of the new design in the dialog boxes which appear on the screen. 
9 - When finished, use "File -> Exit" menu to exit Editor. 
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Splitting - Saving and Sewing of Split Designs 

This tutorial explains how to save the parts of split design. It also shows how to create the template, which 
you will use for aligning the parts when sewing out on the embroidery machine. To find out how to split a 
design, please read the following tutorials: Interactive Free-Hand Splitting, Auto-Split, Auto-Split Along Hoop 
Boundaries, Split Before/After Color, Separate Color and Using Initial and Ending Stitch Boxes. 
 
Once the splitting is completed, please follow these steps to save the design parts:  

1 - In this example, we applied "Edit -> Auto-Split" command to SUNFLOWER design. The design was 
automatically split into four parts, and every part now fits into standard 100 x 100 mm hoop (Picture No. 1).  

Picture No. 1  

 

2 - Select "File -> Save Separated As" menu to save all four parts separately; i.e. to save each part into its 
own file on the hard disk (Picture No. 2).  

Picture No. 2  
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3 - A dialog box will appear on the screen, allowing you to choose the format for saving. Please note, that the 
"Center in Hoop" option is ON (Picture No. 3). This means that every part will be automatically centered in 
hoop. Choose the format you need for your embroidery machine and then select "OK". 

Picture No. 3 

 

4 - Another dialog box will appear on the screen, allowing you to choose the name of design file. In this 
example, Embird will offer us SUNFLOWR_1 name for part 1, SUNFLOWR_2 for part 2, etc. (Picture No. 4). 
Select "Save" to save this part. This step will be repeated for the rest 3 parts.  

Picture No. 4 

 

5 - Select "File -> Print Template" menu to print the template (Picture No. 5). There will be 4 crosses in the 
template, showing you the starting position of needle for parts 1, 2, 3 and 4. Use this template and the 
crosses to align the parts when sewing out on your embroidery machine.  
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Picture No. 5 
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Stitch List 

1 - Run Embird and click "Editor" menu to switch to Editor window.  
2 - Select "File -> Open" menu to open the design which you want to edit (Picture No. 1).  

Picture No. 1  

   

3 - Switch ON the "Stitch List" in "View" menu in case it is unchecked (Picture No. 2).  

Picture No. 2  

   

4 - The stitch list appears in the "Objects Order Bar" at the right side of the screen (Picture No. 3). It 
displays the list of stitches contained in the selected object: stitches, trims, stops and jumps. 
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Picture No. 3 

   

5 - Click the item in the stitch list to select the stitches in the design (Picture No. 4). Selected stitches are 
drawn in red color on the Work Area. 
 
Tip 1: Double-click the item in the stitch list if you want to hide all the other parts of the object, and have 
only the red selection visible on the Work Area. 
 
Tip 2: Press "arrow up"/"arrow down" keys on the keyboard if you want to move to upper/lower item of the 
same type in the stitch list. In this example, the selected item is "Stitches 4" (Picture No. 4), so if you press 
the "arrow up" key on the keyboard, the "Stitches 3" item becomes selected.  

Picture No. 4 
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6 - Click right mouse button on the stitch list item for popup menu (Picture No. 5). Use the commands in the 
popup menu to delete the selected item, split design before/after the selected item, insert/remove stop code 
or trimming code, etc.   

Picture No. 5 

   

7 - When you are finished with editing, select "File -> Save" menu to save the changes to the file on your 
disk. 
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Text Arching 

In this tutorial you will find out how to arch the text created using Alphabets or Font Engine plug-in:  

1 - Run Embird and click "Editor" menu to switch to Editor window. 
2 - Select "Insert -> Font Engine Text" menu (Picture No. 1).  

Picture No. 1  

 

3 - Font Engine dialog box will appear on the screen (Picture No. 2). In the "Fonts" box you can choose the 
font which will be used for characters. After choosing the font, you can type your text into the "Text" box at 
the bottom of the "Insert" tab.  

Picture No. 2  
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4 - Click the "Properties" tab to change the size, fill type, outline type, and other properties of lettering 
(Picture No. 3). If you want to change more fill and outline parameters, click "Parameters" button. 

Picture No. 3 

 

5 - Click "Layout" tab to change the layout parameters of the lettering. After choosing the "Layout" tab, 
change the baseline type in the "Baseline" box from "Line" to "Circle". The lettering is placed at the left side 
of the circle (Picture No. 4).  

Picture No. 4 

 

6 - Uncheck the "Keep Ratio" box to change the baseline shape from circle to ellipse. Then you can set the 
"Width" and "Height" of the ellipse. Use the "Start point" scroll bar to move the text along the ellipse 
boundary (Picture No. 5).  
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Picture No. 5 

  

7 - If you want to place the text to the other side of ellipse click the "Place on the other side" box (Picture No. 
6).   

Picture No. 6 

  

8 - Use the "Start point" scroll bar again to move the text to its final position (Picture No. 7).  
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Picture No. 7 

  

9 - Use the "arrow" buttons in the red frame to expand the gaps between the characters (Picture No. 8).   

Picture No. 8 

  

10 - Finally, click "OK" button to create the lettering and insert it into Editor window (Picture No. 9).  
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Picture No. 9 

 

 

11 - Use "File -> Save As" command to save the whole design to a file on your disk. Specify the format and 
the file name of the new design in the dialog boxes which appear on the screen. 
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Thread Catalogs 

1 - Run "Embird", it will start in "Manager" mode. 
2 - Use "Drive", "Folder" and "Files" boxes located on the Right Panel at the right side of the screen and 
choose the folder with embroidery designs, e.g. "C:\EMBIRD32\FILES" folder in this example. In case you are 
using Embird 2006 or later, you will find some free designs in "C:\Program Files\EMBIRD32\FILES" folder. 
3 - Click the left mouse button on file name of the design which you want to display (arrow 1 in Picture No. 
1). After selecting your design, click the left mouse button on the "View File" button (arrow 2 in Picture No. 
1). Design will be displayed on the middle panel. Below this area there is a bar which contains boxes with 
design colors. 

Choosing Color from Thread Catalogs 

4 - Move mouse pointer to the box containing the color which you want to change and click the right mouse 
button (arrow 3 in Picture No. 1). 

Picture No. 1  

 

5 - Select "Choose Color from Catalog" command from the popup menu which appears on the screen (Picture 
No. 2).  

Picture No. 2  
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6 - You can choose the new color in the thread catalog which appears on the screen. In this example, we 
have chosen the thread no. 1171 from "Madeira Rayon" catalog (Picture No. 3). Click "OK" button to confirm 
the color selection. 

Picture No. 3 

 

7 - After choosing the new color, click "Apply Color Changes" button which appears below color boxes 
(Picture No. 4). The design will be displayed with the new color. 

Picture No. 4 

 

8 - Now you should see the difference between the design displayed with previous color and the new color. 
Compare pictures 1 and 5, the green color of tiger's eyes has been changed to the yellow one. 
9 - Repeat the steps 4 to 7 if you want to change other design colors or the color of the background.  
10 - The color changes are not permanent unless you save the new color palette. If you want to discard the 
color changes and restore previous colors, click "Restore Color Palette" button (arrow 2 in Picture No. 5).  
11 - Click "Save Color Palette" button if you want to save the new color palette (arrow 1 in Picture no. 5).  



 322 

Picture No. 5 

 

 

Searching for Color in Thread Catalogs 

12 - Move mouse pointer to the box containing the color which you want to change and click the right mouse 
button. 
13 - Select "Find Color in Catalog" command from the popup menu which appears on the screen 
(Picture No. 6).  

Picture No. 6 

 

14 -The dialog box will appear on the screen, containing the results of the search. Click "Cancel" button to 
close this box, or choose the new color and click "Choose selected color" button (Picture No. 7).  
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Picture No. 7 

 

15 - After choosing the new color, click "Apply Color Changes" button which appears below color boxes 
(Picture No. 8). The design will be displayed with the new color. 

Picture No. 8 

 

16 - Now you should see the difference between the design displayed with previous color and the new color. 
Compare pictures 1 and 9, the green color of tiger's eyes has been changed to the yellow one. 
17 - Repeat steps 12 to 15 if you want to change other design colors or the color of the background.  
18 - The color changes are not permanent unless you save the new color palette. If you want to discard the 
color changes and restore previous colors, click "Restore Color Palette" button (arrow 2 in Picture No. 9).  
19 - Click "Save Color Palette" button if you want to save the new color palette (arrow 1 in Picture No. 9).  
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Picture No. 9 
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Ultimate Box - Reading Designs from Card 

The Ultimate Box is a read/write device that transfers embroidery designs from the hard drive of your 
computer to a re-writable blank embroidery card that fits your Brother, Babylock, Bernina Deco, Simplicity, 
White and Viking/Husqvarna embroidery machines. The 2-slot Ultimate Box also supports the cards for Pfaff 
and Bernina Artista embroidery machines. The Ultimate Box writes up to 230.000 stitches to the 
Amazing/Magic and Brother 512 Kilobyte (4 Megabit) blank cards. The Ultimate Box writes over 450.000 
stitches to the Ultimate Card. It reads and saves designs back to the hard drive of your computer from the 
above cards and most pre-programmed design cards (except licensed design cards). The box connects with a 
cable to the USB port of your computer. More information about Ultimate Box available at 
http://www.vikant.net. 
 
Note: Ultimate Box is developed by Vikant Corporation. Vikant Corporation is not affiliated with any 
manufacturers mentioned here. All brand names and product names are trademarks and service marks of the 
respective manufacturers. 
 
1 - Run Embird and select "Ultimate Box+" menu (Picture No. 1).  

Picture No. 1  

   

2 - Ultimate Box window will appear on the screen (Picture No. 2). The Ultimate Box screen is divided into 
two main sections: 
 
The top portion of the screen is used to navigate folders on your computer and select designs. It is divided 
into three areas. The Folder Tree (top left, A) allows you to easily navigate to the folders on your computer. 
While browsing, double click on folder to open or close it. The full path of current folder is displayed above 
this panel. The File Browsing Panel (top middle, B) displays the files in the currently selected folder. You 
can filter the files displayed in the File Browsing Panel by selecting Mask in the box above this panel. Click on 
a file to select it and preview it in the Preview area (top right, C). Above this section is the main toolbar and 
menus. 
 
The bottom section of the screen is a Holding Area (D) for writing, reading and viewing designs on the 
embroidery card. At the bottom of the Holding Area is the status bar which shows you the amount of space 
used on the embroidery card and the amount remaining (E). 
 
Choose your card type in the top portion of the screen. In this example we are going to read the designs 
from the card compatible with Brother embroidery machines. Find the list of supported embroidery machines 
at http://www.vikant.de/kompatibel.htm.  
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Picture No. 2  

   

3 - Click the "Read from Card" button (Picture No. 3). 
 
Warning: All designs in the Holding Area are removed and replaced by the designs from the embroidery 
card. 

Picture No. 3 
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4 -  If required by the embroidery card, you are prompted for a design filename prefix. Modify this if desired 
and click "OK". Designs will use this prefix and be assigned sequential numbers (Picture No. 4).  

Picture No. 4 

  

5 -  The embroidery card is read and the designs are displayed in the Holding Area. This process may take 
up to 5 minutes (Picture No. 5).  

Picture No. 5 

   

6 - Use the Folder Tree to navigate to the desired folder. You can also create a new folder to store the 
designs using the "New Folder" tool bar button. After the destination folder is selected, click the "Copy to 
Folder" button (Picture No. 6). This will copy the selected design ("Design01.pes" in this example) to the 
chosen folder.  

Picture No. 6 
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Ultimate Box - Writing Designs to Card  

The Ultimate Box is a read/write device that transfers embroidery designs from the hard drive of your 
computer to a re-writable blank embroidery card that fits your Brother, Babylock, Bernina Deco, Simplicity, 
White and Viking/Husqvarna embroidery machines. The 2-slot Ultimate Box also supports the cards for Pfaff 
and Bernina Artista embroidery machines. The Ultimate Box writes up to 230.000 stitches to the 
Amazing/Magic and Brother 512 Kilobyte (4 Megabit) blank cards. The Ultimate Box writes over 450.000 
stitches to the Ultimate Card. It reads and saves designs back to the hard drive of your computer from the 
above cards and most pre-programmed design cards (except licensed design cards). The box connects with a 
cable to the USB port of your computer. More information about Ultimate Box available at 
http://www.vikant.net. 
 
Note: Ultimate Box is developed by Vikant Corporation. Vikant Corporation is not affiliated with any 
manufacturers mentioned here. All brand names and product names are trademarks and service marks of the 
respective manufacturers. 
 
1 - Run Embird and select "Ultimate Box+" menu (Picture No. 1).  

Picture No. 1  

   

2 - Ultimate Box window will appear on the screen (Picture No. 2). The Ultimate Box screen is divided into 
two main sections: 
 
The top portion of the screen is used to navigate folders on your computer and select designs. It is divided 
into three areas. The Folder Tree (top left, A) allows you to easily navigate to the folders on your computer. 
While browsing, double click on folder to open or close it. The full path of current folder is displayed above 
this panel. The File Browsing Panel (top middle, B) displays the files in the currently selected folder. You 
can filter the files displayed in the File Browsing Panel by selecting Mask in the box above this panel. Click on 
a file to select it and preview it in the Preview area (top right, C). Above this section is the main toolbar and 
menus. 
 
The bottom section of the screen is a Holding Area (D) for writing, reading and viewing designs on the 
embroidery card. At the bottom of the Holding Area is the status bar which shows you the amount of space 
used on the embroidery card and the amount remaining (E). 
 
Choose your card type in the top portion of the screen. In this example we will write card compatible with 
Brother embroidery machines. Find the list of supported embroidery machines at 
http://www.vikant.de/kompatibel.htm.  
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Picture No. 2  

   

3 - Use the Folder Tree to navigate to your embroidery designs folder. Select a design in the File Browsing 
Panel to preview it. To add designs to the Holding Area, click on the "Copy to Holding Area" button 
(Picture No. 3). 

Picture No. 3 
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4 -  When you have finished adding designs to the Holding Area, click the "Write to Card" action button. 
(Picture No. 4).  

Picture No. 4 

 

5 -  As a last reminder, the software will ask you to confirm the write procedure. Select "Yes". (Picture No. 5).  

Picture No. 5 

   

6 - The write operation will start (Picture No. 6). When write operation is complete, take the card out of 
reader/writer box, insert it into your sewing machine and start embroidering.  

Picture No. 6 
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 Uninstalling Embird  

This tutorial explains how to remove Embird program from your computer. 
 
1 - Close Embird in case you are running it. 
2 - Click "Start -> Programs -> Embird -> Uninstall Embird" menu in Windows (Picture No. 1). 

Picture No. 1  

   

3 -  Select "Remove" in the dialog box which appears on the screen (Picture No. 2).  

Picture No. 2  

   

4 - Another dialog box will appear (Picture No. 3), allowing you to back-up your passwords. Insert a 
formatted floppy disk into its drive, which is usually the A: drive and click "Back-up" button. Once the back-up 
process is finished, select "Close". 
 
Note: If you want to back-up your passwords to other disk media, e.g. to USB memory key, choose the drive 
containing this media in the "Back-up to drive:" box before you click the "Back-up" button.  
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Picture No. 3  

   

5 - Continue with the uninstall process by selecting "Yes" option (Picture No. 4). 

Picture No. 4 

   

6 - If you want to uninstall also plug-ins click "Yes" button (Picture No. 5). This option is displayed only for 
the CD version of Embird. The internet version does not offer the option of uninstalling plug-ins, but you can 
remove them manually by deleting the "C:\Program Files\EMBIRD32\PLUGINS" folder (or the 
"C:\EMBIRD32\PLUGINS" folder if you are using version prior to Embird 2006) once the uninstall process is 
finished.  

Picture No. 5 

   

7 - When the uninstall process is complete, the information message is displayed. Click "OK" button (Picture 
No. 6). Sometimes it might happen, that the restart of Windows is requested by uninstall program - 
depending on the settings of Iconizer plug-in.  

Picture No. 6  

 

Note: Although you uninstall Embird from your PC, the "C:\Program Files\EMBIRD32" folder (or 
"C:\EMBIRD32" folder if you are using version prior to Embird 2006) might remain on the hard disk, 
containing only several configuration files which are used when you install newer version. In case you do not 
plan to install newer version of Embird, you can manually delete the "EMBIRD32" folder from your hard disk, 
e.g. in Windows Explorer or in some other file manager. 
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View History  

The "View History" function in Manager’s "Middle Panel" menu displays a list of recently displayed designs, 
which is useful if you want to display a design again but cannot remember its name or location. Capacity of 
the history list is 200 designs. 

Follow these steps to find out how to view the history list:  

1 - Run Embird, it will start in "Manager" mode.  
2 - Select "Middle Panel -> View History" menu (Picture No. 1).  

Picture No. 1  

 

3 - The list of recently displayed designs will appear on the middle panel (Picture No. 2).  

Picture No. 2  
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4 - In case you are a registered user of the Iconizer plug-in and you want to see also the icons in the history 
list, click "Right Panel -> Preview Files" menu to set this option ON (Picture No. 3). 

Picture No. 3 

 

5 - Double click the filename of the design in the history list if you want to display it again (Picture No. 4). 
You can also right click the filename for popup menu with other commands.  

Picture No. 4 

 

6 - Embird will display the chosen file (Picture No. 5).  
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Picture No. 5 

 

Note: Embird stores the history list in the "embird_history.txt" file in the temporary folder for currently 
logged on user, e.g. into "C:\Documents and Settings\Administrator\Local Settings\Temp\embird_history.txt" 
(or in "C:\EMBIRD32\HISTORY.TXT" file if you use version prior to Embird 2006). You can delete this file 
manually (e.g. in Windows Explorer) if you want to clear the history list, or select the "Middle Panel -> Clear 
History" menu in Embird. 
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View Tree    

The following tutorial explains how to use the "View Tree" feature in Embird 2006 or later. 

1 - Run Embird, it will start in "Manager" mode.  
2 - In the "Folder:" box at the right side of the screen choose the folder which contents will be displayed in 
the tree (Picture No. 1). Embird will scan this folder and all its subfolders for files, taking also the "Filter:" 
setting into consideration. In this example, Embird will display in the tree all .DST files stored in "C:\Program 
Files\EMBIRD32" folder and its subfolders.  
3 - Click "Right Panel -> View Tree" menu to switch ON the displaying of the tree on the middle panel (Picture 
No. 1). 

Picture No. 1  

 

4 - Embird will scan the folder and after a while the tree appears on the screen (Picture No. 2). The 
advantage of displaying files in the tree is that you can see the contents of several folders at once - in this 
example there is contents of the "C:\Program Files\EMBIRD32\FILES" folder and also the contents of 
"C:\Program Files\EMBIRD32\NEW" folder displayed at the same time. In case you are a registered user of 
Iconizer plug-in, and the "Right Panel -> Preview Files" option is ON, the design icons will appear also in the 
tree, as shown in Picture No. 2 below. The "Print" and "Export" buttons located below the tree allows you to 
print the tree, or export it to .BMP or .JPG file. 
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Picture No. 2 

 

5 - You can click the left mouse button on the filename in the tree to focus it at the right panel 
(Picture No. 3). 
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Picture No. 3 

 

6 - You can click the right mouse button on the filename in the tree to display the popup menu with 
commands (Picture No. 4). 

Picture No. 4 
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 Viewing Designs 

1 - Run Embird.  
2 - In the "Files:" box at the right side of the screen select the design which you want to display. To select the 
design, please move mouse pointer to its file name and click the left mouse button.  
3 - Click the "View File" button to display the design (Picture No. 1). It is also possible to display the design by 
double-clicking on its file name in the "Files:" box.  

Picture No. 1  

   

4 - Click the "View Color Layers" button if you want to see the color layers of the design (Picture No. 2).  

Picture No. 2  

   

5 - The color layers of the design will be displayed on the middle panel of Manager window. Move mouse 
pointer to some color layer if you want to find out more details about it. After a while, a yellow hint will popup 
on the screen, showing the color layer properties (Picture  No. 3).  
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Picture No. 3  

 

6 - Click the "View Thread List" button to see the list of threads used by the design (Picture No. 4). 

Picture No. 4 

 

7 - The "Thread List" window will appear on the screen, showing the list of threads used by design. You can 
see the design color, the closest thread color, thread consumption, color name and the catalog number of the 
thread (Picture No. 5). The "Catalog:" box at the bottom of the window allows you to choose your thread 
chart. Double-click the left mouse button on the cell in "Mark" column to mark the corresponding thread. This 
way you can mark those designs which you actually have in stock. Then, if you turn ON the "Marked Only" 
switch (located at the bottom of the window in Picture No. 5), only the threads with "Mark" attribute will be 
taken into consideration when assembling the thread list. Click "OK" button to close the thread list window.  
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Picture No. 5 

 

8 - Click "View Thumbnails" button to display the thumbnails of multiple selected designs (Picture No. 6). To 
select multiple designs, please move mouse pointer to the file name of the first design in the "Files:" box at 
the right side of the screen, depress the left mouse button and hold it down while moving the mouse pointer 
over the file names of the other designs. When the mouse pointer is over the last design, please release the 
left mouse button.  

Picture No. 6 

 

9 - Click "View Dense Thumbnails" button to display the dense thumbnails of multiple selected designs 
(Picture No. 7). 
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Picture No. 7 
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Viewing Images in Embird  

This tutorial explains how to view images (e.g. digital photos) in Embird. Supported image formats are: BMP, 
GIF, JPG, PCX, PNG, PSD, TGA and TIF. The steps described in this tutorial work not only with images, but 
also with designs. 

1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen double-click the file name of the image which you want 
to display. Move mouse pointer to the image file name and then double-click the left mouse button. In this 
example, the filename of the image is "Slovakia1.jpg" (Picture No. 1).   

Note: The image scale is chosen according to settings in "Options -> Image Scale" sub-menu. There are the 
following settings available: "Actual Size", "Auto-Shrink to Fit", "Auto-Enlarge to Fit".  

Tip: The "Space" key will display the next file and the "Backspace" key will display the previous file in "Files:" 
box at Right Panel.  

Picture No. 1  

 

  

3 - You can also view the "Thumbnails" and the "Dense Thumbnails" of multiple selected images (Picture No. 
2). To select multiple image files, please move mouse pointer to the file name of the first image file in the 
"Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving the 
mouse pointer over the file names of the other images. When the mouse pointer is over the last image, 
please release the left mouse button. Once the files are selected, choose "View Thumbnails" (or "View Dense 
Thumbnails") command from "Right Panel" menu.  
4 - When the images are displayed as thumbnails, the "browse" buttons (i.e. "Home", "End", "Up", "Down") 
appear at the bottom of the middle panel. Use these buttons to scroll to next or previous page of thumbnails, 
or to print the actual page of thumbnails.  
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Picture No. 2  

   

5 - You can also open an image in special Viewer window, which offers also some editing functions. To open 
the file in Viewer window, select it in "Files:" box at Right Panel and then choose "Open in Viewer" command 
in "Right Panel" menu (Picture No. 3). 

Picture No. 3 

 

6 - Another way of opening a file in Viewer window is to double-click on its displayed image (Picture No. 1). 
You can also select multiple files, view them as thumbnails, and then double-click on any thumbnail to open 
these files in the Viewer window (Picture No. 4).  
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Picture No. 4 

   

In Viewer window you can do the following: 
 
- Display first image or design (press Home key) 
- Display last image or design (press End key) 
- Display previous image or design (press Page Up key, or Backspace) 
- Display next image or design (press Page Down key, or Space) 
- Start Slideshow (press S key, each image will be displayed 5 seconds) 
- Display the image or design using Full Screen mode (press F key) 
- Print image or design (press P key) 
- Delete image or design (press Delete key) 
- Rename image or design (press N key) 
- Show File List (press L key) 
- Close Viewer window and view the last selected file in Manager (press V key) 
- Close Viewer window (press ESC key) 
 
The following commands in Viewer window do not work with designs, only with images: 
 
- Zoom In (press numpad + key) 
- Zoom Out (press numpad - key) 
- Zoom 1:1 (press Enter key) 
- Actual Size (press numpad /) 
- Auto-Shrink to Fit (press Ctrl and numpad -, the Actual Size must be off) 
- Auto-Enlarge to Fit (press Ctrl and numpad +, the Actual Size must be off) 
- Desktop Wallpaper (press D key) 
- Rotate and Mirror (press R key) 
- Set Size (press W or H key) 
- Convert image to B&W, grayscale, or to 16- and 256-colors (press Insert key) 
- Crop image (press C key). First select an area to crop by depressing the right mouse button and drawing a 
rectangle. Another way is to hold down the Ctrl key, depress left mouse button and draw a rectangle. Last 
way is to double-click on image and specify the rectangle size in the dialog box which appears on screen. 
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Writing Designs to Floppy Disks  

Embird supports standard and non-standard floppy disk formats.  
 
Standard floppy disks are disks with designs stored in standard MS-DOS format. These disks are recognized 
and can be accessed in Windows Explorer, common file manager or any other application supporting floppy 
disks. In Embird you can access standard floppy disk by choosing the disk drive (typically "A:") in "Drive:" box 
in Right Panel of Manager window. 
 
Non-standard floppy disks are disks with designs stored in special format. These disks are not recognized 
and cannot be accessed in Windows Explorer or in common file manager - these applications report "Disk is 
not formatted" error when you attempt to read floppy disk contents. In Embird you can access non-standard 
floppy disks via Left Panel menu of Manager window. However, the non-standard floppy disk formats require 
low-level access and therefore the non-standard floppy disks are supported only when running Embird in 
Windows 98 or Windows ME. Embird does not support non-standard floppy disks when running in Windows 
NT, 2000 or XP. 
 
Writing Designs to Standard Floppy Disks (MS-DOS Format) 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Insert the floppy disk into the disk drive. Make sure, that the disk is not write-protected.  
3 - In the "Files:" box at the right side of the screen select the design which you want to write to the floppy 
disk. To select a design, please move the mouse pointer to its file name and click the left mouse button 
(Picture No. 1). 
 
Note: You can select multiple files and write them all to the floppy disk at once. Please move mouse pointer 
to the file name of the first design in the "Files:" box at the right side of the screen, depress the left mouse 
button and hold it down while moving the mouse pointer over the file names of the other designs. When the 
mouse pointer is over the last design, please release the left mouse button.  

Picture No. 1  

 

4 - Move mouse pointer to the "Files:" box in right panel and click right mouse button for popup menu. 
Choose "Copy Files to Clipboard" command to copy selected designs to the clipboard. You will find this 
command also in "Right Panel" menu (Picture No. 2).  
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Picture No. 2  

 

5 - Choose floppy disk drive in the right panel in "Drive:" box (Picture No. 3).  

Picture No. 3  

 

6 - Move mouse pointer to the "Files" box in right panel and click right mouse button for popup menu. Choose 
"Paste Designs from Clipboard" command to copy the files from floppy disk to hard disk. You will find this 
command also in "Right Panel" menu (Picture No. 4).  
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Picture No. 4  

 

7 - Embird will paste the files to the chosen drive and folder - in this example, the files will be written to the 
root of "A:" drive. 
 
Writing Designs to Non-Standard Floppy Disks (e.g. Barudan, ZSK) 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - Insert the formatted floppy disk into the disk drive. Make sure, that the disk is not write-protected. 
3 - In the "Files:" box at the right side of the screen select the design which you want to write to the floppy 
disk. To select a design, please move the mouse pointer to its file name and click the left mouse button. You 
can select multiple files and write them all to the floppy disk at once.  
4 - Move mouse pointer to the "Files:" box in right panel and click right mouse button for popup menu. 
Choose "Input/Output Operations -> Copy Files to Floppy Disk" command. You will find this command also in 
"Right Panel" menu (Picture No. 5).  

Picture No. 5  
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5 - Choose floppy disk format in the dialog box which appears on the screen (Picture No. 6). Click "OK" button 
to continue. 
 
Note: The floppy disk must be formatted with chosen format before you start writing designs to it - please 
see also tutorial Formatting Floppy Disk.  

Picture No. 6  

 

6 - You will be prompted to insert the formatted disk into drive (Picture No. 7). Click "OK" button to continue. 

Picture No. 7 

 

7 - The writing process will start. Wait until this process is finished. 
8 - Once the writing is finished, a dialog box will appear on the screen, showing the result of the operation. 
You will see the files saved on the floppy disk in the left panel in "Files:" box (Picture No. 8).  

Picture No. 8 

 

9 - Floppy disk is now ready for use. You can eject it from the disk drive and use it with your embroidery 
machine. 
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Writing Designs to USB Stick  

This tutorial explains how to write designs to general USB flash memory stick, which works like another disk 
drive on your PC (e.g. drive E:). 
 
1 - Run Embird, it will start in "Manager" mode. 
2 - In the "Files:" box at the right side of the screen select the design which you want to write to USB stick. 
To select a design, please move the mouse pointer to its file name and click the left mouse button 
(Picture No. 1). You can select multiple files: Move mouse pointer to the file name of the first design in the 
"Files:" box at the right side of the screen, depress the left mouse button and hold it down while moving the 
mouse pointer over the file names of the other designs. When the mouse pointer is over the last design, 
please release the left mouse button.  

Picture No. 1  

   

3 - Select "Right Panel -> Input/Output Operations -> USB Stick" command from the main menu (Picture 
No. 2).  

Picture No. 2  
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4 - A dialog box will appear on the screen (Picture No. 3). Choose the "Drive:" which contains USB stick. In 
this example it is "E:" drive. The upper box shows the folders and files of  USB stick.  
5 - Click "Create new folder" button to create a new folder for the designs and choose this folder in the 
"Folder" box. In this example we have created "Designs" folder (Picture No. 3). 
6 - The bottom box shows the files which you are going to write to the card (Picture No. 3). Click "Write files 
to card" button to start writing of designs to the card. 

Picture No. 3 

 

7 - Embird will ask you about the target format for the files being written (Picture No. 4). Designs will be 
converted 'on-the-fly' to this format and then written to selected folder on the USB stick. In this example, we 
have chosen "Janome .JEF" format. Click "OK" button to continue.  

Picture No. 4 
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8 - Another dialog box will appear on the screen, inquiring whether you want to save to USB stick also the 
Embird color palette for each design (Picture No. 5). This color palette is stored in separate file with .EDR 
extension. Click "Yes" button if you want to save the color palette, because some file formats offer only 
limited color palette and if you don't save the real palette along the design, it might happen that the next 
time you will display this design from the USB stick it will have a little bit different colors. 

Picture No. 5 

 

9 - Embird will write the designs to the USB stick and it will display the result of this operation (Picture No. 6). 
In this example, the "ROSE2.jef", "ROSE3.jef" and "ROSE5.jef" designs were written to the card. The 
corresponding files with .EDR extension contain the Embird color palette for these designs. 

Picture No. 6 
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Writing Floppy Disk for Viking Designer 1    

The following tutorial explains how to write floppy disks for Viking Designer 1 embroidery machine in Embird. 
Before you start using floppy disks written in Embird with Designer 1 machine, make sure that the machine 
has the latest firmware. If not, download and install the update from 
http://www.husqvarnaviking.com/us/3190_6597.htm. Older firmware does not accept designs stored on 
floppy disks which were created in Embird. 

1 - Run Embird, it will start in "Manager" mode.  
2 - In the "Files:" box at the right side of the screen select the design which you want to write to floppy disk. 
To select a design, please move the mouse pointer to its file name and click the left mouse button (Picture 
No. 1).  
 
Note: You can select multiple files and write them to floppy disk at once. To select multiple designs, please 
move mouse pointer to the file name of the first design in the "Files:" box at the right side of the screen, 
depress the left mouse button and hold it down while moving the mouse pointer over the file names of the 
other designs. When the mouse pointer is over the last design, please release the left mouse button.  

Picture No. 1  

 

3 - Click "Right Panel -> Input/Output Operations -> Create Designer 1 Disk" menu to create Designer 1 
floppy disk contents of selected designs (Picture No. 2). 

Picture No. 2 
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4 - Embird will ask you to insert blank formatted 2HD (standard) floppy disk into disk drive "A:" (Picture No. 
3). Click "OK" button to continue with writing designs to the disk.  
 
Tip: Click "Retry" button instead if you want to format the floppy disk before writing designs (Picture No. 3). 
This will display standard Windows dialog box for formatting disks. 

Picture No. 3 

 

5 - Choose the menu into which the designs will be written (Picture No. 4). You can choose either "Menu 1", 
"Menu 2", "Menu 3" and "Menu 4", or let Embird write the designs to the first free menu on the floppy disk. 
 
Warning: If you have already written some designs to Designer 1 floppy disk in Embird, you can use this 
disk again (without formatting or erasing its contents) and Embird will add selected designs to existing 
designs to chosen menu on this floppy disk. However, do not add designs to floppy disks written in other 
software - always format or erase these disks before using them in Embird. 

Picture No. 4 

 

6 - It will take some time to write all selected designs to the floppy disk. The blue bar below the middle panel 
shows the progress of the writing process (Picture No. 5). 

Picture No. 5 

 

7 - When the operation is finished, Embird will display the results of the writing process (Picture No. 6).  

Picture No. 6 
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Writing USB Memory Stick for Viking Designer 1    

The following tutorial explains how to write USB memory sticks for Viking Designer 1 embroidery machine in 
Embird. Before you start using USB memory sticks written in Embird with Designer 1 machine, make sure that 
the machine has the latest firmware. If not, download and install the update from 
http://www.husqvarnaviking.com/us/3190_6597.htm. Older firmware does not accept designs stored on 
memory sticks which were created in Embird. 

1 - Run Embird, it will start in "Manager" mode.  
2 - In the "Files:" box at the right side of the screen select the design which you want to write to USB 
memory stick. To select a design, please move the mouse pointer to its file name and click the left mouse 
button (Picture No. 1).  
 
Note: You can select multiple files and write them to USB memory stick at once. To select multiple designs, 
please move mouse pointer to the file name of the first design in the "Files:" box at the right side of the 
screen, depress the left mouse button and hold it down while moving the mouse pointer over the file names 
of the other designs. When the mouse pointer is over the last design, please release the left mouse button.  

Picture No. 1  

 

3 - Click "Right Panel -> Input/Output Operations -> Create Designer 1 USB Medium" menu to create 
Designer 1 USB memory stick contents of selected designs (Picture No. 2). 
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Picture No. 2 

 

4 -  After a short while (depending on the current contents of USB memory stick), a new dialog box will 
appear on the screen (Picture No. 3). Choose the drive containing the USB memory stick using "Drive:" box. 
In this example, it is "E:" drive, which contains the empty USB memory stick. In case your USB memory is 
not empty, continue with step 5, otherwise click "Format medium" button to create empty VFD.BIN and 
VFD00.BIN ~ VFD11.BIN files, which are used for storing .SHV designs. Embird will warn you that the 
formatting will delete the current contents of VFD files, click "Yes" button to continue (Picture No. 4). 

Picture No. 3 
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Picture No. 4 

 

5 - Embird will read the contents of all VFD files from USB memory stick and it will temporarily unpack their 
contents into the "Temp_D1_USB" folder on your hard disk (Picture No. 5). Choose some of the disks 
"Disk01" ~ "Disk12" in the "Folder" box, this disk will be used for storing new designs. You can choose the 
disk by double-clicking its name under "Temp_D1_USB" folder. 

Picture No. 5 

 

6 - In this example, we have selected "Disk01" for storing designs (Picture No. 6). Click "Write files to 
selected disk" button to start writing .SHV designs on Disk01. 
 
Tip 1: Click "Erase contents of selected disk" button if you want to delete all designs stored on Disk01. 
 
Tip 2: If you want to read existing .SHV files from the Disk01, select the menu with these designs (double-
click either "MENU_01", "MENU_02", "MENU_03" or "MENU_04" folder under Disk01 in the "Folder:" box), 
then select the .SHV files in "Files:" box and finally click "Read selected files from disk" button. Files will be 
converted to chosen format and saved into currently chosen folder at right panel in Embird Manager. 
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Picture No. 6 

 

7 - Choose the menu into which the designs will be written (Picture No. 7). You can choose either "Menu 1", 
"Menu 2", "Menu 3" and "Menu 4", or let Embird write the designs to the first free menu on the chosen disk 
of USB memory stick. 

Picture No. 7 

 

8 - It will take some time to write all selected designs to the USB memory stick. When the operation is 
finished, Embird will display the results of the writing process (Picture No. 8). 

Picture No. 8 

 


