FAQ - Frequently Asked Questions

See also Tasks - How do I... ?

If you have a question, let us know it at embird@embird.net. Others probably have the same question and it needs to be answered.

Where can I download the most recent version, plug-ins and tutorials?

- At http://www.embird.net/sw/embird/down.htm

May I use Embird on multiple computers?

- You may use Embird on a single computer, but may transfer it to another computer as long as the other computer is owned by you and as long as it is used on only one computer at a time. You may NOT lend, lease, rent, sub-license or otherwise distribute any portion of Embird. You may not translate, reverse program, disassemble or decompile Embird.

How to insert the password into Embird:

- Save the PASSWORD file from attachment of Embird registration e-mail into the folder, where Embird application is installed (typically it is C:\Program Files\EMBIRD32 folder or C:\EMBIRD32 folder). Then run Embird and check, whether your name is displayed in the blue bar at the top of Manager window (in application title).

How can I manually insert the password into Embird?

- Run Embird. When Embird starts, it will warn you that your copy is not registered and that it is going to expire in 30 days. Then it will ask you if you want to register right now. Choose "Yes" and type your password into the box that appears on the screen. Another way of invoking registration box is to select "Registration" command from "Help" menu. This will display a window containing the box where you can type in the password. Press “OK” button when you are finished with entering password. If you have entered the correct password, Embird will start and you will see your name in the blue bar at the top of window (in application title)

When I enter the registration password, it says "Invalid password". I have checked and tried it numerous times making sure the letters are the right case.

- Please use CLIPBOARD for transfer of the password from e-mail into Embird. Select password in e-mail by dragging mouse cursor over the password (push the left mouse button while dragging). Selected text should be highlighted now. Push “Ctrl“ and “C” buttons simultaneously. Password is now taken into clipboard. Start Embird and initialize registration, put the cursor in the box for password and push “Ctrl” and “V” buttons simultaneously. Password will appear in the box. Finally, click “OK” button to register.

How to enter password into Embird plug-in Alphabet ?

- Run Embird and click “Editor” menu to switch to Editor window. Then select “Insert -> Text" menu. The “Insert Text” dialog box will appear on the screen. Choose the appropriate Alphabet in the “Plug-ins:” box. Then, in case this alphabet is not registered yet, it will ask you for the plug-in registration number. Type in your number and click “OK” button. You will see that all characters are enabled now, whereas in unregistered plug-in only the A, B and C characters are enabled.

Does Embird convert designs from one format to another?

- Yes. Read Tasks - How do I...? topic to find out more about converting designs.

I am having a problem with splitting designs with Embird Editor. Are there any specific directions available?

- Please read Tasks - How do I...? topic to find out more about splitting designs.

I edited a file and when I try to save it I get an error message "Cannot create the file - Design does not fit within the embroidery field". The size is not too large for my machine's hoop.

- Edited design is probably not centered in hoop. Even if design size is only 2.50" x 2.50", it may be too large for machine with 3.94" x 3.94" hoop size if it is not centered (there is only 3.94" / 2 = 1.97" space available for each direction if measured from center of hoop). Please try to center design in hoop.

All my designs are displayed as if they were rotated by 90 degrees in Manager, but they appear to be normal in Editor. Is there something wrong with my installation of Embird?

- No. Just uncheck the “Exchange X and Y Axis” option in “Options “ menu in Manager.

Some designs are displayed with gaps in Manager,  but I am sure there are no gaps but stitches covering the whole area. Is there something wrong with my installation of Embird?

- No. Probably there are wide areas in the design, which are covered by series of jump (floating) stitches instead of running stitches. Try to turn ON the “Show Floating Stitches” option in “Options” menu in Manager to make these stitches visible.

The designs are not displayed in scale on my display, I have checked that the “Options -> Scale 1:1” option is ON. Is there something wrong with my installation of Embird?

- No. You probably must calibrate the display in “Options -> Display Calibration” menu.

When I print a template, the stitches are not printed correctly and only some small circle appear  instead. Is there something wrong with my installation of Embird?

- No. Just uncheck the “Print Stitch Points Only” option in “Options” menu in Manager.

I cannot export images to .JPG format.

- Exporting images to .JPG file format is successful only if Windows display setting is "High Color (16 bit)" or "True Color (24 bit)". Otherwise you may export images to .BMP format only.

Does Embird support Melco SS (Normal) disk format?

- Embird shows Melco .CND files on a diskette, but cannot view, print, convert or edit condensed files. You may, however, move them from your floppy disk to your hard drive and vice versa. Please note that you must install floppy disk controller (FDC) with FM modulation support to your computer if you want to process Melco SS disks (see also System Requirements).

I receive "Not enough free conventional memory!" error message when starting Embird.

- Embird software requires 96kB of free conventional memory. Conventional memory is block of first 640kB of memory. Please free as much of conventional memory as possible. Usually this memory is occupied by old real-mode drivers, which are loaded in CONFIG.SYS or AUTOEXEC.BAT file. You may use MS-DOS MEMMAKER.EXE program for optimization of conventional memory use.

-How to install Embird Alphabet plug-in?

- Download installation file of an alphabet plug-in fromhttp://www.embird.net/sw/embird/down.htm and save it somewhere to your hard disk (save it for example into the “C:\My Documents” folder). Then run this downloaded installation file in Windows: Select “Start -> Run ->Browse ->C:\My Documents\{installation file of alphabet plug-in} -> OK” and allow the installer to unzip its contents into the Embird application folder (typically it is C:\Program Files\EMBIRD32 folder or C:\EMBIRD32 folder).

-How to install Embird Tutorial plug-in?

- Download installation files of all tutorials from http://www.embird.net/sw/embird/down.htm and save them somewhere to your hard disk (save them for example into the “C:\My Documents” folder). Then run each downloaded installation file in Windows: Select “Start -> Run ->Browse ->C:\My Documents\{installation file of tutorial plug-in} -> OK” and allow the installer to unzip its contents into the Embird application folder (typically it is C:\Program Files\EMBIRD32 folder or C:\EMBIRD32 folder).

-How to install Embird Studio plug-in?

- Download installation file of Embird Studio plug-in from http://www.embird.net/sw/embird/down.htm and save it somewhere to your hard disk (save it for example into the “C:\My Documents” folder). Then run this downloaded installation file in Windows: Select “Start -> Run ->Browse ->C:\My Documents\{installation file of Studio plug-in} -> OK” and allow the installer to unzip its contents into the Embird application folder (typically it is C:\Program Files\EMBIRD32 folder or C:\EMBIRD32 folder).

-I have uninstalled my old Embird and I have installed new version of Embird. My Iconizer is not showing the pictures in the new Embird like in the old version. I have my registration number but don't know how to get the pictures.

- Your Iconizer is not enabled. Visit our tutorial at http://www.embird.net/sw/embird/tutorial/iconizer.htm to see how to enable/disable it.

-How to install Embird on the new/another computer?

- Please note, that if you just copy the contents of Embird application folder from the old computer to the new computer, then the copied Embird would not be working correctly! Embird (as almost every other program running in Windows) must be installed to run properly. To install Embird to the new computer you need to transfer the installation files of Embird and plug-ins to the new computer.

In case your new computer is connected to the Internet, you can download all installation files fromhttp://www.embird.net/sw/embird/down.htm.

In case your computer is not connected to the Internet, you must download the installation files using another computer, and then transfer these files to the new computer using either the CD, DVD, USB memory key or the floppy disks.

Once the installation file is saved somewhere on the new computer, run it in Windows and allow it to install Embird into the C:\Program Files\EMBIRD32 folder (or C:\EMBIRD32 folder). Then download and transfer also the installation files of all plug-ins and install them as well. After installing all files, please copy the PASSWORD file containing your passwords into the C:\Program Files\EMBIRD32 folder (or C:\EMBIRD32 folder). Run Embird and check whether your name appears in the blue bar on the top in Manager (not displayed in Editor) or not. If yes, Embird has inserted password and is registered full functional program. Select “Help -> Installed-Plug-Ins” and check whether you have installed and registered all plug-ins (registered plug-ins have numbers in line - if not, write them now).

-I have inserted my password into Embird, but Embird still runs in demo mode.

- Please check following:

1. Whether the password file has PASSWORD name. Some browser may change the name of file in attachment of email. In case the file name is different, please rename it to PASSWORD.

2. Whether you have saved the PASSWORD file into the Embird application folder (typically it is C:\Program Files\EMBIRD32 folder or C:\EMBIRD32 folder).

Registered full functional Embird displays the user name in the blue bar on the top of Manager window. The user name is not displayed in Editor window, only in Manager.

-I want to insert password for alphabet, but I am not able to find alphabet in Editor. The message " No Plug-in Found" appears instead of alphabet.

- You have not installed the alphabet plug-in yet. Download the installation file of an alphabet plug-in from http://www.embird.net/sw/embird/down.htm and save it somewhere to your hard disk. Then start this file in Windows and allow the installer to unzip its contents into the Embird application folder (default folder is C:\Program Files\EMBIRD32 or C:\EMBIRD32.)

To check which plug-ins are installed and registered select “Help ->Installed Plug-Ins” menu in Embird. Registered plug-ins have numbers in-line.

-Embird will not install on my computer, although I downloaded it several times. I tried to close the anti-virus software, install in Safe Mode of Windows, but it still does not work. The previous version worked without problems.

- Follow these steps:

1. Check whether the previous version of Embird was uninstalled. Click on "Start -> Programs -> Embird -> Uninstall Embird" command to remove the previous version. Restart the computer if necessary.

2. Manually delete the “C:\Program Files\EMBIRD32” folder (or “C:\EMBIRD32” folder). Before you delete this folder, make sure it does not contain any of your designs.

3. Run installation file of Embird. You must agree with license agreement if you want to continue with installation. Then the INSTALL button will be enabled and you can click it to start the setup process.

4. When the copying of files to hard disk is finished, a dialog box will appear on the screen, allowing you to change the settings of Iconizer plug-in.

5. Choose "None - Embird should not handle any of supported file types." in the dialog box and hit “OK” button to finish the setup process.

6. Run Embird and click on "Options -> Iconizer Settings" if you want to enable the Iconizer plug-in.

-After installing Iconizer plug-in, I lost the ability to double click on a file and have it open in associated software. The double clicking on the design always opens in Embird. How can I retain the ability to double click and have the design open in the respective software as before Iconizer?

-There are 2 solutions possible:

First solution: Disable “double-click-open” feature for the extension which you do want to be handled by other software than Embird. Run Embird, click on “Options -> Iconizer Settings” menu and uncheck the extension in the upper list in the dialog box which appears on the screen.

Second solution: Let the double click open the design in Embird, but once Embird is launched hit “CTRL + O” key. This will launch the software which was associated with the file extension before installing Iconizer.

-I have resized the design in Embird Editor and some of the connections are now running stitches, but in the original design there were jumps. What am I doing wrong?

- In some designs, there are connection stitches between objects (between letters for example). Connection stitch may be real jump or just longer single running stitch that is easy to cut off. However, the code for jump is different from the code for running stitch. Although short jump looks quite like running stitch on real embroidery, it is not the same code in design. In Embird Editor, the real jump stitches are shown as dotted line. In Embird Manager are real jumps invisible by default, but they can be set visible (in Options menu). Digitizers use real jumps for longer connections and running stitches for short connections that are supposed to be not cut off. When you enlarge a design, connections become longer. If there was a real jump, it should remain real jump even after enlargement. However, if connection was just a running stitch, program may split this stitch into several shorter running stitches that are not so easy to cut off. The reason for it is that program cannot distinguish between running stitch connections and thin outlines. Program must re-stitch the underlay stitches, the outlines and it also re-stitches the running stitch connections.

There is a way how to switch off the re-stitching of outlines (and running stitch connections). In Embird Editor, click "Options -> Stitch Density" menu and set the "Specify stitch length for outlines and underlays" option to OFF.

-I have installed Embird and all parts of Embird Tutorial plug-in. I can't activate the tutorial through the Help menu, nor by using the F5 key:

- Your internet browser is probably not associated with files which have the .HTM extension. Try the following:

1. Find “C:\Program Files\EMBIRD32\PLUGINS\TUTORIAL\INDEX.HTM” file (or “C:\EMBIRD32\PLUGINS\TUTORIAL\INDEX.HTM”) in Windows Explorer: Select “Start -> Programs -> Windows Explorer” and browse to the “C:\Program Files\EMBIRD32\PLUGINS\TUTORIAL” folder (or to “C:\EMBIRD32\PLUGINS\TUTORIAL” folder).

2. Click left mouse button on the “INDEX.HTM” file. Menu containing the "Open With" command will pop-up on the screen. Select this command from the menu.

3. The "Choose the program you want to use" dialog box will appear on the screen. Select your default internet browser (Netscape, MS Internet Explorer, Opera, etc.) and then click “OK” button.

4. Open Embird and activate the tutorial through the “Help” menu or using the F5 key.

- Files in .JEF format are not visible on my embroidery machine. It seems that the FlashCard is empty.

- All .JEF files must be stored in the Emb_file folder on the FlashCard. You can create Emb_file folder e.g. in Windows Explorer.

-I was able to split a design in Embird Editor, however, I cannot figure how to select more than one object and "join" them together. I cannot even get the "Join" button to highlight and I cannot get the "Align" button to highlight so I cannot figure out how to align objects.

- If you want to select more than one object, hold down “Ctrl” or “Shift” key when you click on the object. The “Join” and “Split” buttons are highlighted only if there are two and more objects selected.

-I reduced the size of the design and now it has more stitches.

- Even if you shrink the design, the stitch count might arise, because of the Adjust stitch density when resizing option in Editor's Options > Stitch Density dialog box. In case this option is ON, Embird will adjust the density of stitches to the values specified in Column Stitches Density and Fill Stitches Density boxes. Either switch OFF this option, or specify bigger values of density settings to obtain a design with less stitches after its shrinking.

-I opened a .DST design and the colors are all funny.

- The .DST designs (and also some others, e.g. .EXP) do not contain color information, only the stitches and "stop code" which means "change thread" for the embroidery machine. However, because these designs do not carry the true colors with them, Embird uses default color palette when displaying these designs. You can modify these colors and save the new color palette to special .EDR file, as explained in Color Palette Menu.

-I converted a .HUS to a .PCS, and Embird combined some design colors.

- Some formats allow only limited color palette, for example, .PCS format allows to store only 16 different colors, whereas .HUS format allows to store colors from palette containing 29 colors. Therefore it might happen that some colors are replaced with other (close) colors during the conversion to format with limited color palette. Find more information about color limits in File Formats, Available Hoops and Limits.

-I sorted all the colors to reduce the jumps, and now the design doesn't look right.

- Use Smart Color Sort command instead of Sort Colors command. Although it runs slower, it sorts colors smartly and therefore it does not allow to bring some color layer from beneath up to the top of design, which might mess the whole design up.